Авторское предисловие к Договору

Даже в тяжёлые для России годы общественного переустройства фирма Visual Solutions Inc уделяла не мало внимания российским пользователям своего программного продукта. На протяжении продолжительного времени в России действует уникальная схема распространения программы VisSim на бесплатной основе для академических пользователей. В немалой степени она способствовала обновлению учебного процесса в вузах России. Я был приятно удивлен, когда получил официальный запрос лично от президента фирмы Питера Дарнелла с просьбой о возможности включения данного моего произведения в дистрибутивный пакет программы VisSim для русскоговорящих пользователей, без нарушения выбранной для него стратегии распространения. Строго говоря, фирма имела право сделать это молча, но предпочла официально попросить. Именно по этим причинам я принял решение публично передать фирме Visual Solutions Inc Почетное право распространять мое произведение.

Клиначёв Николай Васильевич

Договор передачи Почетного права распространения авторского произведения

22 января 2004 года Клиначёв Николай Васильевич (далее Автор), с одной стороны, и фирма Visual Solutions Inc в лице президента фирмы Питера Дарнелла (Peter Darnell), с другой стороны, заключили договор о нижеследующем:

Предмет договора

Предметом договора являются соглашения о распространении произведения Автора: "Теория систем автоматического регулирования: Учебно-методический комплекс" (файл tau_knv.chm). Регистрационный номер в реестре Роспатента 2003612643. Далее Произведение.

Соглашения, закрепленные договором

  1. Договор не может ущемить ни одного из прав Автора на собственное Произведение.
  2. Автор передает фирме Visual Solutions Inc право распространения своего Произведения совместно с производимой фирмой программой VisSim.
  3. Автор сохраняет за собой право независимого распространения своего Произведения.
  4. Фирма Visual Solutions Inc обязуется распространять Произведение Автора на правах "Свободной информации" и не ущемлять следующих прав пользователей:
    • Право запускать Произведение в любых целях.
    • Право изучать работу документа (Произведения) и адаптировать его собственным нуждам.
    • Право распространять копии Произведения1.
    • Право улучшать Произведение и публиковать версии на правах "Свободной информации".
  5. Договор вступает в силу с момента опубликования Автором версии Произведения, содержащей текст договора и имеющей цифровую подпись2 Автора.

1) Право пользователя распространять копии Произведения (т.е. право распространять файл tau_knv.chm) не включает в себя право распространять копии программы VisSim. Незаконное распространение, или копирование программы VisSim запрещено.

2) Публичный ключ Автора (файл KNV.ASC) можно найти в директории SIGNS после распаковки файла Произведения. Цифровая подпись индивидуальна для каждой версии Произведения и распространяется совместно с ним (файл tau_knv.sig).


Теория автоматического управления

VisSim.nm.ru & VisSim.com 681.5(07)
К493

Н. В. Клиначёв

ТЕОРИЯ СИСТЕМ АВТОМАТИЧЕСКОГО
РЕГУЛИРОВАНИЯ

Учебно-методический комплекс


УДК 681.5(07) K493

УДК 681.5.01(076)
K493

Клиначёв Н. В. Теория систем автоматического регулирования и управления: Учебно-методический комплекс. - Offline версия 3.4. - Челябинск, 2004. - 654 файла, ил.

Учебно-методический комплекс рекомендуется в качестве базового ресурса для организации учебного процесса на кафедрах САУ вузов. Комплекс включает типовую рабочую программу, конспект лекций адаптированный к компьютерным проекторам, комплект лабораторных работ, тесты, и др. документы. На лекциях, для демонстрации методов теории, преподавателям рекомендуется использовать программу VisSim фирмы Visual Solutions Inc. Комплекс не содержит информацию для служебного пользования (билеты к экзамену, и пр.), тем самым предусмотрена передача комплекса студентам.

Ил. 366, учебных моделей 124, список лит. - 12 назв.

© Н.В. Клиначёв, 2000-2004.

Предисловие

Об авторстве

В любой момент авторство Клиначёва Н. В. на данный учебно-методический комплекс (далее цифровой документ) может быть подтверждено. Дайджест данного файла (для цифрового документа это эквивалент отпечатка пальца) зашифрован закрытым ключом Клиначёва Н. В. (т.е. файл подписан). К электронной подписи Клиначёва посредник добавил временную метку и зашифровал пакет своим закрытым ключом. Для подтверждения авторства необходимо самостоятельно вычислить дайджест имеющегося у вас файла и сравнить его с тем, что зашифрован. Расшифровать дайджест можно двумя публичными ключами - посредника и Клиначёва.

Входящий в данный учебно-методический комплекс конспект лекций по своему содержимому наиболее близок к учебнику В. А. Бесекерского, Е. П. Попова "Теория систем автоматического регулирования".

Правом автора Клиначёв Н. В. объявил данный цифровой документ "Свободной информацией". Т.е. пользователям данного документа доступны четыре вида свободы:

  1. Свобода запускать документ в любых целях.
  2. Свобода изучать работу документа и адаптировать его собственным нуждам.
  3. Свобода распространять копии.
  4. Свобода улучшать документ и публиковать свободные версии.

Однако "Свободная информация" - это не есть "бесплатное пиво". Дабы Вас, как пользователя данного документа нельзя было уличить в воровстве, Вы обязаны соблюдать условия лицензии на свободную документацию и, в зависимости от вашего социального положения, обязаны выполнить следующие действия:

  • Студент обязан познакомить своего преподавателя с данным документом и сетевыми ресурсами о программе VisSim. В случае если преподаватель не использует в курсе программ для визуального математического моделирования, студент обязан спросить преподавателя, в какой части курса он, за свои деньги, будет ознакомлен с современным инструментарием специалиста в области проектирования систем управления, например, с программой VisSim.
  • До тех пор пока учебное заведение, в котором работает преподаватель, будет пользоваться "Бесплатной Академической Программой" фирмы Visual Solutions Inc., и не приобретёт у нее полную версию программы VisSim, преподаватель обязан каждые пол года брать счет у фирмы и поднимать вопрос о приобретении программы как на уровне кафедры и факультета, так и на уровне проректора по учебной работе.

О студенческой версии программы VisSim

Для изучения моделей, входящих в учебно-методический комплекс и организации учебного процесса требуется загрузить студенческую версию программы VisSim, см. раздел "Download" сайта "VisSim в России". Данная версия программы специально предоставлена пользователям этого учебно-методического комплекса фирмой Visual Solutions Inc. Условием правомочного использования бесплатной студенческой версии является регистрация пользователя.

Пройти процедуру регистрации можно на сайте фирмы путем заполнения формы-требования демонстрационных версий программы VisSim. На вопрос о том, как вы узнали о программе (How did you hear about VSI / VisSim?) вам рекомендуется указать адрес, с которого вы загрузили студенческую версию (например, http://vissim.nm.ru/setupVisSimFAC.zip). Большая просьба: заполняйте форму английскими буквами.

Студенческая версия является эквивалентом действовавшей ранее "Бесплатной Академической Программы распространения VisSim'а", которой мог воспользоваться лишь преподаватель вуза.

Фирма Visual Solutions Inc. готова поставить русскоязычным вузам платную, полную, русифицированную версию программы.

О демонстрационных версиях программы VisSim

Студенческая версия программы VisSim не имеет достаточного количества примеров, для раскрытия всех ее возможностей. Преподавателю рекомендуется ознакомиться с демонстрационными версиями, которые можно найти на сайте фирмы Visual Solutions Inc.:

  • VisSim\Analyze - базовая версия, включающая библиотеку частотного анализа.
  • VisSim\TI-C2000 Rapid Prototyper - версия для специалистов в области электропривода (включает моторы, регуляторы на ЦСП (DSP) и т.д.).
  • VisSim\Comm - версия для связистов (включает источники, шифраторы, модуляторы, каналы связи, демодуляторы, дешифраторы, фильтры и т.д.).
  • VisSim\SigPro - версия для специалистов работающих с сигналами аудио диапазона.
  • VisSim\ModelWizard - дополнительный инструментарий, не включающий VisSim, нужный специалистам по идентификации объектов по историческим данным (по переходным процессам).

Только одна демо-версия VisSim\Analyze позволяет полностью изучить модели входящие в учебно-методический комплекс, поскольку остальные не имеют требуемой библиотеки частотного анализа. Все демо-версии полнофункционально работают 60 дней. После 60 дней демо-версии перестают сохранять рабочие файлы, а библиотека частотного анализа отключается (сохранение учебных моделей не предполагается).

Памятка по эксплуатации

  1. Материала в теоретическом разделе не достаточно для освоения дисциплины. Его объём специально ограничен. Раскрытие сути отдельных аспектов теории входит в обязанность лектора. При самообучении студент должен дополнительно пользоваться учебниками.
  2. Лектору, при появлении необходимости возвращения к прочитанному материалу, рекомендуется запускать копию пособия, и переключатся между окнами.
  3. Для покадрового изучения рисунков с анимацией необходимо пользоваться кнопками "Стоп" и "Обновить" в инструментальной панели окна документа.
  4. Рекомендуемое разрешение проекционной аппаратуры для визуализации на лекциях любого раздела документа - 800x600x256. Однако оформление документа не искажается и при видеорежиме 640x480x16.
  5. При работе с графическим разрешением 640x480 рекомендуется скрыть панель оглавления, при этом сохраняется возможность навигации по документу посредствам гиперссылок.
  6. При работе с проекционной аппаратурой, можно увеличить шрифт во всем документе. Закройте документ. Запустите браузер MSIE. Увеличьте шрифт по умолчанию с помощью кнопки в его инструментальной панели. Закройте браузер MSIE. Вернитесь к документу. При необходимости более существенного изменения оформления документа составьте свою каскадную таблицу стилей и подключите ее к браузеру MSIE (Сервис > Свойства обозревателя > Общие > Оформление).
  7. Замечено, что некоторые антивирусные программы-мониторы блокируют распаковку рабочих файлов моделирующих программам из данного пособия. Измените их соответствующие настройки. Пособие распространяется с электронной подписью сделанной автором (tau_knv.chm.sig - подпись, KNV.asc - публичный ключ Клиначёва Н.В.). Используя программу PGP, вы можете убедиться, что при распространении данный файл ни кем не был изменен.

Технические аспекты

Учебно-методический комплекс выполнен в соответствии со стандартом Windows-HTML-справки. Он представляет собой один файл, в котором заархивированы html-страницы, рисунки и необходимые скрипты. Файл пособия автоматически распознается и запускается операционной системой Windows 98 (NT, 2000), точнее браузером MSIE версии не ниже 4.0. Пользователям Windows 95 (NT) дополнительно следует установить Windows-HTML-справку. Для чего следует найти на сайте фирмы Microsoft файл hhupd.exe (733 KB). Там же, или в секторе "download" сайта фирмы Microsoft, вы можете скачать программу HTML Help Workshop (файл htmlhelp.exe (4 MB)). Используя ее, Вы можете декомпилировать пособие для запуска в браузере Netscape или для создания собственного на основе этого образца. Программа HTML Help Workshop также содержит утилиту для создания gif-файлов с изображениями необходимых вам фрагментов экрана. Для корректной цветопередачи при создании gif-файлов активируйте цветовое разрешение дисплея в 256 цветов. Пособие так же полностью функционально и запускается браузером MSIE, если в адресной строке набрать: mk:@MSITStore:C:\tau_knv.chm::/index.htm - где C:\ - путь к файлу tau_knv.chm.

Сведения об источнике обновленных версий документа

Обновленные версии данного цифрового документа доступны на сайте "VisSim в России". Если при загрузке с сайта возникают технические затруднения, то для их решения можно связаться с автором (адрес электронной почты: klinacherv_nv@mail.ru). При возможных изменениях в адресах рекомендуется воспользоваться поисковыми системами, используя ключевые слова: VisSim, симуляция движения, моделирование, Nikolay Klinachyov.

Регистрация документа на Вашем компьютере

Если Вы часто пользуетесь этим документом, то постоянная активация счетчика статистики в документе будет мешать вам. Вы можете получить у автора пароль, для деактивации счетчика на полгода. Заполните и отправьте форму:

ФИО: | *
Должность: |
Научное звание: |
Организация (вуз): | *
Город: | *
Область: | *
Укажите сайт, откуда вы скачали этот документ:
http:// |
Какими программами для моделирования
вы пользуетесь? |
Сообщать вам об обновлениях?

Если пароль получен вами, то введите его в эту строку:

Срок действия пароля определен периодом публикации новой версии документа. Если срок истек, и счетчики вновь начали работать, то рекомендуется обновить версию документа. Так же допустимо отключить счетчики повторным вводом пароля на очередные полгода. Клиначёв Николай Васильевич


Оглавление лекций Клиначёва по ТАУ

Тематический план лекционных занятий дисциплины
"Теория систем автоматического регулирования"

Введение. Классификация САР
1. Составление исходных ДУ САР
2. Описание САР в частотном домене
3. Типовые динамические звенья
4. Принципы и законы регулирования
5. Устойчивость САР
6. Оценка качества регулирования
7. Повышение точности САР
8. Коррекция САР
9. Синтез САР
10. Системы с переменными параметрами
11. Системы с запаздыванием
12. Системы импульсные
13. Системы цифровые
Литература


Введение в теорию автоматического управления

Введение

Мир технических систем разнообразен. Однако математика и физика выявили простые параллели в этом сложном мире. Можно выделить ряд энергетических доменов, которым принадлежат те или другие системы или их модули. Это электрический, магнитный, термальный, гидравлический, акустический, механический и ротационный домены. Так же существуют два фундаментальных постулата. Первый постулат гласит, что материя не может появиться ни откуда и не может исчезнуть в никуда. Второй постулат утверждает то же самое в отношении энергетического потенциала. Эти постулаты имеют частные формулировки для каждого энергетического домена. Например, для электрического домена это первый и второй законы Кирхгофа. Каждый из энергетических доменов характеризуется двумя физическими величинами первого и второго рода. В случае электрического домена - это электрические ток и напряжение соответственно. Эти парные физические величины, в каждом энергетическом домене, связаны между собой законом Ома в соответствующей формулировке (существуют: электрическое, магнитное, термальное, гидравлическое, акустическое, механическое и ротационное сопротивления). Так же следует отметить, что произведение физических величин первого и второго рода всегда есть мощность.

Представленная система параллелей позволяет понять, что математическое описание процессов движения координат систем принадлежащих разным энергетическим доменам подобно, и может быть предметом изучения одной науки, которая называется "Теория систем автоматического регулирования". Более того, в последние годы, приобретен успешный опыт применения методов этой теории при решении задач управления в экономических, финансовых и других нетехнических системах.

Предмет, проблематика, задачи и цель дисциплины
"Теория систем автоматического регулирования"

Рабочие файлы: [САР]

Система управления
Это совокупность одного или нескольких управляемых объектов и управляющей ими системы

Принцип действия всякой системы автоматического регулирования (САР) заключается в том, чтобы обнаруживать отклонения регулируемых величин, характеризующих работу объекта или протекание процесса от требуемого режима и при этом воздействовать на объект или процесс так, чтобы устранять эти отклонения.

В теории автоматического регулирования основными являются проблемы: устойчивости, качества переходных процессов, статической и динамической точности, автоколебаний, оптимизации, синтеза и отождествления (идентификации).

Задачи общей теории автоматического регулирования заключаются в решении перечисленных проблем. При поиске решений используются:

  1. Методы анализа устойчивости замкнутых САР
  2. Методы оценки качественных показателей САР
  3. Методы повышения точности САР
  4. Методы коррекции динамических свойств САР
  5. Методы синтеза САР

Разработка же методов решения прикладных инженерных задач стоящих при проектировании САР есть глобальная цель теории систем автоматического регулирования.

Классификация систем автоматического регулирования

Классификация систем автоматического регулирования

Классификация по характеру изменения величин:

  1. Системы непрерывного действия
  2. Системы импульсного действия (AM, ФМ, ЧМ, ШИМ, ЧИМ, ...)
  3. Системы дискретного действия (01001011110101100010101)
  4. Системы релейного действия

Классификация по математическим признакам:

  1. Линейные системы
  2. Нелинейные системы
  3. Существенно нелинейные

Классификация по способу настройки:

  1. Не адаптивные системы
  2. Адаптивные системы
    • Системы с переменной структурой
    • Системы с самонастройкой программы
    • Системы с самонастройкой параметров
    • Системы с самонастройкой структуры

Классификация по типу ошибки в статике:

  1. Статические САУ
  2. Астатические САУ

Классификация по алгоритмам функционирования (по назначению):

  1. Системы стабилизации
  2. Системы слежения
  3. Системы программного управления
  4. Системы телеуправления
  5. Системы самонаведения (снаряда), сопровождения (орудия), автопилотирования
  6. Системы компенсационных измерений
  7. ...


Исходные дифференциальные уравнения САР

Составление исходных дифференциальных уравнений САР

Два подхода к получению исходных дифференциальных уравнений систем.
Истинные и ложные модели

Рабочие файлы: [Истинная и ложная модели] [Принцип измерения ЧХ]

Если поставлена задача составления исходных ДУ САР, то возможны две ситуации. Либо детальная декомпозиция системы на модули и отдельные звенья возможна, либо нет.

Если декомпозиция возможна, то, опираясь на постулаты о сохранении материи и энергии (для соответствующего энергетического домена) и на закон Ома (в соответствующей формулировке), приступают к составлению исходных ДУ САР, т.е. к созданию истинной модели системы. Истинной будем называть такую модель или такое математическое описание, о которых известно, что они детально соответствуют физической природе системы.

Если декомпозиция на модули и звенья для системы невозможна, то, не имея детальной информации о ее физической природе, можно получить лишь ложную модель или ложное математическое описание, которые, однако, позволят исследовать систему и получить адекватные результаты. В этом случае совокупность исходных ДУ САР получают через частотный домен, путем экспериментального снятия частотных характеристик.

Для физической системы порядок системы ДУ ее истинной модели обычно в десять и более раз выше порядка системы ДУ ее ложной модели (например, для моделей ОУ). Тем обусловлена широкая популярность ложных моделей, и типовых звеньев, как структурных элементов для их создания.

Общая форма записи систем ДУ

В целях формализации процесса составления исходных ДУ систем используют такие методы, как "Метод контурных токов", "Метод узловых потенциалов" и их аналоги, имеющиеся во всех энергетических доменах. В результате их применения получается единая система:

(1)

a11(p) x1 + a12(p) x2 + ... + a1k(p) xk = f1(t)
a21(p) x1 + a22(p) x2 + ... + a2k(p) xk = f2(t)
...
ak1(p) x1 + ak2(p) x2 + ... + akk(p) xk = fk(t)

где:

  • x1, x2, ..., xk - обобщенные координаты системы, в том числе (для САР) ошибка - x(t) и регулируемая величина - y(t);
  • f1(t), f2(t), ..., fk(t) - внешние координаты - задающие g(t) и возмущающие f(t) воздействия.

Для удобства и формализации решений систему уравнений (1) могут представить в одной из пяти стандартных форм:

  1. в форме Коши;
  2. в пространстве состояний;
  3. решенную относительно регулируемой величины - y(t);
  4. решенную относительно ошибки - x(t);
  5. в виде передаточных функций - W(p), F(p), F x(p).

Форма Коши

Форма Коши
Матричная форма записи системы ДУ решенных исключительно относительно первой производной координат САР.

Структура блок-схемы решающая систему ДУ представленную в форме Коши

Изображенная на рисунке блок-схема позволяет решить систему ДУ представленную в форме Коши:

(2)

где:

  • x1, x2, x3 - собственные координаты системы - ошибка системы x(t), воздействие на объект u(t), выходная координата - y(t), ...;
  • a11, ... , a33 - постоянные коэффициенты (если система не является зависимой от параметра) - суммы и произведения постоянных времени Tj, коэффициентов усиления Kn;
  • f1, f2, f3 - воздействия на систему - сигнал задания g(t), помехи fj(t).

О форме Коши:

  • Применяется в теории управления не часто.
  • Удобна, если для расчетов использовать классические математические пакеты: MathCAD, MATLAB, Mathematica, Maple, Derive.
  • Используется при построении аналоговых вычислительных моделей матричного типа (например, моделей на операционных усилителях).
  • Уравнения могут быть решены относительно любой из фазовых координат xi.

Пространство состояний

Рабочие файлы: [ABCD.vsm] [ABCD-ПФ и W(j w)]

Пространство состояний (ABCD-форма)
Матричная форма записи системы ДУ САР адаптированная для теории управления путем выделения из формы Коши алгебраических уравнений связывающих внутренние координаты САР с выходной(ыми). Применяется для описания САР большого порядка, как правило, с несколькими входами / выходами и с перекрестными связями.

Структура блок-схемы решающая систему ДУ представленную в форме "Пространства состояний"

Изображенная на рисунке блок-схема позволяет решить систему ДУ представленную в форме "Пространства состояний":

(3)

u' = A u + B x
y = C u + D x

где:

  • xm x 1 - вектор входных переменных;
  • yk x 1 - вектор выходных переменных;
  • un x 1 - вектор переменных состояния (фазовых координат системы);
  • An x n - матрица коэффициентов системы;
  • Bn x m - матрица входных коэффициентов (матрица управления);
  • Ck x n - матрица выходных коэффициентов;
  • Dk x m - матрица коэффициентов пропорциональных каналов (матрица компенсации);
  • n - порядок системы; m - кол-во входов; k - кол-во выходов (m<n).

О форме "Пространство состояний":

  • Это вторая по частоте применений форма записи ДУ в ТАУ. Применяется реже, чем в 5% случаев.
  • Признана стандартом для программ математического моделирования VisSim, Simulink, и т.д., однако в большинстве случаев реализована в SISO-форме (с одним входом и одним выходом). Моделирующие программы для выполнения анализа (символьного или частотного) сводят любую модель пользователя к пространству состояний, заполняя в ходе первых шагов симуляции коэффициенты ABCD-матриц.
  • Как правило, используется для построения моделей тех больших не поддающихся модуляризации, но не сложных систем, описание которых оптимально в матричной форме (таких мало). Для записи уравнений используются такие методы как: "Метод контурных токов", "Метод узловых потенциалов", - а так же их эквиваленты для других энергетических доменов (гидравлического, теплового, механического, ...).
  • Матричное описание строго формализовано, и не требует понимания физической природы системы. Так же структура модели в "пространстве состояний" не позволяет разобраться во внутренней природе системы. Если эта форма записи ДУ применена обосновано, то модель, скорее всего, будет истинной.

ДУ решенное относительно регулируемой величины y(t) - уравнение движения

Рабочие файлы: [САР]

Система ДУ (1) может быть преобразована к одному уравнению путем исключения промежуточных координат (обычно выходную координату выражают через координату задания):

.

Результатом подобного преобразования является уравнение движения системы:

(4)

D(p) y(t) = R(p) g(t) - N(p) f(t) ,

где:

  • D(p) = a0pn + a1pn-1 + ... + an-1p + an - характеристический полином;
  • R(p) = D(p) - Q(p) = b0pm + b1pm-1 + ... + bm-1p + bm - коэффициенты этого полинома определяют влияние задающего воздействия g(t) на регулируемую координату у(t), причем его степень меньше степени характеристического полинома, т.е. m<n;
  • N(p) = d0pk + d1pk-1 + ... + dk-1p + dk - коэффициенты полинома определяют влияние помехи f(t) на систему.

ДУ решенное относительно ошибки x(t) - уравнение ошибки

Рабочие файлы: [САР]

Если система ДУ (1) решается относительно ошибки системы, то получается уравнение ошибки замкнутой системы:

(5)

D(p) x(t) = Q(p) g(t) + N(p) f(t)

где:

  • D(p) = a0pn + a1pn-1 + ... + an-1p + an - характеристический полином;
  • Q(p) = D(p) - R(p) = c0pn + c1pn-1 + ... + cn-1p + cn - коэффициенты полинома определяют влияние задающего воздействия g(t) на ошибку x(t);
  • N(p) = d0pk + d1pk-1 + ... + dk-1p + dk - коэффициенты полинома определяют влияние помехи f(t) на систему.

Передаточные функции САР

Передаточная функция
Функция, связывающая один входной и один выходной сигналы САР. Является формой записи системы ДУ САР решённой относительно требуемой выходной координаты. Обычно ПФ записывается не для временного домена, а для домена Лапласа, связывая в этом варианте не сигналы (т.е. не функции времени), а их изображения.

ПФ-ии получают из ДУ решенного относительно требуемой координаты системы (уравнение (4) или (5)). Для чего правую часть уравнения делят на характеристический полином D(p). Отношения полиномов в правой части при возмущающих воздействиях и есть ПФ-ии.

Типовая структура замкнутой САР

Для типовой структурной схемы замкнутой САР различают 3 основные ПФ, применяемые для исследований:

  1. W(p) = y(t)/x(t) Ч Wос(p) = Wрег(p) Wо(p) Wос(p) - ПФ разомкнутой системы;
  2. F(p) = y(t)/g(t) - ПФ замкнутой системы;
  3. F x(p) = x(t)/g(t) - ПФ замкнутой системы по ошибке.

Запишем по структурной схеме уравнение движения для разомкнутой системы:

Уравнение движения для разомкнутой системы.

где: Wпрк(p) - ПФ прямого канала системы.

Замкнем систему с помощью уравнения замыкания:

Уравнение замыкания.

Тогда совместное решение даст уравнение движения замкнутой системы:

Уравнение движения замкнутой системы

и уравнение ошибки замкнутой системы:

Уравнение ошибки замкнутой системы.

При отсутствии помехи f (t) выходная величина связана с задающим воздействием ПФ замкнутой системы:

Передаточная функция замкнутой системы .

А ошибка - с задающим воздействием ПФ замкнутой системы по ошибке:

Передаточная функция замкнутой системы по ошибке .

При этом:

Другие связывающие отношения

Разделим уравнение движения (4) на уравнение ошибки (5), считая, что f(t)=0 и Wос(p)=1:

y(t) / x(t) = R(p) / Q(p) , => W(p) = R(p) / Q(p) .

В соответствии с теми же уравнениями и уравнением замыкания характеристический полином D(p) = R(p) + Q(p). Добавим 1 к W(p):

1 + W(p) = Q(p) / Q(p) + R(p) / Q(p) = D(p) / Q(p) .

При исследованиях характеристический полином приравнивают к нулю, т.е. вместо него можно использовать W(p):

1 + W(p) = 0 , - характеристическое уравнение.

А так же:

W(p) = [D(p) - Q(p)] / Q(p) = D(p)/Q(p) - 1 = R(p) / [D(p) - R(p)] .

и

W(p) = F(p) / [1 - F(p)] , W(p) = [1 - Fx(p)] / Fx(p) .

Линеаризация ДУ САР

Достаточно часто встречаются звенья, имеющие нелинейную зависимость между входной и выходной координатами. Если для малых отклонений от установившегося режима нелинейность несущественна, то в этом случае до составления исходных ДУ САР (1), ..., (5). Выполняют процедуру линеаризации.

Суть линеаризации

Представление сигналов на входах и выходах САР для решения задачи линеаризации

  1. Пусть нелинейное динамическое уравнение звена имеет вид:

    F(x1, x2, x2', y, y', y'', y''') = j( f, f ') .

  2. Тогда уравнение установившегося состояния, всилу равенства нулю всех производных, имеет вид:

    Fo(x1o, x2o, 0, yo, 0, 0, 0) = j( f o, 0) .

  3. Перейдем к уравнению динамики для отклонений, выполнив подстановки:

    x1 = x1o+D x1(t), x2 = x2o+D x2(t), x2' = D x2'(t),
    y = yo+D y(t), y' = D y'(t), y'' = D y''(t), y''' = D y'''(t);

    и разложив функцию F в ряд:

    .

  4. Завершая линеаризацию, вычтем из левой и правой части уравнение установившегося состояния:

    (*)

    Линеаризованное уравнение модуля системы.

Особенности линеаризованного уравнения

  1. Оно является приближенным - отброшены члены высшего порядка малости.
  2. Неизвестными функциями являются не полные величины, а их отклонения D... от установившихся значений.
  3. Уравнение является линейным относительно отклонений D..., при этом масштабирующие коэффициенты (частные производные) могут быть постоянными или переменными во времени.
  4. Внешнее воздействие линеаризации не подлежит.

Геометрическая трактовка линеаризации

Рабочие файлы: [de_lin.vsm]

Запись линеаризованных уравнений в стандартных для ТАУ формах

Представим линеаризованное уравнение (*) в форме уравнения движения и в виде ПФ.

Уравнение движения предполагает: а) выходную величину и ее производные в левой части уравнения, а входную и все остальные члены - в правой; б) так же, принято, чтобы сама выходная величина входила в уравнение с коэффициентом единица. Чтобы привести линеаризованное уравнение (*) к такому виду введем обозначения:

тогда:

T33D y''' + T22D y'' + T1D y' + D y = k1D x1 + k2D x2 + k3D x'2 + k4 f1 .

Знак D обычно опускают и записывают уравнение в символьном виде:

(**)

(T33 p3 + T22 p2 + T1 p + 1) y = k1x1 + (k2 + k3 p) x2 + k4 f1 ,

где:

T3, T2, T1 - постоянные времени;
k4, k3, k2, k1 - коэффициенты усиления;
p=d.../dt - оператор дифференцирования.

Для вывода ПФ решим уравнение движения (**) относительно выходной величины:

y = W1(p) D x1 + W2(p) x2 + Wf (p) f1 ,

Более строго передаточные функции определяются через изображения Лапласа или Карсона-Хевисайда, как отношение изображений выходной и входной величин: Пример отображения структурной блок-схемы модуля системы

.

Запись ПФ для переменных во времени величин и для их изображений совпадает до оператора. В первом случае ПФ зависит от оператора дифференцирования p=d.../dt. Во втором случае - от оператора Лапласа s=c+j w.


Описание САР в частотном домене

Частотная передаточная функция

Рабочие файлы: [Измерение ЧХ]

Если на вход любой системы подать сигнал синусоидальной формы:

x(t) = Xm cos(w t) = Xm e j w t .

Очевидно, что выходной сигнал будет иметь ту же форму:

y(t) = Ym cos(w t+j) = Ym e j(w t+j) .

Зависимость же между амплитудами и фазами выходного и входного сигналов определяет ДУ движения системы. Возмем произвольное, считая помеху f(t) равной нулю:

(T22 p2 + T1 p + 1) y(t) = (k1 + k2 p) x(t) .

Подставим сигналы в уравнение движения:

T22(j w)2 Ym e j(w t+j) + T1(j w) Ym e j(w t+j) + Ym e j(w t+j) = k1 Xm e j w t + k2(j w) Xm e j w t .

Найдем отношение выходного сигнала ко входному:

Частотная передаточная функция.

Заметим. Если вместо подстановки сигналов записать ДУ движения системы для домена Лапласа и вновь найти отношение выходного сигнала к входному (а точнее их изображений), то полученная в ходе этого преобразования ПФ совпадет с точностью до свободной переменной с частотной ПФ.

Резюме 1: Частотная передаточная функция получается из обычной заменой оператора Лапласа s на комплексную частоту j w, т.е. в результате перехода от изображения Лапласа к изображению Фурье.

Резюме 2: ДУ движения системы связывает входной и выходной сигналы (т.е. функции времени), ПФ связывет изображения Лапласа тех же сигналов, а частотная ПФ связывает их спектры.

Частотные характеристики

Частотная передаточная функция может быть представлена в следующих видах:

W(j w) = A(w) e j j(w), или W(j w) = U(w) + jV(w) ;

где:

  • A(w) - модуль частотной передаточной функции - находится как отношение модулей числителя и знаменателя:

    A(w) = (k12 + k22 w2)1/2 / ((1 - T22 w 2)2 + T12 w 2)1/2 .

  • j(w) - фаза частотной передаточной функции - находится как разность аргументов числителя и знаменателя:

    j(w) = arctg(k2w / k1) - arctg(T1w / (1-T2w2)).

  • U(w) и V(w) - вещественная и мнимая части частотной ПФ. Для их нахождения немобходимо избавиться от мнимости в знаменателе, умножением на сопряженную знаменателю комплексную величину.

Амплитудно-фазовая (частотная) характеристика или годограф Найквиста

Амплитудно-фазовая характеристика (годограф Найквиста)
Графическое отображение для всех частот спектра отношений выходного сигнала САР к входному, представленных в комплексной форме. Величина отрезка от начала координат до каждой точки годографа показывает во сколько раз на данной частоте выходной сигнал больше входного, а сдвиг фазы между сигналами определяется углом до упомянутого отрезка. Правила отображения "Амплитудо-фазовой характеристики" или "Годографа Найквиста" в программах математического моделирования

От АФХ порождаются все другие частотные зависимости:

  • U(w) - четная (для замкнутых САР P(w));
  • V(w) - нечетная;
  • A(w) - четная (АЧХ);
  • j(w) - нечетная (ФЧХ);
  • ЛАЧХ & ЛФЧХ - используются наиболее часто.

Логарифмические ЧХ - ЛАЧХ & ЛФЧХ

Построение ЛАЧХ & ЛФЧХ производится по выражениям:

L(w) = 20 lg |W(j w)| = 20 lg A(w), [дБ]; j(w) = arg(W(j w)), [рад].

Числитель и знаменатель ПФ САР могут быть представлены либо в виде отношения полиномов:

,

либо в виде отношения их разложений на элементарные множители:

(1)

Передаточная функция линейной системы, записанная в наиболее обобщающем виде

Постановка s¬j w позволяет перейти в частотный домен. При наличии ЭВМ построение ЛАЧХ & ЛФЧХ не составит труда в любом случае. Однако разложенная на множители ПФ (1) позволяет построить асимптотические ЛАЧХ & ЛФЧХ практически без вычислительной работы. Каждый линейный множитель ее числителя и знаменателя есть комплексное число. Найдем модуль каждого (как гипотенузу прямоугольного треугольника), и перейдем к логарифмическому масштабу:

Обобщающая формула для построения ЛАЧХ.

Для упрощения дальнейших построений избавимся от операции умножения, заменив ее операцией сложения в логарифмическом домене:

(2)

Обобщающая формула для построения ЛАЧХ.

Легко понять, что каждое слагаемое выражения (2) есть либо прямая линия, либо асимптотически приближается к прямым линиям при устремлении частоты к нулю и к бесконечности. Наклон аппроксимирующих прямых всегда кратен 20 дБ за декаду.

Для построения ЛФЧХ необходимо найти фазу каждого множителя числителя и знаменателя частотной ПФ, как арктангенс отношения его противолежащего катета к прилежащему (напомним, что при произведении комплексных чисел (в экспоненциальной форме) фазы (показатели степени) складываются, а при делении - вычитаются). Таким образом, построение ЛФЧХ производится по выражению:

Обобщающая формула для построения ЛФЧХ.

Отметим так же, что одному Белу соответствует увеличение мощности в 10 раз. Поскольку A - это физическая величина либо первого, либо второго рода, а не их произведение (т.е. не мощность); увеличение ее в 10 раз соответствует увеличению мощности в 100 раз, что соответствует двум Белам или 20 дБ.

Правила построения асимптотических ЛАЧХ & ЛФЧХ

Правила построения асимптотических ЛАЧХ & ЛФЧХ, точнее каждого слагаемого выражения (2) показаны на рисунках.

Точность асимптотических ЛАЧХ & ЛФЧХ достаточна в большинстве случаев. Для звеньев первого порядка максимальная амплитудная ошибка вблизи частоты сопряжения составляет 3 дБ. Максимальная фазовая ошибка - 6%. Фрагмент ЧХ колебательного звена вблизи резонансной частоты лишь иногда следует уточнить по опорным справочным кривым для данного z.


Типовые звенья и их характеристики

Единичная функция. Дельта-функция.
Типовые реакции систем

Рабочие файлы: [Интеграл Дюамеля] [Интеграл свертки]
[h(t) & w(t)] [Интеграл свертки]

Единичная ступенчатая функция - 1(t)
Математическая функция, заданная условиями: 1(t) = 0 при t < 0, и 1(t) = 1 при t > 0. Для автоматических систем является распространенным видом входного воздействия. Как правило, подобные воздействия сопровождают процессы включения систем и вызывают переходы от одного установившегося состояния к другому.
Дельта-функция Дирака - d(t)
Математическая функция, заданная условиями: d(t) ® Ґ при t = 0, и d(t) = 0 при t № 0, - т.е. это импульс с бесконечной амплитудой, площадь которого принимается равной 1. Для автоматических систем является менее распространенным видом входного воздействия, чем единичная ступенчатая функция. Однако для теоретического описания последних имеет существенное значение. Подобные воздействия характерны для радарных комплексов, описывают передачу импульса при упругом взаимодействии и т.д.

Из определений функций 1(t) и d(t) очевидна связь между ними:

(1)

1(t) = т d(t) dt и d(t) = 1'(t).

Единичная ступенчатая функция 1(t) легка для практической реализации с высокой точностью, однако дельта-функцию Дирака d(t) реализовать сложнее. Для теоретического описания систем и их моделирования ее можно грубо представить с помощью двух ступенчатых функций:

(2)

d(t) » N 1(t) - N 1(t-e),

где: N - амплитуда функций, e - время, на которое запаздывает вторая ступенчатая функция, при этом N e = 1 и e ® 0.

Переходная функция или характеристика - h(t)
Переходный процесс на выходе типового звена или линейной системы, возникающий при подаче на вход единичной ступенчатой функции 1(t).
Функция веса - w(t)
Переходный процесс на выходе типового звена или линейной системы, возникающий при подаче на вход короткого импульса, который, в приближении, можно рассматривать как дельта-функцию Дирака d(t).

В виду независимости присущих линейным системам свойств от внешних воздействий и наличия связи (1) между последними, подобное же отношение существует и для соответствующих типовых реакций:

h(t) = т w(t) dt и w(t) = h'(t).

Докажем эту взаимосвязь подав на систему грубую реализацию дельта-функции (2). В этом случае переходный процесс на выходе можно представить следующей суперпозицией:

y(t) = N h(t) - N h(t-e),

которая будет являться функцией веса, предел которой (при e ® 0) будет равен производной от переходной функции:

w(t) = lime®0( e N (h(t) - h(t-e)) / e ) = h'(t), - напомним: N e = 1.

Функция веса связана с передаточной функцией преобразованием Лапласа:

W(s) = oҐ т w(t) e -st dt.

Переходная функция связана с передаточной функцией преобразованием Карсона:

W(s) = s oҐ т h(t) e -st dt.

Для произвольного входного воздействия, переходный процесс на выходе линейной системы может быть определен на основании интеграла Дюамеля-Карсона, если известны типовые реакции:

  • h(t): y(t) = x(0) h(t) + ot т x'(t) h(t-t) d t;
  • w(t): y(t) = ot т x(t) w(t-t) d t, - так же "Интеграл свертки";

где: t - вспомогательное время интегрирования.

Типовые динамические звенья

Рабочие файлы: [Звенья]

Типовые динамические звенья
Совокупность элементарных, универсальных математических функций наиболее часто используемых при построении динамических моделей реальных объектов. Представляют собой ДУ, записанные в особой форме - в виде ПФ связывающих входной и выходной сигналы звеньев. Обычно ПФ записываются не для временного домена, а для домена Лапласа, связывая в этом варианте не сигналы (т.е. не функции времени), а их изображения.

Типовые динамические звенья Частотные характеристики типовых динамических звеньев

Наличие нулевых корней в числителе или знаменателе ПФ типовых звеньев - это признак для разбиения последних на три группы:

  • Позиционные звенья: 1, 2, 3, 4, 5, - не имеют нулевых корней, и, следовательно, в области низких частот (т.е. в установившемся режиме), имеют коэффициент передачи равный k.
  • Интегрирующие звенья: 6, 7, 8, - имеют нулевой корень-полюс, и, следовательно, в области низких частот, имеют коэффициент передачи, стремящийся к бесконечности.
  • Дифференцирующие звенья: 9, 10 - имеют нулевой корень-ноль, и, следовательно, в области низких частот, имеют коэффициент передачи, стремящийся к нулю.

Передаточные функции типовых динамических звеньев

Правила преобразования структурных схем линейных систем

Декомпозиция любой линейной системы на модули (модуляризация) эквивалентна ее представлению с помощью типовых динамических звеньев. Блок-схема может содержать большое количество звеньев, и их соединение может быть произвольным. Существует лишь два основных правила преобразования структурных схем линейных систем.

  • Результирующая ПФ-я двух последовательно включенных блоков равна произведению их ПФ-ий.
  • Результирующая ПФ-я двух параллельно включенных блоков равна сумме их ПФ-ий.

Для упрощения более сложных соединений следует пользоваться принципом суперпозиции, как показано на рисунке.

Правила преобразования структурных схем линейных систем

Поскольку в логарифмическом домене операция умножения осуществляется сложением, результирующая ЛАЧХ последовательно включенных звеньев получается сложением исходных. Построение результирующей ЛАЧХ параллельно включенных звеньев выполняется по огибающей исходных. Здесь действует принцип – если один из параллельных каналов с изменением частоты сигнала перестает его пропускать, то сигнал проходит по второму параллельному каналу.


Принципы и законы регулирования

Основы регулирования автоматических систем

Принципы автоматического регулирования

По принципу управления САУ можно разбить на три группы:

  1. С регулированием по внешнему воздействию - принцип Понселе (применяется в незамкнутых САУ).
  2. С регулированием по отклонению - принцип Ползунова-Уатта (применяется в замкнутых САУ).
  3. С комбинированным регулированием. В этом случае САУ содержит замкнутый и разомкнутый контуры регулирования.

Принцип управления по внешнему возмущению

Структурная схема системы, построенной согласно принципу управления по внешнему возмущению В структуре обязательны датчики возмущения. Система описывается передаточной функцией разомкнутой системы.

Достоинства:

  • Можно добиться полной инвариантности к определенным возмущениям.
  • Не возникает проблема устойчивости системы, т.к. нет ОС.

Недостатки:

  • Большое количество возмущений требует соответствующего количества компенсационных каналов.
  • Изменения параметров регулируемого объекта приводят к появлению ошибок в управлении.
  • Можно применять только к тем объектам, чьи характеристики четко известны.

Принцип управления по отклонению

Структурная схема системы, построенной согласно принципу управления по отклонению Система описывается передаточной функцией разомкнутой системы и уравнением замыкания: x(t) = g(t) - y(t) Woc(p). Алгоритм работы системы заключен в стремлении свести ошибку x(t) к нулю.

Достоинства:

  • ООС приводит к уменьшению ошибки не зависимо от факторов ее вызвавших (изменений параметров регулируемого объекта или внешних условий).

Недостатки:

  • В системах с ОС возникает проблема устойчивости.
  • В системах принципиально невозможно добиться абсолютной инвариантности к возмущениям. Стремление добиться частичной инвариантности (не 1-ыми ОС) приводит к усложнению системы и ухудшению устойчивости.

Комбинированное управление

Структурная схема системы, построенной согласно принципу комбинированного управления Комбинированное управление заключено в сочетании двух принципов управления по отклонению и внешнему возмущению. Т.е. сигнал управления на объект формируется двумя каналами. Первый канал чувствителен к отклонению регулируемой величины от задания. Второй формирует управляющее воздействие непосредственно из задающего или возмущающего сигнала.

Достоинства:

  • Наличие ООС делает систему менее чувствительной к изменению параметров регулируемого объекта.
  • Добавление канала(ов), чувствительного к заданию или к возмущению, не влияет на устойчивость контура ОС.

Недостатки:

  • Каналы, чувствительные к заданию или к возмущению, обычно содержат дифференцирующие звенья. Их практическая реализация затруднена.
  • Не все объекты допускают форсирование.

Программы и законы регулирования

Рабочие файлы: [Нелинейные законы]

Программа регулирования
План формирования задающего воздействия g(t) на систему.

Программа регулирования может быть:

  • временной: y = y(t);
  • параметрической: y = y(s1, s2, s3, ..., sn).

Например, временная программа приготовления пищи (лапшу варить 12 мин.), или параметрическая программа посадки самолета на палубу авианосца (в зависимости от: бокового ветра, изменений координат посадочной полосы, массы остатка топлива, ...).

Закон регулирования
Зависимость, по которой формируется регулирующее воздействие u(t) на объект из первичной информации: g(t) и/или x(t) и, возможно, f (t).

Законы регулирования бывают:

  • линейные:
    Пример линейного закона регулирования;
  • нелинейные: F1(u, du/dt, ...) = F2(x, dx/dt, ...; g, ...; f, ...) .

Классификация нелинейных законов регулирования:

  1. Функциональные.
  2. Логические.
  3. Параметрические.
  4. Оптимизирующие.

Примеры статических функциональных нелинейностей в законах:

Примеры статической нелинейности в законах регулирования.

Примеры динамических функциональных нелинейностей в законах:

Примеры динамической нелинейности в законах регулирования

Пример логического нелинейного закона:

Если |x| < 0.2Gm, тогда u = k1 x ;
Если |x| > 0.2Gm, тогда u = k2 x ;
где: k1 < k2

Пример параметрического нелинейного закона:

u = k (t [°C]; h [м]; G [кг]) x .

Пример оптимизирующего нелинейного закона:

u = k (min(CO2); max(КПД)) x .

Линейные непрерывные законы регулирования

Под законом регулирования (управления) понимается алгоритм или функциональная зависимость, определяющая управляющее воздействие u(t) на объект:

u(t) = F(x, g, f) .

Линейные законы описываются линейной формой:

u(t) = k1x(t) + k2т x(t)dt + k3тт x(t)dt2 + ... + k4x'(t) + k5x''(t) + ...

она же в операторной форме записи:

(1*)

u(t) = x(t) [k1 + k2/p + k3/p2 + ... + k4 p + k5 p2 + ...] .

Наличие в (1*) чувствительности регулятора к пропорциональной, к интегральным или к дифференциальным составляющим в первичной информации x(t), определяет тип регулятора:

  1. P - пропорциональный.
  2. I - интегральный.
  3. PI - пропорционально интегральный (изодромный).
  4. PD - пропорционально дифференциальный.
  5. и более сложные варианты - PID, PIID, PIDD, ...

Пропорциональное регулирование

Пропорциональный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = k1x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = k1Wo(p) .

Рассмотрим уравнение ошибки:

В установившемся режиме p®0 (все производные равны нулю); Wo(p)®ko; W(p)®k1ko=k; где k - контурный коэффициент усиления разомкнутой системы (при Wос(p)=1).

Резюме: P-регулирование позволяет уменьшить установившуюся (статическую) ошибку, но только в 1+k раз, поэтому регулирование будет статическим. Т.е. при любом k xуст№0.

Интегральное регулирование

Интегральный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = k2/p x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = k2/p Wo(p) .

Рассмотрим уравнение ошибки:

В установившемся режиме p®0, => W(p)®Ґ; => первая составляющая ошибки g0/Ґ®0. Ошибка от возмущения зависит от вида функции Wf(0) и может быть отлична от нуля.

Резюме: I-регулирование позволяет исключить статическую ошибку в системе, т.е. система будет астатической по отношению к задающему воздействию g(t).

Интегральное регулирование по второму интегралу от ошибки

Двойной интегральный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = k3/p2 x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = k3/p2 Wo(p) .

В этом случае система будет обладать астатизмом второго порядка - в ноль обратятся как постоянная составляющая ошибки, так и её скоростная составляющая (ошибка от помехи здесь не рассматривается):

Резюме: повышение порядка астатизма приводит к увеличению установившейся точности САР, но делает систему более замедленной в действии.

К пояснению инерционных свойств интегрирующих каналов регуляторов

На рисунке показано, что, на сколько бы мал ни был коэффициент усиления пропорционального канала, и насколько большим бы ни был коэффициент усиления интегрального канала, для малых отклонений ошибки x(t) сигнал управления на объект u(t) интегральным каналом формируется менее интенсивно.

Изодромное регулирование - PI

Изодромный закон регулирования имеет вид:

u(t) = Wрег(p) x(t) = (k1 + k2/p) x(t) ,

тогда в разомкнутом состоянии система будет характеризоваться ПФ:

W(p) = Wрег(p) Wo(p) = (k1 + k2/p) Wo(p) .

В этом случае если p®0, то W(p)®Ґ и регулирование будет астатическим. Но если p®Ґ, то W(p)®k1ko=k и регулирование будет пропорциональным.

Резюме: PI-регулирование сочетает точность I-регулирования и быстродействие P-регулирования.

Регулирование с использованием производных

Рабочие файлы: [Шум дифференцирования]

Регулирование с использованием одного канала, чувствительного к производной сигнала не имеет самостоятельного значения, т.к. сигнал управления:

u(t) = Wрег(p) x(t) = k4 p x(t) ,

будет равен нулю при p®0 (т.е. в установившемся режиме). Поэтому обязательно наличие параллельного либо P, либо I-канала, а чаще обоих:

u(t) = (k1 + k2/p + k4 p) x(t) .

В таком варианте регулятора управляющее воздействие будет образовываться даже когда x(t)=0, но dx/dt№0. Т.е. наличие параллельного D-канала в регуляторе повышает быстродействие системы и снижает ошибки в динамике.

Сегодня техническая реализация регуляторов, чувствительных к производным более высоких порядков, затруднена.


Устойчивость систем

Устойчивость САР

Рабочие файлы: [Начальные условия / Параметры & Устойчивость]

Понятие устойчивости системы регулирования связано с ее способностью возвращаться в состояние равновесия после исчезновения внешних сил, которые вывели ее из этого состояния.

Понятие устойчивости можно распространить и на случай движения САР:

  • невозмущенное движение,
  • возмущенное движение.

Определение устойчивости по М. Я. Ляпунову

Невозмущенное движение (при D xi Ґ=0) называется устойчивым по отношению к пременным xi, если при всяком заданном положительном числе A2, как бы мало оно нибыло, можно выбрать другое положительное число l2(A2) так, что для всех возмущений D xi0, удовлетворяющих условию:

,

возмущенное движение будет для времени t і T удовлетворять неравенству:

,

где: m i - коэффициенты, уравновешивающие размерности величин D xi0.

Если с течением времени lim D xi®0, то система ассимптотически устойчива.

Понятие о характеристическом уравнении

Было сказано, что устойчивость системы связана с природой самой системы, а не с тем, как внешние источники движущих сил (задание, помехи) заставляют перемещаться ее координаты. Очевидно, что невозможно описать цепь преобразования энергии (систему) не учитывая источников. Поэтому в правой части ДУ описывающих систему всегда будут присутствовать источники движущих сил (вспомните как записываются уравнения по II закону Кирхгофа). Однако если их обнулить, то система ДУ не потеряет смысла. После отключения источников в любой линейной цепи преобразования энергии возникнет переходный процесс обусловленный энергией, которую накопили пассивные реактивные элементы цепи (собственный переходный процесс). Именно он определит, будет ли система устойчивой. И именно эта система ДУ, в которой обнулены величины источников движущих сил, называется характеристической. Если система характеристических ДУ решена относительно одной из координат, то она называется характеристическим уравнением.

Условие устойчивости. Типы границы устойчивости

Устойчивость систем зависит от корней характеристического уравнения, поскольку его решение есть сумма экспоненциальных функций:

.

Рассмотрим варианты свободного движения систем от ненулевого начального положения:

Влияние знака вещественной части корня ХУ на вид преходного процесса

Заметим, что:

C1 e -(a+j b)t + C2 e -(a-j b)t = A e -a t sin(b t+j) ,

где: A и j - новые постоянные интегрирования, a - показатель затухания, b - круговая частота затухающих колебаний.

Область устойчивости (для корней) Таким образом, для затухания переходного процесса и устойчивости линейной системы необходимо и достаточно, чтобы вещественные части корней были отрицательными, те лежали слева от мнимой оси плоскости корней.

Система будет находиться на границе устойчивости при наличии:

  • нулевого корня,
  • пары чисто мнимых корней,
  • бесконечного корня.

Необходимое условие устойчивости САР,
достаточное только для систем 1-ого и 2-ого порядков

Чтобы корни ХУ имели отрицательные вещественные части, необходимо чтобы все его коэффициенты были положительны. Однако это условие является достаточным только для систем 1-ого и 2-ого порядков. Док-во:

ХУ

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 ,

представим в виде:

a0 (s - s1) (s - s2) ... (s - sn-1) (s - sn) = 0 ,

где: s1, s2, ... sn-1, sn - корни.

В устойчивой системе вещественные части корней отрицательны.
            Подставим такие корни: s1 = -a1;
            s2 = -a2;
            s34 = -a3±j b ...
            :

a0(s+a1)(s+a2)(s+a3-j b)(s+a3+j b)
                ... = a0(s+a1)(s+a2)((s+a3)2+b2)
                ... = 0

Если раскрыть скобки и вернутся к стандартному виду ХУ, то все коэффициенты уравнения получатся положительными.

Критерий устойчивости Гурвица

Чтобы все корни ХУ:

a1 | a3 | a5 | a7 | ... | 0 | 0
a0 | a2 | a4 | a6 | ... | 0 | 0
0 | a1 | a3 | a5 | ... | 0 | 0
0 | a0 | a2 | a4 | ... | 0 | 0
... | ... | ... | ... | ... | ... | ...
0 | 0 | 0 | 0 |  | an-1 | 0
0 | 0 | 0 | 0 |  | an-2 | an

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 ,

имели отрицательные вещественные части, необходимо, при a0 > 0 выполнение условия: все n определителей Гурвица получаемые из квадратной матрицы коэффициентов должны быть положительны. Матрицы, для расчета определителей, получаются из исходной последовательным исключением последних столбца и строки.

Условие нахождения системы на границе устойчивости - D n = 0. Но D n = an D(n-1) = 0, следовательно, если an = 0, то наблюдается апериодическая граница устойчивости (нулевой корень - астатическая система), а если D(n-1) = 0, то - колебательная граница устойчивости (комплексные корни).

Критерий устойчивости Михайлова

Рабочие файлы: [fr_ABCD.mcd]

Чтобы все корни ХУ:

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 ,

имели отрицательные вещественные части, необходимо чтобы после подстановки частоты в соответствующий характеристический полном D(s) полное приращение его фазы при изменении w от 0 до Ґ составляло n p/2, где: n - степень полинома D(s). При этом характеристический полином опишет в комплексной плоскости кривую - "годограф Михайлова".

Док-во: Представим D(s) в виде разложения на линейные множители и выполним подстановку s=j w:

D(j w) = a0 (j w - s1) (j w - s2) ... (j w - sn) ,

где: s1, s2, ..., sn - корни ХУ. Скобки идентичны, поэтому рассмотрим одну из них. Возможны четыре основных варианта:

Пусть si=a, - вещественный положительный корень. Тогда годограф соответствующего линейного множителя (j w - a) при изменении w от 0 до Ґ повернется на угол -p/2.

Пусть si=-a, - вещественный отрицательный корень. Тогда годограф соответствующего линейного множителя (j w + a) при изменении w от 0 до Ґ повернется на угол p/2.

Пусть si;i+1=a±j b, - сопряженные корни с положительной вещественной частью. Тогда годографы соответствующих линейных множителей (j w - a - j b)(j w - a + j b) при изменении w от 0 до Ґ повернутся на углы -p/2+g, и -p/2-g. Вектор, соответствующий произведению двух сомножителей, повернется на угол равный -p.

Пусть si;i+1=-a±j b, - сопряженные корни с отрицательной вещественной частью. Тогда годографы соответствующих линейных множителей (j w + a - j b)(j w + a + j b) при изменении w от 0 до Ґ повернутся на углы p/2-g, и p/2+g. Вектор, соответствующий произведению двух сомножителей, повернется на угол равный p.

Резюме: Если ХУ имеет l корней с положительной вещественной частью, то угол поворота годографа D(j w) при изменении w от 0 до Ґ составит:

y = - l p/2 + (n - l) p/2 = n p/2 - l p ,

где: n - порядок ХУ.

Свойства годографа Михайлова

  • Годограф всегда спиралевиден.
  • При w=0, будетy=0, следовательно годограф начинается с точки на оси "+1".
  • Поскольку при w®Ґ K(j w)®0 (нет безинерционных систем), годограф уходит в бесконечность.
  • При четном n, годограф стремится к Ґ параллельно оси "+1"; при нечетном n, годограф стремится к Ґ параллельно оси "+j".

Определение типа границы устойчивости по виду годографа Михайлова

Оценка типа границы устойчивости по виду годографа Михайлова

  1. Астатизм первого порядка - "апериодическая" граница устойчивости.
  2. Астатизм второго порядка - "апериодическая" граница устойчивости.
  3. "Колебательная" граница устойчивости.
  4. Граница устойчивости типа "бесконечный корень".

Критерий устойчивости Найквиста

Рабочие файлы: [fr_ABCD.mcd]

Чтобы система в замкнутом состоянии была устойчивой необходимо и достаточно, чтобы при изменении w от -Ґ до +Ґ годограф разомкнутой системы W(j w) (АФХ), поворачиваясь вокруг начала координат по часовой стрелке, охватил точку (-1, j0) столько раз, сколько корней в правой полуплоскости содержит знаменатель W(j w).

Примечания:

  1. Если корней в правой полуплоскости нет, то годограф W(j w) не должен охватить точку (-1, j0).
  2. Неустойчивая система в разомкнутом состоянии может быть устойчивой в замкнутом состоянии. И наоборот.
  3. Годограф W(j w) всегда начинается на оси "+1". Но при порядке астатизма равном r, по причине устремления W(j w) к Ґ (при w®0), видимая часть годографа появляется только в квадранте r, отсчитанном по часовой стрелке.

Док-во:

Рассмотрим ПФ для статической САР сдвинутую на величину (-1, j0):

W1(s) = 1+ W(s) = Q(s)/Q(s) + R(s)/Q(s) = D(s)/Q(s) ,

в ней D(s) - характеристический полином, Q(s) пусть не имеет корней в правой полуплоскости (пусть W(s) устойчива).

Рассмотрим угол поворота годографа W1(s). Он равен j = j1(D(j w)) - j2(Q(j w)). Поскольку степень полинома R(s) всегда меньше степени полинома Q(s), то степени полиномов числителя и знаменателя ПФ W1(s) равны. Следовательно при изменении w от -Ґ до +Ґ: j1(D(j w))=n p - (по критерию Михайлова), j2(Q(j w))=n p - (по предположению об отсутствии корней в правой полуплоскости у полинома Q(s)). Т.е. j=n p-n p=0. Другими словами для устойчивости САР в замкнутом состоянии W1(j w) не должна охватывать начала координат, а функция W(j w) - точку (-1, j0).

Если знаменатель будет содержать l корней в положительной полуплоскости, то угол поворота годографа W(j w) должен составить величину:

j = j1(D(j w)) - j2(Q(j w)) = n p - [(n - l) p - l p] = l 2p ,

что и требовалось доказать.

Свойства годографа Найквиста

  1. К пояснению вида годографа консервативного звена Годограф Найквиста спиралевиден.
  2. При w®Ґ годограф W(j w)®0, т.к. нет безинерционных систем.
  3. Годограф статических САР начинается из точки на вещественной оси.
  4. Для положительных и отрицательных частот годографы зеркально симметричны относительно оси "+1".
  5. Наличие корней на границе устойчивости приводит к устремлению годографа в Ґ и приращению его фазы на -1800.

Примеры годографов Найквиста статических САР (wО[0...+Ґ))

Примеры годографов Найквиста статических САР

  1. САР на колебательной границе устойчивости.
  2. Абсолютно устойчивая САР (устойчива при любом уменьшении K).
  3. Неустойчивая САР.
  4. Условно устойчивая САР (только при изменении K в некотором диапазоне).

Примеры годографов Найквиста астатических САР и САР с чисто мнимыми корнями

Примеры годографов Найквиста астатических САР и САР с корнями, близко расположенными к мнимой оси

  1. Устойчивая САР с астатизмом первого порядка.
  2. Устойчивая САР с астатизмом второго порядка.
  3. Устойчивая САР с астатизмом третьего порядка.
  4. Неустойчивая САР с консервативным звеном.
  5. Устойчивая САР с консервативным звеном (коррекция выполнена фазовращающим звеном).

Определение устойчивости по логарифмическим частотным характеристикам

Рабочие файлы: [fr_ABCD.mcd]

Для определения устойчивости по критерию Найквиста можно строить не АФХ, а ЛАЧХ & ЛФЧХ разомкнутой системы.

Чтобы замкнутая система была устойчива, необходимо и достаточно, чтобы сдвиг фазы на частоте единичного усиления разомкнутой системы W(j w) не достигал значения -1800.

Если система условно устойчивая, то при модулях больших единицы, фазовый сдвиг может достигать значения -1800 четное число раз.

Построение областей устойчивости - D-разбиение

Пусть имеем произвольную передаточную функцию систем:

,

и требуется оценить влияние разброса параметров на устойчивость.

Выделим два параметра (K и Ti), влияние которых на устойчивость следует оценить. Остальные параметры зафиксируем. Воспользуемся алгоритмом:

Итог итерационного алгоритма - область устойчивости (D-разбиение) ограниченная осями и графиком (уменьшение K и одной из постоянных времени объекта, как правило, положительно сказывается на устойчивости).

При заданной частоте существует только одна координата (K, Ti), которой будет соответствовать положение системы на границе устойчивости.

Наиболее удобно в итерационном алгоритме для системы любого порядка использовать критерий Михайлова, тогда уравнение границы:

D(j w) = 1+ W(j w) = 1 + R(j w)/Q(j w) = R(j w) + Q(j w) = 0,
т.е. K (1 + T3(j w)) ... + j w(1 + T1(j w)) (1+T2(j w)) ... = 0


Оценка качества регулирования

Качество любой системы регулирования определяется величиной ошибки:

x(t) = g(t) - y(t) = F x(p) g(t)

Но функцию ошибки x(t) для любого момента времени трудно определить, поскольку она описывается с помощью ДУ системы - F x(p) - высокого порядка, и зависит от большого количества параметров системы. Поэтому оценивают качество САР по некоторым ее свойствам, определяют которые с помощью критериев качества.

Критериев качества регулирования много. Их разделяют на 4 группы:

  1. Критерии точности - используют величину ошибки в различных типовых режимах.
  2. Критерии величины запаса устойчивости - оценивают удаленность САР от границы устойчивости.
  3. Критерии быстродействия - оценивают быстроту реагирования САР на появление задающего и возмущающего воздействий.
  4. Интегральные критерии - оценивают обобщенные свойства САР: точность, запас устойчивости, быстродействие.

Существует два основных подхода к оценке качества:

  1. Первый использует информацию о временных параметрах системы: h(t), w(t); расположение полюсов и нулей ПФ замкнутой системы F(s).
  2. Второй использует информацию о некоторых частотных свойствах системы: полоса пропускания; относительная высота резонансного пика; и т.д.

Точность в типовых режимах

Рабочие файлы: [ok_ast.vsm]

Для оценки точности используется величина ошибки в различных типовых режимах. Типовые режимы движения состоят в подаче на вход сигналов с нормированными метрологическими характеристиками. Различают типовые режимы:

  1. Ненулевое, неподвижное состояние.
  2. Движение с постоянной скоростью.
  3. Движение с постоянным ускорением.
  4. Движение по гармоническому закону.

Сигналы задания для типовых режимов движения, их модели и изображения по Карсону-Хевисайду

Сигналы задания для типовых режимов движения

На рис. показаны режимы: ненулевого, неподвижного положения координаты; движение с постоянной скоростью; движение с постоянным ускорением. Легко понять, что перемещение координаты с постоянной скоростью легко получить интегрированием постоянного сигнала, а для получения координаты движущейся с постоянным ускорением необходимо интегрировать координату перемещающуюся с постоянной скоростью. Заменив операцию интегрирования оператором, получим изображения по Карсону-Хевисайду.

Ошибки статической системы

Здесь и далее будем рассматривать установившиеся составляющие ошибки системы в типовых режимах движения. Для чего будем анализировать уравнение ошибки:

,

где: g0+v/s+e/s2 - изображение представленного рядом Тейлора входного сигнала; s®0 соответствует установившемуся режиму.

Итак, если ПФ САР W(s) статическая, т.е. в области низких частот W(s)|s®0®K. Тогда первая составляющая ошибки:

,

т.е. в статической системе ошибка, вызванная заданием равным константе, так же константа, но меньшая на величину 1+K, а ошибки от заданий меняющихся с постоянными скоростью или ускорением нарастают до бесконечности.

Ошибки системы с астатизмом первого порядка

Если ПФ САР W(s) обладает астатизмом первого порядка, т.е. в области низких частот W(s)|s®0®Kv/s. Тогда первая составляющая ошибки:

,

т.е. в астатической системе первого порядка ошибка от задания равного константе равна нулю, ошибка от задания меняющегося с постоянной скоростью равна xv=v/Kv, а ошибка от задания меняющегося с постоянным ускорением нарастает до бесконечности.

Ошибки системы с астатизмом второго порядка

Если ПФ САР W(s) обладает астатизмом второго порядка, т.е. в области низких частот W(s)|s®0®Ke/s2. Тогда первая составляющая ошибки:

,

т.е. в астатической системе второго порядка ошибки от заданий равного константе и изменяющегося с постоянной скоростью равны нулю, а ошибка от задания меняющегося с постоянным ускорением равна константе xe=e/Ke.

Качество САР с астатизмом принято характеризовать величинами, называемыми добротностью по скорости и ускорению:

.

О компенсации помех в астатических системах

Астатическая система под воздействием помех

Рассмотрим вторую составляющую ошибки x''уст от возмущающих воздействий fko. Если САР астатическая, то W(s)|s®0®Ґ, но возможен случай, когда Wfk(s)|s®0®Ґ. Т.е. при любой степени астатизма САР x''уст может быть отличной от нуля.

.

Резюме:

  1. Для подавления ошибки от возмущения необходимо, чтобы интегрирующий элемент был включен в контур до места приложения возмущения.
  2. Если рассматривать ошибку чувствительного элемента (сумматора) как возмущение, то, очевидно, что повышение степени астатизма не позволяет устранить ее.

Ошибка при движении по гармоническому закону g(t)=Gmsin(w kt)

Рассмотрим только первую составляющую ошибки:

x'уст = g(t) / [1+W (s)] = Xmsin(w kt+j)

где: g(t) - синусоида; [1+W (s)] - комплексное число.

Следовательно:

(1)

Xm = Gm / |1+W (j wk)| » Gm / A(wk).

Резюме:

  1. Формула (1) позволяет идентифицировать положение неизвестной ЛАЧХ на данной частоте по амплитуде ошибки или сформулировать требования к ЛАЧХ при синтезе системы.
  2. Особые точки ЛАЧХ определены комплексными сопряженными корнями. Поведение системы при данных частотах (w k=|j b k|) требует дополнительного исследования.
  3. Особенность движения системы при гармоническом сигнале задания - это смена знака координат, которое во многих системах может сопровождаться нелинейными искажениями типа "ступенька" или сменой направления сил сухого трения.

Коэффициенты ошибок

Рабочие файлы: [c1c2c3.vsm] [c1c2c3_is.vsm]

Пусть известна ПФ по ошибке F x(s), тогда:

X(s) = F x(s) G(s) = 1/(1+W(s)) G(s)

где: G(s) - изображение функции g(t).

Разложим F x(s) в ряд Тейлора:

(2)

X(s) = [c0 + c1s/1! + c2s2/2! + c3s3/3! + ...] G(s) ;

перейдем к оригиналу:

x(t) = c0g(t) + c1g'(t)/1! + c2g''(t)/2! + c3g'''(t)/3! + ...

Величины c0, c1, c2, ..., cm - называют коэффициентами ошибок. Их можно определять двумя способами:

  1. c0 = F x(s)|s®0, cm = [dm F x(s)/dsm]|s®0
  2. Делением числителя F x(s) на знаменатель и сравнением с рядом (2).

Примечания:

  1. Коэффициенты ряда (2) непосредственно связанны с коэффициентом усиления САР, добротностями Kv, Ke, ...
    Система \ Ошибки | K & c0 | Kv & c1 | Ke & c2
    W(s)=1/s0 * ... | K & 1/1+K | 0 & ... | 0 & ...
    W(s)=1/s1 * ... | Ґ & 0 | Kv & 1!/Kv | 0 & ...
    W(s)=1/s2 * ... | Ґ & 0 | Ґ & 0 | Ke & 2!/Ke
  2. САР астатическая сигналу задания g(t) может быть статической для f (t), поэтому равенство нулю коэффициентов c0, c1, c2, ... для сигнала g(t) не обязательно означает равенство нулю коэффициентов c0, c1, c2, ... для сигнала f (t).
  3. Ограничение количества членов ряда (2) и предположение о постоянстве коэффициентов ошибок c0, c1, c2, ... определяет применение метода для плавно меняющихся сигналов g(t) и f (t), когда переходная составляющая в движении системы успевает затухнуть.

Оценка запаса устойчивости и быстродействия по переходной характеристике

Оценка запаса устойчивости и быстродействия по переходной характеристике

Запас устойчивости САР оценивают по величине перерегулирования:

s = (ymax - yҐ) / yҐ100, [%]

Варианты s | 0 % | 10..30 % | 50..70 %
Применяемость | редко | часто | избегают
Запас по фазе | 900 | 600..300 | 300..100
Число колебаний | 0 | 1, 2 | 3, 4, ...

Быстродействие САР оценивают по времени окончания переходного процесса tп, при заданной допустимой ошибке (трубке):

D О 5; 2,5; 1,5; 1; 0,5; ... [%] от yҐ , - установлено ГОСТ-ами.

Частоту единичного усиления разомкнутой системы wср можно оценить по частоте колебаний переходной функции.

Область допустимых значений регулируемой величины Примечание: При синтезе САР используют область допустимых отклонений регулируемой величины.

Время нарастания ограничено:

  • tн min - допустимым ускорением координат и предельными колебательными режимами;
  • tн max - требуемым быстродействием.

На рис. tз - максимальное допустимое время запаздывания (распространения) сигнала.

Корневые методы оценки качества

Поскольку корни ПФ однозначно определяют вид переходного процесса, их можно использовать для оценки: 1) запаса устойчивости и, 2) быстродействия.

Примечание: Обычно обходятся исследованием только полюсов ПФ F(s), т.е. корней характеристического уравнения 1+W(s)=0.

Система будет склонна к колебаниям, если имеются комплексные корни вида -a±j b. Оценить эту склонность можно используя показатель запаса устойчивости - колебательность:

m = b/a, 0 < m < Ґ

где: a - коэффициент затухания; b - круговая частота колебаний.

Колебательность определяет другой показатель - затухание амплитуды колебаний x(t) = Ce -a t sin(b t+j) за период: Допустимая область расположения корней системы, удовлетворяющей заданному показателю колебательности или затуханию за период

Связь между показателями: затуханим за период и колебательностью.

Задание определенной колебательности заставляет ограничить область расположения корней.

Колебательность системы m можно найти используя подстановку s = z e j(90-j), что соответствует повороту осей плоскости корней на угол (90-j). Далее, используя любой критей устойчивости, подбирают угол j, при котором система будет находиться на границе устойчивости. И тогда: m = tg j = b/a.

Для оценки быстродействия может использоваться понятие степени быстродействия h - это абсолютное значение вещественной части ближайшего к мнимой оси корня. Т.е. если этот корень -a±jb, то h равна коэффициенту затухания a.

И действительно, составляющая в переходном процессе xh(t) = Che -h tsin(b t+j), затухает тем медленней, чем меньше h. Если в конце переходного процесса амплитуда колебаний равна D Ch, то веремя переходного процесса: Допустимая область расположения корней системы, дополнительно удовлетворяющей заданному показателю степени быстродействия

.

Задание определенной степени быстродействия заставляет ограничить область расположения корней.

Степень быстродействия h можно найти используя постановку s = z - hvar, что соответствует смещению корней на величину hvar. Далее, используя любой критерий устойчивости, подбирают значение hvar, при котором система будет на границе устойчивости. И тогда: h=hvar.

Понятие о среднегеометрическом корне W0. Мажоранта и миноранта переходной функции

Пусть имеем характеристическое уравнение:

a0 s n + a1 s n-1 + ... + an-1 s + an = 0 .

Приведем его к нормированному виду (разделим на an и выполним подстановку [image]):

q n + a1/an (W0 q) n-1 + ... + ak/an (W0 q) n-k +...+ 1 = 0 ,

где: Среднегеометрический корень - среднегеометрический корень.

Влияние величины среднегеометрического корня на радиальное смещение корней Для статических САР an = 1 + K, для астатических an = K, a0 = T1 T2 ... Tn; следовательно увеличивая K можно увеличить W0. На основании теоремы подобия увеличение W0 вызовет пропорциональное радиальное смещение корней. Т.е. вид переходного процесса меняться не будет, но будет меняться его временной масштаб. Поэтому среднегеометрический корень W0 является мерой быстродействия.

Для приведенного уравнения время будет безразмерным t = W0 t, переходная функция h(t) в случае кратных вещественных корней или одной пары комплексных будет ограничена минорантой и мажорантой:

Мажоранты и миноранты переходных функций h(t) дла кратных вещественных корней 1-u(h, t) < h(t) < 1+u(h, t) ,

где: u(h, t) = e -h t [1 + (h t)1/1! + (h t)2/2! + ... + (h t)n-1/(n-1)! ] - разложение в ряд Тейлора огибающей той составляющей в пререходном процессе, корень которой ближе к оси "+j".

На рис. демонстрируется, что любой переходный процесс в любой системе будет затухать тем медленней, чем больше корней вблизи оси "+j".

Интегральные оценки качества

Рабочие файлы: [ok_absx_s.vsm]

Интегральные оценки дают обобщенную оценку быстроты затухания и величины отклонения регулируемой величины, в виде единого числового значения.

Находят применение первые три ИТ-оценки из перечисленных в списке:

  1. I1 и I2 - линейные ИТ-оценки (не чувствительны к высшим производным координат САР).
  2. I и I' - квадратичные ИТ-оценки (первая не чувствительна к высшим производным координат САР; вторая – к неподвижному режиму).
  3. I+T12I' - улучшенная квадратичная ИТ-оценка (чувствительна к постоянной и к скоростной составляющим в движении координат САР).
  4. I+T12I'+T24I''+... - ИТ-оценки более высоких порядков (чувствительны к постоянной составляющей в движении координат САР, к их скорости, к ускорению, ...).

Пусть имеем переходные функции h(t).

Рассмотрим линейные ИТ-оценки:

Линейные интегральные оценки.

Очевидно, что чем меньше значение оценки I1 или I2, тем лучше переходный процесс, но:

  1. Оценка I1 не может применяться к колебательному переходному процессу.
  2. Аналитическое вычисление оценки I2 по коэффициентам уравнения ошибки затруднено.
  3. Одно значение оценки I2 может соответствовать переходным процессам с разной колебательностью (если совпадают мажоранты и миноранты).

Ограничения "a" и "b" для оценок I1 и I2 преодолеваются квадратичными ИТ-оценками I и I' :

Квадратичные интегральные оценки.

Заметим, что оценку I' можно получить нахождением оценки I, если подать на вход САР не ступенчатую 1(t), а дельта функцию d(t)=1'(t). Применение оценки I' ограничено тем, что она не чувствительна к установившемуся значению ошибки xҐ.

Ограничение "c" и другие ограничения оценок I1, I2, I и I' снимаются улучшенной квадратичной ИТ-оценкой:

Улучщенная квадратичная интегральная оценка,

где: x0 - начальное значение отклонения в переходном процессе; I+T12I' – не формула, а составной символ обозначения данной ИТ-оценки.

Очевидно, что I+T12I' будет минимальна при T1x'+x = (T1p+1)x = 0. Решение этого ДУ есть экспонента: , а [image].

Т.е. улучшенная квадратичная ИТ-оценка I+T12I' будет иметь минимум при приближении переходной функции к экспоненте с заданной постоянной времени T1.

Можно использовать улучшенные ИТ-оценки более высоких порядков. Например:

Улучщенная квадратичная интегральная оценка второго порядка.

Здесь оценка будет иметь минимум, только при перемещениях координат САР с определенными скоростью и ускорением, которые задаются постоянными времени T1 и T2 соответственно. Идея другого способа выбора параметров оценки заключена в том, что коэффициенты ДУ второго порядка можно выразить в виде затухания z и резонансной частоты q, которыми должна обладать настраиваемая САР.

Аналитический расчет квадратичных ИТ-оценок

Для аналитического расчета можно воспользоваться теоремой Парсеваля:

.

Если ошибка x(t) = yҐ - y(t), то ее изображение:

Надо сделать проще - здесь сразу записать Фx (jw) и не мучиться.

Для нахождения I и I' мы должны подавать сигналы 1(t) и 1'(t). Их изображения Фурье соответственно равны:

.

Тогда установившиеся значения выходной координаты и, соответственно, значения ПФ для этих режимов:

yҐ = 1, F(0) = 1 и yҐ = 0, F(0) = 0.

В итоге изображения ошибок:

А квадратичные ИТ-оценки:

.

Частотные критерии качества

Частотные критерии качества применяют, когда известны или можно определить экспериментально частотные свойства САР (АФХ, АЧХ, ЛАЧХ & ЛФЧХ). Вид переходного процесса при этом не рассматривается.

Оценить частотными критериями можно:

  1. Запас устойчивости (b; m1; M)
  2. Быстродействие САР (wр; wср; wп; wэк).

Оценка запаса устойчивости

Запретная область для АФХ на основе запасов устойчивости по амплитуде и фазе

По виду АФХ разомкнутой системы оценивают запас устойчивости:

  • по амплитуде - L1=20lgb1 и L2=20lgb2
  • по фазе m1=180+j1

где: j1 - запаздывание по фазе на частоте единичного усиления при |W(j w)|=A(w)=1 или L(w)=0 (по ЛАЧХ).

Для абсолютно устойчивых систем (n<3) имеет смысл только величина L1, т.к. L2®Ґ. Для хорошо демпфированных систем bО[2...10), т.е. [6...20) дБ.

Запас устойчивости тем больше, чем больше b и m1. Используя b и m1 можно задать запретную область для АФХ. Но недостаток заключен в том, что если АФХ будет касаться запретной области в разных точках, перерегулирование s будет разным.

Если имеется АЧХ замкнутой системы |F(j w)|, то удобным критерием запаса устойчивости является показатель колебательности: Определение показателя колебательности M по максимальному значению AЧХ системы в замкнутом состоянии, и (опосредованно) запаса устойчивости

Показатель колебательности - M,

равный максимальному значению АЧХ замкнутой системы приведенной к коэффициенту усиления в области низких частот. Т.е. вынужденное движение на резонансной частоте будет иметь амплитуду в M раз большую, чем в области низких частот. И чем больше M, тем меньше запас устойчивости.

Если имеется только АФХ разомкнутой системы W(j w), то показатель колебательности M удобно использовать в виде фоновой сетки, которой можно пользоваться как линиями уровня M О [1/4; 1/2; 1; 0,707; 1,41; 2; 4]. Выполним расчет сетки:

Сетка показателя колебательности M на АФХ - W(jw)

где: (1) - уравнение окружности с радиусом R, и центром в точке C.

Оценка быстродействия САР

Оценить быстродействие можно по частотным характеристикам замкнутой и разомкнутой системы, используя:

  1. |F(j w)| - АЧХ замкнутой системы
  2. P(w) = Re(F(j w)) - вещественную ЧХ
  3. W (j w) - АФХ разомкнутой системы
  4. ЛАЧХ & ЛФЧХ
  5. ...

При этом в качестве критериев используют величины:

  • wр - резонансная частота, соответствует пику АЧХ, близка к частоте колебаний в переходном процессе;
  • wср - частота среза, соответствующая условию |W(j wср)|=A(wср)=1 или L(wср)=0 (по ЛАЧХ).
  • wп - частота соответствующая полосе пропускания замкнутой системы F(j w), определяемая из условия A(wп)=0,707.
  • wэ - эквивалентная полоса пропускания замкнутой системы: wэ = oҐ т |F(j w)|2 dw, - эта величина связана с вопросом пропускания системой помех. Кроме того, если ее рассчитать, включая отрицательные частоты, причем в герцах, то она совпадет с квадратичной ИТ-оценкой I'.


Повышение точности систем

Повышение точности САР

Задача повышения точности САР обычно предполагает существенный пересмотр ее структуры. Возможны замены или добавления отдельных звеньев в контуре.

Общими методами повышения точности САР являются:

  1. Увеличение коэффициента усиления K разомкнутой цепи
  2. Повышение порядка астатизма r
  3. Применение регулирования по производным
  4. Использование комбинированного управления
  5. Введение неединичных обратных связей
  6. Включение масштабирующих устройств на входе или выходе

Повышение точности систем увеличением коэффициента усиления

Рассмотрим задачу повышения точности системы второго порядка, состоящей из 2х апериодических звеньев.

Повышение точности системы увеличением коэффициента усиления

Повышение точности системы увеличением коэффициента усиления Ошибка системы:
,
будет тем меньше, чем больше K.

Очевидно так же, что первые коэффициенты ошибок не будут равны нулю, но будут тем меньше, чем больше K:

Т.е. увеличение K уменьшает ошибки во всех типовых режимах.

Метод эффективен, широко применяется, но обычно увеличение K приводит к уменьшению запаса устойчивости (см. ЛАЧХ & ЛФЧХ)

Повышение точности систем увеличением порядка астатизма

Повышение порядка астатизма используется для устранения установившихся ошибок в типовых режимах движения.

Повышение точности системы увеличением порядка астатизма

Повышение точности системы увеличением порядка астатизма Применением интегрирующих или изодромных звеньев стремятся свести к нулю первые коэффициенты ошибок системы:

или

где: Kv = Ki K ; Ke = Ki1 Ki2 K.

Очевидно, что последовательное включение уже 2-х интеграторов приведет к появлению структурной неустойчивости, когда ни при каком значении общего коэффициента усиления невозможно получить устойчивую систему.

Это затруднение можно преодолеть использованием изодромных устройств:

Передаточная функция изодромного устройства

Повышение точности системы увеличением порядка астатизма

Повышение точности системы увеличением порядка астатизма По ЛАЧХ & ЛФЧХ видно, что постоянную времени изодромных звеньев Ti надо брать большой, дабы вносимый ими фазовый сдвиг не был существенным в области частоты среза wср и не влиял на устойчивость системы.

Поскольку постоянные времени изодромных устройств Ti, обычно, самые большие в системе, то определенные ими составляющие в переходном процессе затухают наиболее медленно, ухудшая тем самым динамические свойства системы. Это видно и по необращенным в ноль коэффициентам ошибок, поскольку коэффициент усиления интегратора в изодромном устройстве Ki=1/Ti обычно меньше единицы.

Повышение точности систем применением регулирования по производным от ошибки

Использование регулирования по производным от ошибки, позволяет повысить точность системы, поскольку:

  1. Система начнет чувствовать не просто наличие ошибки, но и тенденцию к ее изменению.
  2. Повышается запас устойчивости по фазе и можно поднять общий коэффициент усиления.

Повышение точности системы использованием регулирования по производным от ошибки

Повышение точности системы использованием регулирования по производным от ошибки Раскладывая в ряд ПФ системы по ошибке Fx(s), получим соотношения для ошибок:

Сравнивая полученные коэффициенты с исходными можно увидеть, что все, кроме c0, уменьшаются. При соответствующем выборе Td можно обратить в ноль один из старших коэффициентов c1, или c2, или ...

Последовательное включение 2х пропорционально-дифференцирующих элементов, позволяет обратить в ноль два старших коэффициента ошибки.

Повышение точности систем применением комбинированного управления

САР является инвариантной по отношению к задающему или возмущающему воздействию, если после завершения переходного процесса, определяемого начальными условиями, ошибка системы не зависит от этого воздействия.

Снижение ошибки от сигнала задания введением сигнала КУ на входе регулятора

Рабочие файлы: [пример]

Повышение точности системы использованием комбинированного управления Мысленно поменяем сумматоры местами, тогда для структурной схемы очевидно:

где: Fэк(s) - эквивалентная ПФ для данной системы.

Условие полной инвариантности к сигналу задания - условие полной инвариантности к g(t) (оно наблюдается, если выходной сигнал четко повторяет входной, поэтому его можно получить, приравняв Fэк(s) к 1 или же Fx.эк(s) к нулю, т.к. Fx.эк(s) = 1- Fэк(s)).

Разложим 1/W(s) в ряд по возрастающим степеням оператора, тогда: j(s)=a0+t1s+t22s2+t33s3+..., т.е. ПФ j(s) должна состоять из масштабирующего (a0<<1) и дифференцирующих звеньев (t1s, t22s2, t33s3, ...).

Снижение ошибки от сигнала задания введением сигнала КУ после регулятора

Повышение точности системы введением сигнала КУ после регулятора Преобразованная эквивалентная структурная схема используемая для вывода условия инвариантности к сигналу задания

На рисунке показаны структурные схемы исходной и преобразованной системы. Для последней легко записать уравнение движения:

Условие полной инвариантности к сигналу задания - условие полной инвариантности к g(t) (оно наблюдается, если выходной сигнал четко повторяет входной, поэтому его можно получить, приравняв Fэк(s) к 1 или же Fx.эк(s) к нулю, т.к. Fx.эк(s) = 1- Fэк(s)).

Снижение ошибки от возмущающего сигнала применением КУ

Снижение ошибки от возмущающего сигнала применением КУ Для данной системы ПФ по возмущению имеет вид:

Условие полной инвариантности к сигналу помехи - условие полной инвариантности к f(t) (можно получить, приравняв F f(s) к нулю).

Достоинство КУ:

  • Поскольку знаменатели функций F(s) (исходной) и Fэк(s) равны, введение j(s) не меняет характеристического уравнения системы, следовательно, не нарушаются условия устойчивости.

Недостатки КУ:

  • Требуется точная подстройка коэффициентов ПФ j(s).
  • При изменении параметров W(s) появляются ошибки.
  • Практическая реализация дифференцирующих звеньев высокого порядка затруднительна.

Повышение точности систем применением неединичных обратных связей

Рабочие файлы: [пример]

Повышение точности системы использованием неединичных обратных связей Введение не 1-ых ОС (j(s)) позволяет уменьшить ошибку вызванную задающим воздействием в замкнутой системе.

Для показанной на рисунке системы с не 1-ой ОС уравнение движения будет иметь вид:

Условие полной инвариантности к сигналу задания при не 1-ой ОС - условие полной инвариантности к g(t) (оно наблюдается, если выходной сигнал четко повторяет входной, поэтому его можно получить, приравняв Fэк(s) к 1 или же Fx.эк(s) к нулю, т.к. Fx.эк(s) = 1- Fэк(s)).

Разложим 1-1/W(s) в ряд по возрастающим степеням оператора, тогда: j(s)=1-(a0+t1s+t22s2+t33s3+...), те ПФ j(s) должна состоять из масштабирующего звена (1-a0, где a0<<1) создающего ООС по постоянной составляющей и дифференцирующих звеньев (t1s, t22s2, t33s3, ...), создающих ПОС по переменным составляющим сигнала. Заметим, что a0№0 только для статических систем.

Поскольку знаменатели функций F(s) (с 1-ой ОС) и Fэк(s) не равны, введение j(s) изменит характеристическое уравнение системы. А при полном выполнении условия инвариантности система буден находится на границе устойчивости.

Повышение точности систем применением масштабирующих устройств на входе или выходе

Повышение точности системы использованием масштабирующего устройства на входе Повышение точности системы использованием масштабирующего устройства на вхыходе


Коррекция систем

Коррекция САР

Задача коррекции состоит в повышении динамической точности САР в переходных режимах. Она возникает, поскольку стремление снизить ошибки регулирования в типовых режимах, приводит к необходимости использования таких значений общего коэффициента усиления, при которых без принятия спец. мер (внедрения пассивных звеньев) система оказывается неустойчивой.

Способы введения корректирующих звеньев

Три способа введения корректирующих звеньев

Результирующие ПФ:

 Формулы эквивалентных
переходов:

Показания к применению:

  • - последовательная коррекция - электрические цепи с немодулированными сигналами (легка в проектировании);
  • - параллельная коррекция - необходимость ВЧ-шунтирования инерционных звеньев;
  • - коррекция локальной ОС - необходимость уменьшения нелинейностей, дрейфа параметров или суммы постоянных времени (проста в реализации).

Частотные свойства последовательных корректирующих звеньев и их практическая реализация для электрического энергетического домена

Рабочие файлы: [zvenya_kor.vsm]

К основным корректирующим звеньям относятся:

  1. Пассивное интегрирующее звено
  2. Пассивное дифференцирующее звено
  3. Пассивное интегро-дифференцирующее звено
  4. Фазосдвигающее звено
  5. Антивибратор

Пассивное интегрирующее звено

Пассивное дифференцирующее звено

Пассивное интегро-дифференцирующее звено

где: T1 = (R1+R2)C2; T2 = R2C2; T3 = R1C1; T4 = (R1||R2)C1.

Схемы замещения пассивного интегро-дифференцирующего звена на разных частотах

Отмеченный участок ЛАЧХ корректирующих звеньев 1, 2 и 3, должен так изменить вид корректируемой ЛАЧХ, чтобы она в том же диапазоне частот пересекала ось частот с наклоном -20 дБ/дек.

Методы повышения запаса устойчивости

Рабочие файлы: [см.4&5]

Суть ВЧ, СЧ и НЧ демпфирования Общими методами повышения запаса устойчивости, те динамической точности являются:

  1. Демпфирование с подавлением высоких частот
  2. Демпфирование с подавлением средних частот
  3. Демпфирование с подавлением низких частот или эквивалентным поднятием высоких
  4. Демпфирование с введением дополнительных фазовых сдвигов

Демпфирование с подавлением высоких частот

Применяется сдержанно, поскольку при сохранении точности существенны потери в быстродействии - режется полоса пропускания.

Реализуется:

  1. C помощью апериодического звена с большой постоянной времени T0 - только для точных статических систем T0 і K T1 (подобный тип коррекции в ОУ).
  2. C помощью пассивного интегрирующего звена - для систем имеющих участок ЛАЧХ с наклоном -20 дБ/дек вблизи частоты единичного усиления (среза) wср, на которой наклон может составлять -40, -60, .. дБ/дек.

Коррекция апериодическим звеном Коррекция пассивным интегрирующим звеном

Демпфирование с подавлением средних частот

Применяется наиболее
часто, поскольку позволяет
сохранить точность САР и
полосу пропускания
(быстродействие).

Реализуется с помощью
пассивного интегро-
дифференцирующего
звена. Позволяет успешно
корректировать ЛАЧХ с
наклоном -40 дБ/дек.
Однако
корректирующее звено
вносит дополнительные
отрицательные фазовые
сдвиги в НЧ области. 		Коррекция пассивным интегро-дифференцирующим звеном

Демпфирование с подавлением низких частот или эквивалентным поднятием высоких

Применяется ограниченно, поскольку без восстановления коэффициента усиления в области низких частот, падает точность, а поднятие верхних частот расширяет полосу пропускания и увеличивает шумы в системе.

Реализуется с помощью пассивного дифференцирующего звена, которое не дает дополнительных отрицательных фазовых сдвигов в области низких частот и позволяет успешно корректировать ЛАЧХ с наклоном -40 дБ/дек. Компенсировать же падение коэффициента усиления D K = T3 / T4 можно, если только наклон -40 дБ/дек после частоты среза wср сохраняется более одной декады.

Коррекция пассивным дифференцирующим звеном Коррекция пассивным дифференцирующим звеном с компенсирующим увеличением коэффициента усиления


Синтез систем

Синтез САР

Синтез системы
Направленный расчет, имеющий конечной целью отыскание: 1) рациональной структуры системы и 2) установление оптимальных величин параметров отдельных звеньев.

При множестве возможных решений, должен быть выбран критерий оптимизации - цена, точность, надежность, быстродействие, затраты энергии ...

При инженерном синтезе ставятся задачи:

  1. Достижение требуемой точности.
  2. Обеспечение приемлемого характера переходных процессов (задача демпфирования).
  • Решение первой задачи заключено в выборе средств повышающих точность системы (усилительных, изодромных блоков; каналов КУ; не 1ОС), т.е. фактически вида регулирования.
  • Решение второй задачи заключено в выборе оптимальных корректирующих средств.

Метод логарифмических амплитудных характеристик

Процесс синтеза включает в себя следующие операции:

  1. Построение располагаемой ЛАЧХ исходной системы Wo, состоящей из регулируемого объекта без регулятора и без корректирующего устройства.
  2. Построение НЧ части желаемой ЛАЧХ на основе предъявленных требований точности.
  3. Определение вида и параметров регулятора K, Ki, ...:
    Wрег(s) = WНЧ.ж.(s) / Wo(s);

    Lрег(w) = LНЧ.ж.(w) - Lo(w ) .

  4. Уточнение ВЧ части желаемой ЛАЧХ на основе требований к запасу устойчивости - LНЧ&ВЧ.ж.(w).
  5. Определение вида и параметров последовательного корректирующего устройства:
    WПЗ кор = WНЧ&ВЧ.ж. / [Wрег Wo]; LПЗ кор = LНЧ&ВЧ.ж. - Lрег - Lo .
  6. Техническая реализация корректирующих устройств. В случае необходимости - перерасчет на эквивалентные параллельное звено или ОС.
  7. Поверочный расчет и построение переходного процесса.

Требования к НЧ части желаемой ЛАЧХ

Оценка точности САР по воспроизведению гармонического сигнала

Если: g(t) = Gmsin(w kt), то амплитуда Xm = |F x(j w k)| Gm = Gm / |1+W(j w k)|.

Поскольку Xm должна быть << Gm, то W(j w k) >> 1, следовательно Xm » Gm / |W(j w k)|.

Те, чтобы система воспроизводила сигнал с ошибкой, непревышающей Xm, ЛАЧХ системы должна проходить не ниже контрольной точки Ak с координатами: w = w k, L(w k) = 20lg |W(j w k)| = 20lg Gm/Xm.

Формирование запретной НЧ области для желаемой ЛАЧХ

Способ №1

Дано:

Xm - максимальная амплитуда ошибки;
Vm - максимальная скорость слежения;
Em - максимальное ускорение слежения.

Найдем связывающие отношения между амплитудой, скоростью и ускорением синусоидального сигнала:

g(t) = Gmsin(w kt)
g'(t) = Gm w kcos(w kt)
g''(t) = -Gm w k2sin(w kt) 		=> Vm = Gm w k
Em = Gm w k2 		=>

w k = Em / Vm
Gm = Vm2 / Em

  • Если зафиксировать Vm в сигнале и уменьшать w от w k, то Gm будет увеличиваться на 20 дБ за декаду (в 10 раз).
  • Если зафиксировать Em в сигнале и увеличивать w от w k, то Gm будет уменьшаться на 40 дБ за декаду (в 100 раз).

Запретная НЧ область для системы, удовлетворяющей требованиям точности Запретная область соответствует ЛАЧХ вида 1-2, т.е. системе с астатизмом 1-ого порядка добротности которой:

  • - по скорости
  • - по ускорению

Способ №2

Дано:

w k - контрольная частота;
Dj - фазовая ошибка слежения;
d - относительная амплитудная составляющая ошибки.

Приближенная передаточная функция систем с астатизмом первого порядка - определяет вид запретной области (Kv и T1 - неизвестны).

Построим векторную диаграмму гармонических координат системы:

Общий вид векторной диаграммы для САР, координаты которой меняются по синусоидальному закону

где:

;

Построение НЧ части желаемой ЛАЧХ

Построение желаемой ЛАЧХ для системы с астатизмом второго порядка В следящих системах с астатизмом 2-ого порядка, положение первой низкочастотной асимптоты всегда однозначно. Настройкой параметров регулятора (K, Ki1, Ki2) ее нужно подстроить по правой границе запретной области для НЧ.

В системах с астатизмом первого порядка надо определить положение 2-х асимптот. Возможные варианты определены положением постоянной времени объекта T1, относительно контрольной частоты:

  1. Ke > Ke треб, но: затруднено демпфирование и увеличиваются ВЧ шум.
  2. Kv > Kv треб, но: увеличиваются НЧ шум.
  3. Истинная ЛАЧХ должна быть поднята на 3 дБ, для компенсации ослабления в 1,4142 раза в зоне частоты сопряжения.

Требования к ВЧ части желаемой ЛАЧХ

Методика переноса линий показателя колебательности M на ЛФЧХ Формировать ВЧ участок ЛАЧХ удобно при использовании показателя колебательности M, линии уровня которого, при скольжении вектора A, с фазой j по окружностям M, можно нанести на ЛФЧХ.

В качестве типовых в НЧ части используются ЛАЧХ с наклоном не более -40 дБ/дек, которому соответствует нулевой запас по фазе, поэтому необходимо в области частоты среза формировать участок с наклоном -20 дБ/дек, т.е. сводить типовые ЛАЧХ к одному из 2-х видов:

Запретные зоны для ЛАЧХ & ЛФЧХ вида 2-1-2 Запретные зоны для ЛАЧХ & ЛФЧХ вида 1-2

1-2-1-2-3
0-1-2-1-2-4
... 		1-2-3
0-1-2-3-4
...

Запретные зоны на ЛАЧХ определяют:

  • Для ЛАЧХ вида 2-1-2: а) начало
корректирующего участка - Т2; и б) его длину - h = Т2/S Тi,
где i = [3, 4, ...), и w3 = w2h
или wср = w2M/(M-1)
или w3 = wср(M+1)/M.
  • Для ЛАЧХ вида 1-2 максимальное значение суммы постоянных времени равно S Тi, где i = [1, 2, ...).

Если выше частоты среза имеется пик от колебательного звена, то его амплитуда не должна приблизиться к окружности с заданной колебательностью M, т.е. не должна достичь уровня на ЛАЧХ 20lg M/(M+1); а постоянная времени, при определении h, должна войти в сумму как 2z T.

Построение ВЧ части желаемой ЛАЧХ

Исходные данные: w0 и T1 - определены при построении НЧ части желаемой ЛАЧХ.

Для систем с астатизмом 2-ого порядка:

  • Задаются перерегулированием s и определяют M:
    s, % | 13,8 | 26,5 | 37,2 | 44,6
    M | 1,1 | 1,3 | 1,5 | 1,7
  • Зная M, определяют положение постоянной времени T2 (начало корректирующего участка): , где [image]; и его длину: .
  • Проверяют, чтобы резонансные пики высокочастотных колебательных звеньев не достигали вновь уровня 20lg M/(M+1).

Для систем с астатизмом 1-ого порядка проверяют возможность сведения желаемой ЛАЧХ к виду 1-2 или модификациям, путем уменьшения постоянных времени до значения:

, где (M<1,3).

Если это невозможно, то формируют участок -20 дБ/дек аналогично методике для систем с астатизмом 2-ого порядка.

Корневой метод синтеза

Метод позволяет получить приемлемые динамические качества, при заданной структуре САР и заданном значении коэффициента усиления (последний член характеристического уравнения).

Пусть имеется ХУ:

(1)

sn+A1sn-1+...+An = 0.

Сумма модулей вещественных частей всех корней равна коэффициенту A1. При заданной его величине быстродействие будет максимальным, если вещественные части корней равны. Но это не достижимо - система будет не устойчивой. Например, для САР состоящей из 3-х апериодических звеньев выполнение условия эквивалентно равенству постоянных времени...

Реально всегда можно выделить 2 или 3 корня, с наименьшей по модулю вещественной частью, которые определяют вид переходного процесса. Положим их 2 и они комплексные. Перепишем ХУ:

(2)

(sn-2+C1sn-3+...+Cn-3) (s2+B1s+B2) = 0.

Достаточно рассматривать только 2-ой сомножитель, поскольку им определен вид переходного процесса:

  • B2 определяется значением K и должен иметь возможно большее значение.
  • B1 определяется суммой 2-х низкочастотных постоянных времени и связан с затуханием z, следовательно должен быть выбран исходя из 2-х противоречивых требований быстродействия и устойчивости.

Оптимальное соотношение между B1 и B2 может быть получено из условия затухания за один период z, выбор которого определяет отношение вещественной части корней к мнимой:

m = a/b = 2p / ln(1/(1-1/z)), где: a = - B1/2; b = (B2-B12/4)1/2.

Если принять, что вид переходного процесса определяют три корня, то следует воспользоваться уравнением 3-ей степени:

(3)

(...) (s3+B1s2+B2s1+B3) = 0,

которое нужно представить в виде:

(s+C11) (s2+B11s+B22) = 0.

Вещественные части корней будут равны a1 = a2,3 = - B1/3. Требования к B11 и B22 уже сформулированы, а связи с (3) определены равенствами:

B1=C11+B11, B2=B22+B11C11, B3=C11B22.

Выбор порядка уравнения для описания основной составляющей переходного процесса (2) или (3) зависит от структурной схемы САР.

Метод корневых годографов

Рабочие файлы: [root_locus.vsm]

Метод позволяет подобрать параметры системы по оценке их влияния на общую картину расположения корней замкнутой САР.

Если ПФ замкнутой САР:

где: m < n,

то полюсы и нули (корни) всегда можно вычислить и нанести на комплексную плоскость. Если менять один из параметров системы, (K, ..., Ti, ..., z), то изменения в ПФ F(s) приведут к смещению корней - движению по траекториям, совокупность которых называется корневым годографом. Если менять один параметр, при дискретных значениях другого, то можно оптимально выбрать значения уже 2-х параметров, оценивая семейство корневых годографов. При выборе допустимо пользоваться любой из корневых оценок качества: m, h, W0.

Наиболее эффективен метод при выборе K. ПФ разомкнутой системы и ХУ запишем в виде:

(*)

,

здесь s - не оператор Лапласа или дифференцирования, а любой из корней!!!

Если корни - полюсы и нули известны (q1o, q2o, ..., qmo; q1x, q2x, ..., qnx), то операторную часть ПФ - G1(s) можно представить в виде:

где: ; n>m.

Представим сомножители (s - qi) векторами:

.

Теперь вновь запишем ХУ:

.

При изменении K от 0 до бесконечности уравнения (1) и (2) определяют правила движения корней:

  1. Если K=0, то корни ХУ (*) совпадают с полюсами W(s), т.к. G(s) должна стремится к бесконечности.
  2. Если K®Ґ, то часть корней ХУ (*) совпадают с нулями W(s), а часть уходит в бесконечность, т.к. G(s)®0 как при совпадении s с нулями, так и при s®Ґ. Наклон асимптот для уходящих в бесконечность корней можно рассчитать по формуле:

(p+2i p) / (n-m), где: i=1,2, ..., n-m.


Системы с переменными параметрами

Система линейная с переменными параметрами
Линейной системой с переменными (var) параметрами называется такая, движение которой описывается ДУ с переменными во времени коэффициентами:
где воздействие f может быть и задающим - g(t).

Те. ПФ подобной системы параметрическая, например:

W(s, t ) = | Y(s, t) | = | K(t)...
 | X(s, t) |  | (1+T1s)(1+T2(t)s)...

где: K(t), T2(t) - зависящие от времени функции.

Пример параметрической САР

Понятие о параметрической функции веса. Нахождение реакции параметрической САР на произвольное воздействие

Рабочие файлы: [Интеграл Дюамеля] [Интеграл свертки]
[Интеграл свертки]

Очевидно, что реакции САР с var-параметрами на стандартные возмущения 1(t) и d(t) будут зависеть от момента времени поступления сигналов. В связи с этим функцию веса можно изобразить в виде поверхности:

Сопряженная весовая функция и ее реверс-смещение Различают:

  • Нормальную весовую функцию w(t-J, J) при J=const.
  • Сопряженную весовую функцию w(t-J, J) при t=const.
  • Реверс-смещение сопряженной весовой функции w(q, t-q) при t=const.

Заметим, что в системах с постоянными параметрами рельеф функций веса цилиндрический и нормальная функция веса совпадает с сопряженной (с реверс-смещением).
Если на систему, со свойственной ей функцией веса w(t-J, J), действует входной сигнал f(t), то элементарная реакция на выходе системы в произвольный момент времени t=J будет:

dy = w(t-J, J) f(J) d J .

Полный сигнал определяется как суперпозиция элементарных реакций:

y = ot т w(t-J, J) f(J) d J .

А если использовать реверс смещение q = t-J (t=const):

y = ot т w(q, t-q) f(t-q) d q ,

то получим интеграл свертки для квазистационарных систем.

Найти функцию веса для систем первого и второго порядков можно аналитически. Для систем высших порядков существуют численные методы.

Отыскание ПФ системы с var-параметрами

ПФ системы с переменными параметрами можно определить либо по функциям веса:

W(s, t) = -Ґt т w(t-J, J) e-(t-J)s d J = o+Ґ т w(q, t-q) e-q s d q ,

либо по переходной функции h(t-J, J):

W(s, t) = s -Ґt т h(t-J, J) e-(t-J)s d J = s o+Ґ т h(q, t-q) e-q s d q ,

но этот подход нерационален, т.к. требует знания типовых реакций системы h и w.

Более удобно находить ПФ W(s, t) из исходного ДУ с var-параметрами:

A(s, t) W(s, t) + N{W(s, t)} = B(s, t) ,

где:

A(s, t) = a0(t)sn+...+an(t) ;      B(s,
            t) = b0(t)sm+...+bm(t) ;
N{W(s, t)} =[ dA/ds dW/dt + ... + 1/n! dnA/dsn dnW/dtn
            ] .

Решение ДУ, т.е. ПФ W(s, t) будем искать в виде ряда:

W(s, t) = W0(s, t) + W1(s, t) + ...

где: W0(s, t) = B(s, t) / A(s, t); Wk(s, t) = N{Wk-1(s, t)} / A(s, t) .

Устойчивость и качество регулирования систем с var-параметрами

Поскольку в квазистационарных САР параметры меняются много медленней свободного движения системы, параметрическую САР считают устойчивой, если при всех "замороженных" комбинациях параметров она остается устойчивой.

Т.е. в параметрической ПФ W(s, t) фиксируют время t в диапазоне 0 < t < T и многократно исследуют на устойчивость, используя любой из критериев. Максимальное внимание надо уделить временным интервалам, где параметры меняются быстро или происходит смена знака. Особенно эффективно использование корневого годографа, зависимого от var-параметра, для оценки тенденций в системе.

При оценке качества регулирования следует учитывать, что коэффициенты ошибок получаются зависимыми от времени: Ck = [dk F x(s, t) / dsk], при s=0.

Изменение параметров можно рассматривать как возмущающее воздействие на систему. Соответственно составляющие ошибки от var-параметра не будут сводиться к нулю, за исключением случая, когда содержащее var-параметр звено установлено в цепи ОС или в прямом канале до интегрирующих элементов. Поскольку динамика изменения var-параметров в сравнении с динамикой задающего воздействия g(t) не значительна в случае квазистационарных систем, то соответствующие составляющие ошибок: по скорости, ускорению, ... - как правило, меньше.

Синтез параметрических САР

При синтезе САР на ЭВМ так же используют "замораживание" коэффициентов, и, если во всем рабочем интервале времени качество САР оказывается приемлемым, ее считают работоспособной.

Во многих случаях удается выделить одно звено первого или второго порядков с var-параметром. Тогда возможно осуществить синтез САР расчетным путем.

Диапазоны и зоны измения параметров

При синтезе следует стремиться максимально точно определить законы изменения параметров и не ограничиваться диапазонами. Так для случая 2 изменений var-параметров, согласно "D"-разбиению вероятность сохранения устойчивости существенно больше.


Системы с запаздыванием

Система линейная с запаздыванием
Линейной системой с запаздыванием называется такая, которая содержит в своей структуре хотябы одно звено, в котором есть неизменное запаздывание во времени t изменения выходной координаты после начала изменения входной.

Переходная характеристика апериодического звена первого порядка с элементом чистого запаздывания Рассмотрим апериодическое звено первого порядка, которое описывается уравнением:

(1)

T dy/dt + y = K x(t) .

Уравнение соответствующего звена с запаздыванием t будет иметь вид:

(2)

T dy/dt + y = K x(t-t) .

Оно называется дифференциально-разностным.

Обозначим x*(t) = x(t-t), тогда уравнение (2) запишется в обыкновенном виде:

(3)

T dy/dt + y = K x*(t) .

Следовательно его переходная характеристика соответствует апериодическому звену (рис. 1в), но задержана на t с, что определено задержкой воздействия x*(t) (рис. 1б).

Резюме:

  • Временная характеристика любого звена с запаздыванием будет такая же, как у соответствующего обыкновенного звена, но только сдвинута по оси времени вправо на величину t.
  • Величину запаздывания t в звене можно определить экспериментально, путем снятия временной характеристики.

Пример системы с транспортным запаздыванием

Рабочие файлы: [e^(-st)_tc.vsm]

Примеры систем с транспортным запаздыванием

ПФ звена чистого запаздывания

Блочное обозначение звена чистого запаздывания Свойства звена таковы, что y(t) = x(t-t), где t - запаздывание, а x(t-t) = 0 при 0 < t < t.

Разложим правую часть уравнения (т.е. выходной сигнал) в ряд Тейлора:

Разложение запазывающего сигнала в ряд Тейлора,

или

Изображение запаздывающего сигнала,

т.е.:

Передаточная функция звена чистого запазывания.

Аппроксимация звена чистого запаздывания

Рабочие файлы: [Аппроксиматоры]

i1.gif (913 bytes) Сравним переходные функции апериодического звена с запаздывающим аргументом и апериодического звена 2-ого порядка:

Переходные функции апериодического звена с запаздывающим аргументом и апериодического звена 2-ого порядка

Поскольку они существенно похожи, в приближенных расчетах можно осуществлять подмены передаточных функций звеньев.

В некоторых случаях применяется прием учета большого числа N звеньев в системе с малыми постоянными времени D Ti и единичным коэффициентом передачи, одним звеном с постоянным запаздыванием, равным сумме этих постоянных времени t = SD Ti » N ЧD T. Т.е.:

Если N®Ґ, то в пределе получим W(s)»e-t s. Уже при N=8..10 степень приближения высока. Ряд будет более точно соответствовать разложению в ряд функции e-t s, если его представлять не апериодическими, а фазосдвигающими звеньями.

Размыкание систем с запаздыванием

Большинство методов исследования устойчивости или качества систем в качестве входной информации используют ПФ системы для разомкнутого состояния W(s). Звено чистого запаздывания является нелинейным элементом, и затрудняет как аналитический анализ систем, так и машинный (программы математического моделирования не могут выполнять функции анализа для систем с нелинейными элементами). Поэтому либо используют линеаризованные аппроксиматоры звена чистого запаздывания, либо размыкают систему в той ветви, которая содержит звено чистого запаздывания, дабы ПФ имела вид: W(s) = Wo(s) ґ e-t s, где Wo(s) - ПФ части системы без запаздывания.

Рассмотрим и разомкнем системы с основными вариантами включения звена чистого запаздывания - последовательным, параллельным и в цепи ОС:

Преобразование структурной схемы системы при последовательном включении звеньев чистого запаздывания в контуре

Преобразование структурной схемы системы при параллельном включении звена чистого запаздывания

Преобразование структурной схемы системы при включении звена чистого запаздывания цепи локальной ОС

Если звенья чистого запаздывания имеются в разных ветвях структурной схемы, то для исследований используют их аппроксиматоры и машинные методы анализа.

Частотные свойства систем с запаздыванием. Понятие о критическом запаздывании

Перейдем в частотный домен:

,

следовательно:

L(w) = |W(j w)| = Ao(w) ґ 1 = Ao(w) ,
j(w) = jo(w) - wt .

Закручивание АФХ звеном чистого запаздывания Резюме:

  • Таким образом, наличие звена с запаздыванием не меняет модуля, а лишь вносит дополнительный фазовый сдвиг (-wt).
  • Из графика видно, что звено e-t s закручивает исходный годограф Wo(j w) по часовой стрелке, ухудшая условия устойчивости.
  • По имеющемуся годографу Wo(j w) можно определить критическое значение запаздывания tкр:
    j1 - wсрtкр = -p =>

    tкр = (p + j1) / wср

    В некоторых случаях tкр можно рассчитать аналитически.

Устойчивость систем с запаздыванием

Рассмотрим замкнутую систему:

АФХ и годограф Михайлова системы со звеном чистого запаздывания

По знаменателю ПФ F(j w) видно, что в общем случае характеристическое уравнение будет иметь множитель e-t s, который определяет возможность наличия бесконечного количества корней (см. петли годографа Михайлова D(j w) ).

Как и прежде, для устойчивости все они должны иметь отрицательные вещественные части.

  • Для устойчивости систем 1-ого и 2-ого порядка с запаздыванием не достаточно положительности коэффициентов.
  • Для систем 3-его и более порядков не применимы критерии Вышнеградского, Рауса, Гурвица.

Об исследовании точности систем с запаздыванием

Частотные характеристики звена чистого запаздывания По ЧХ звена чистого запаздывания наглядно видно, что его коэффициент передачи во всем частотном диапазоне равен единице. Причем в области низких частот и задержка в звене пренебрежимо мала (т.е. сдвиг фазы стремится к нулю), поэтому при исследовании точности систем с запаздыванием допустимо просто исключить все звенья чистого запаздывания из структурной схемы. Эта операция допустима, поскольку точность любой системы определяет только НЧ часть ее ЧХ.


Импульсные системы

Система импульсная линейная
Линейной системой импульсного регулирования называется такая САР, которая кроме звеньев описываемых обыкновенными линейными ДУ содержит импульсное звено, преобразующее непрерывное входное воздействие в равноотстоящие друг от друга по времени импульсы.

Варианты выходных последовательностей импульсных звеньев

Варианты выходных последовательностей импульсных звеньев

Пример импульсной системы

Пример импульсной системы

1 - импульсное звено - ключ с ШИМ; 2 - непрерывное звено - фильтр с нагрузкой; изменение +U можно рассматривать как возмущение f(t)

Система линейна, если линеен ШИ-модулятор. Если Rн меняется, то система дополнительно будет параметрической.

Математический аппарат описания импульсных систем

Решетчатые функции

Рабочие файлы: [z_sin.vsm]

Решетчатые функции 2 определены только в дискретные моменты времени [nT] (сокращенно [n]), и формируются из непрерывных функций 1: f [nT] = f (t) при t=nT. Рассматривают так же смещенные решетчатые функции (последовательность 3): f [n, e] = f (t) при t=(n+e)T, где e - относительное смещение, eО[0..1).

Синтез огибающих (интерполяция) Непрерывные функции, проходящие через дискреты заданной решетчатой функции, называют огибающими. Их бесконечно много.

Основная огибающая может быть получена, как результат решения ДУ наименьшего порядка и должна содержать гармоники наименьшей частоты.

Дифференцирование и интегрирование решетчатых функций

Рабочие файлы: [S & 1/S]

Аналогом первой производной для решетчатой функции является либо первая прямая разность: Производная решетчатой функции

D f [n] = f [n+1] - f [n],

либо первая обратная разность:

С f [n] = f [n] - f [n-1].

Аналогами второй производной являются вторые разности. Прямая:

D2 f [n] = D f [n+1] - D f [n] = (f [n+2] - f [n+1]) - (f [n+1] - f [n]) = f [n+2] - 2 f [n+1] + f [n],

и обратная:

С2 f [n] = С f [n] - С f [n-1] = f [n] - 2 f [n-1] + f [n-2].

По аналогии могут определяться и высшие разности:

D k f [n] = n=0k е(-1)nCknf [n+k-n] С k f [n] = n=0k е(-1)nCknf [n-n]

где: Ckn = k! / (n!(k-n)!).

Очевидно, что если f [n] определена только для положительных n, то для n=0 все обратные разности С k f [n] равны нулю, что позволяет ...

Аналогом интеграла является неполная сумма:

s[n] = m=0n-1е f [m] = n=1n е f [n-n],

и полная сумма:

so[n] = s[n] + f [n].

Разностные уравнения

Аналогом ДУ для импульсной системы является уравнение в конечных разностях или разностное уравнение (РУ):

b0С my[n] + b1Сm-1y[n] + ... + bm y[n] = f [n],

(оно может быть составлено и в прямых разностях). Если раскрыть разности, то уравнение будет иметь вид:

(1)

a0 y[n] + a1 y[n-1] + ... + am y[n-m] = f [n],

где: am-k = n=0k е (-1)m-k bn Cm-nk-n ; Cm-nk-n = (m-n)! / [ (k-n)! (m-k)! ] .

РУ легко машинизируются и для их расчета можно составлять рекуррентный алгоритм.

Учтем запаздывание передаточной функцией звена чистого запаздывания и вынесем теперь уже изображение дискретной последовательности y[n] в уравнении (1) за скобку:

(a0 + a1e-Ts + ... + ame-mTs) Y *[s] = F *[s],

введем обозначение z = eTs и перепишем уравнение:

(a0 + a1 z -1 + ... + am z -m) Y [z] = F [z].

Решая для него ХУ (левая часть приравненная к нулю) можно получить "Общее решение" - т.е. переходную составляющую:

y [n] = С1 z1n + С2 z2n + ... + Сm zmn ,

где: z1, z2, ..., zm - корни ХУ; а Ci - произвольные постоянные.

Вид решения ХУ определяет условие устойчивости для систем, описанных с помощью РУ:

| zi | < 1.

Z-преобразование

Для решетчатых функций времени может быть введено понятие дискретного преобразования Лапласа:

Дискретное преобразование Лапласа и z-преобразование

которое называется Z-преобразованием при подстановке z = eTs, и связывает изображение с оригиналом.

Z-преобразования (изображения) типовых решетчатых функций и типовых непрерывных ПФ W(s) сведены в таблицы. Определены правила и теоремы для математических манипуляций с ними.

Типовая структура импульсной системы.
Понятие об импульсном фильтре

Типовая структура импульсной системы

  • Если время замкнутого состояния ключа мало, то сигнал на его выходе можно заменить последовательностью дельта-функций x*[nT], с площадью x[nT], т.е: x*[nT] = x[nT] d(t-nT).
  • В таком случае реакция непрерывной части Wo(s) - это суперпозиция весовых функций w(t), которую можно рассматривать и как непрерывный сигнал y(t), и как дискретную последовательность y[nT].
  • Импульсным фильтром считают импульсный элемент (ключ) с непрерывной частью Wo(s) на выходе. За истинный сигнал фильтра принимают выходную последовательность только в дискретные моменты времени y[nT], где n = ..., -2, -1, 0, 1, 2, ...

Обобщенная модель импульсного элемента

Обобщенная математическая модель импульсного элемента

  • Задача идеального импульсного элемента (ИИЭ) в модели - сформировать для дальнейшего математического описания системы либо последовательность импульсов типа d-функций с площадью ~ x(t), либо решетчатую функцию, в основе которой единичная импульсная функция do(t) = { 1 при t=0; 0 при t№0 } с амплитудой ~ x(t).
  • Задача экстраполятора - математически описать выходную последовательность реального импульсного звена между значениями решетчатой функции (экстраполяция - это прогнозирование (синтез) сигнала по истории выборок вплоть до следующего достоверного значения, которое в текущий момент не известно, и, получив которое, можно провести историческую коррекцию прогноза - интерполяцию).
  • Коэффициент передачи квантователя (ИИЭ) обратно пропорционален периоду квантования, а коэффициент передачи экстраполятора нулевого порядка равен периоду. Таким образом общий коэффициент передачи квантующей и восстанавливающей цепи, т.е. ИЭ обычно равен единице.

Приведенные весовая и передаточная функции разомкнутой импульсной системы

  • Если ИИЭ выдает решетчатую функцию, то можно ввести понятие "приведенной весовой функции" - wп. Это отношение выходного сигнала y(t) к значению единственной дискреты xo поданной на вход экстраполятора.
  • Если ИИЭ выдает последовательность типа d-функций, то для непрерывной части совместно с экстраполятором можно вывести понятие приведенной непрерывной передаточной функции:

Wп(s) = Wэ(s) Wo(s), при этом Wп(s) = L{ wп(t) }.

Дискретная ПФ

Знание приведенной решетчатой весовой функции wп[n] позволяет найти реакцию импульсного фильтра на входную величину произвольного вида - x(t). Рассмотрим реакции на отдельные значения входной величины в дискретные моменты времени:

  • на x[0]: y[n] = wп[n] x[0]
  • на x[1]: y[n] = wп[n-1] x[1]
  • на x[m]: y[n] = wп[n-m] x[m]

Следовательно реакция на всю входную последовательность будет равна:

y[n] = m=0n е w п[n-m] x[m] = m=0n е w п[m] x[n-m] = m=0n е w п[m] x[n] e -mTs = m=0n е w п[m] x[n] z -m = x[n] m=0n е w п[m] z -m .

Здесь первоначально изменен порядок суммирования (свертка), а затем учли запаздывание оператором запаздывания z = eTs. Если устремить n к бесконечности, то, очевидно, что сомножитель для x[n] есть дискретная ПФ:

W (z) = n=0Ґ е wп[n] z -n = Y (z) / X (z) .

И поскольку она является Z-преобразованием приведенной решетчатой весовой функции, то ее можно представить как Z-преобразование от обратного преобразования Лапласа приведенной ПФ экстраполятора и непрерывной части:

W (z) = Z { wп[n] } = Z { L-1 { Wп(s) } } .

Часто для краткости записи знак операции L-1 опускают записывая: W (z) = Z { Wп(s) }.

Правила преобразования структурных схем дискретных систем

Рабочие файлы: [series_z.vsm]

Wп(s) = W1(s) + W2(s)
W(z) = W1(z) + W2(z)

Wп(s) = W1(s) W2(s)
W(z) = Z { W1(s) W2(s) } = W1W2(z)
те. W(z) № W1(z) W2(z) !!!

W(z) = W1(z) W2(z)

W(z, e) = Z { L-1 { Wп(s) e-t s } } =
= z -1 Ze { wп[n, e ] }

где:

e - относительное смещение, которое отсчитывается
от начала предыдущего такта (e = 1 - t/T ; 0 < t < T ).

ПФ системы с экстраполятором нулевого порядка и звеном запаздывания

Импульсная система с экстаполятором нулевого порядка и звеном запаздывания

Экстраполятором нулевого порядка являются: 1) УВХ и 2) ЦАП.

Найдем изображение Лапласа для единичного импульса:

Изображение Лапласа для выходного импульса экстаполятора нулевого порядка.

Тогда Z-изображение экстраполятора и непрерывной части со звеном запаздывания:

,

где: e = 1 - t/T ; 0 < t < T ; W(z) не учитывает коэффициент передачи ИИЭ равный 1/T.

ПФ системы с экстраполятором, осуществляющим АМ первого или второго рода

Импульсная система с экстаполятором, осуществляющим АМ первого рода

Найдем изображение Лапласа для частично заполненного импульса:

Изображение Лапласа для частично заполненного единичного импульса.

Тогда Z-изображение экстраполятора и непрерывной части:

,

где: e = 1 - g ; W(z) не учитывает коэффициент передачи ИИЭ равный 1/T.

Если g << 1, то e -g Ts » 1 - g Ts, тогда:

.

К этой формуле, в первом приближении, сводится и АМ второго рода.

ПФ замкнутой импульсной системы

Замкнутая импульсная система

Опишем систему в изображениях Лапласа:

те.:

.

  • ПФ по ошибке F x может быть получена решением системы относительно ошибки x.
  • Поскольку запаздывание не определяет свойства системы в области низких частот, практически всегда для оценки качества могут быть использованы формулы

(осталась особенность - "W1W2(z)", см. правило 2 преобразования структурных схем)

ПФ для возмущений

Приведение возмущающего воздействия ко входу

Поскольку для произведения 2х операторных многочленов: F(s) (изображение возмущения) и W2(s) нельзя найти Z-преобразование раздельно, см. правило 2, то ПФ по возмущению удобно определять для эквивалентных возмущений F1(z), приведенных к входу ИЭ:

.

Дискретная синусоидальная последовательность x[n] = a sin [w nT+j].
Частота Найквиста. Теорема Котельникова.
Частотные ПФ импульсных систем

Рабочие файлы: [aliasing.vsm] [z_sin2.vsm] [psd45.vsm] [fft30.vsm] [Свойства W(e jwT)]

Дискретные синусоидальные последовательности. Aliasing - эффект наложения (совмещения) частот при недостаточной частоте дискретизации

Особые свойства последовательности x[n]:

  1. Функция может быть как периодической - рис. а и б, так и непериодической - рис. в.
  2. Амплитуда образующей непрерывной функции может быть максимальным значением последовательности x[n] - рис. а, и может не является им - рис. б.
  3. Последовательность не изменится, если на вход ключа подавать сигналы с частотами, отличающимися на частоту дискретизации: f ; f + 1f0; f + 2f0; ...; f + kf0.

Запишем закон изменения синусоидальной последовательности в экспоненциальной форме:

x[n] = a sin [w nT+j] = a e j[w nT+j] = a e j j e j w nT = a e j w nT = a zn ,

тогда выходная величина импульсного фильтра:

y[n] = m=0Ґ е w п[n-m]
                x[m] = m=0Ґ е w п[m]
                x[n-m] = m=0Ґ е w п[m]
                a zn-m = a zn
                m=0Ґ е w п[m]
                z -m = a znW (z) = x[n]
                W (z).

Таким образом ПФ W(z) при подстановке z = e j w T - есть частотная ПФ. Все остается в силе и для F(e j w T) и F x(e j w T).

Очевидно, что частотные ПФ W(e j w T), F(e j w T) и F x(e j w T) обладают периодическими свойствами (w0 = 2p T -1). Это видно и из нижнего рис., поскольку одну и ту же входную последовательность могут вызывать входные сигналы с разными частотами f + k f0.

v - Преобразование. Билинейные преобразования.
Устойчивость и качество импульсных систем

Рабочие файлы: [Аппроксиматоры] [bi_line_sz.vsm]

Вид границы устойчивости в домене Лапласа, в Z и W доменах

Построим область устойчивости в плоскости комплексной величины z. Воспользуемся методикой D-разбиения и, меняя частоту w от - Ґ до + Ґ, получим границу z = eTs = e j w T - в виде окружности единичного радиуса, внутрь которой попадает левая полуплоскость комплексной величины s. Следовательно, для устойчивости, все корни-полюсы замкнутой системы F(z) должны находится внутри этой окружности.

Итак, для описанных с помощью аппарата Z-преобразования импульсных систем, всилу изменившегося вида области устойчивости и периодичности их ЧХ W(e j w T), разработанные для непрерывных систем критери устойчивости (кроме критерия Найквиста и корневого годографа), а так же наиболее эффективные методы коррекции и синтеза (использующие ЛАЧХ & ЛФЧХ) не приемлемы.

Для преодоления этого затруднения используют v-преобразование, которое отражает окружность единичного радиуса на мнимую ось комплексной величины v, с помощью подстановки:

Переход в W-домен и домен псевдочастоты.

Физически подстановка означает переход к ДУ заменой в РУ элементов чистого запаздывания грубой аппроксимацией - одним фазосдвигающим звеном.

Вторая формула для перехода в область псевдочастот l получена из соотношения:

,

отметим так же, что:

.

v-Домен и домен псевдочастоты l используют редко, поскольку для большинства импульсных и цифровых систем частота дискретизации 1/T выбирается в 6...10 раз больше частоты среза. В таком случае выполняется условие wсрT<2, вследствие чего в полосе системы псевдочастота l и частота w практически совпадают. Поэтому обходятся доменом обычных частот, а для переходов используют формулы "Билинейного преобразования":

Формулы "Билинейного преобразования".

Резюме:

  1. После v-преобразования, используя ПФ W(v) или F(v) можно применять обычные (в основном алгебраические) критерии устойчивости, справедливые для непрерывных систем.
  2. После последующего перехода в область псевдочастот (подстановка v = j l T/2) вид ПФ W(j l T/2) и F(j l T/2) становится пригоден для применения медодов, использующих ЛАЧХ & ЛФЧХ.
  3. Качество импульсной системы может оцениваться построением кривой переходного процесса, что при использовании ПФ F(z) сравнительно легко.
  4. Оценку качества в установившихся режимах удобно выполнять нахождением коэффициентов для разложения ошибки в ряд:

    ,

    которые являются коэффициентами разложения ПФ F x(z) в ряд Маклорена по степеням s:

    ,

    где: z = e Ts.

Понятие о переходном процессе конечной длительности

Импульсная система, имеющая переходный процесс конечной длительности

Принципиальным недостатком линейных систем является тот факт, что любой переходный процесс будет иметь бесконечную длительность. Это объясняется тем, что при уменьшении значений сигналов на входах интеграторов пропорционально уменьшается скорость изменения их выходных координат. Т.е. если в линейной астатической системе ошибка становится меньше, то тут же понижается скорость ее компенсации по цепи ООС (см. рис., кадр 1).

Если же на некоторое время периодически замораживать сигнал в цепи ООС, то скорость изменения выходной координаты интегратора в течение периода "заморозки" уменьшаться не будет, а при правильном подборе периода "заморозки" можно добиться переходного процесса конечной длительности, завершающегося за один или же два цикла (см. рис., кадры 2 и 3).

Следует отметить, что подобная импульсная система на время "заморозки" сигнала ООС приобретает все достоинства и недостатки не имеющих ОС систем.


Cистемы цифрового управления

Цифровые системы

Цифровые системы строятся на базе комплекса средств вычислительной техники, основными элементами которого являются: 1) ЦВМ, 2) устройства ввода, 3) устройства вывода.

Функции ЦВМ могут выполнять: 1) ЭВМ (компьютеры), 2) DSP - цифровые сигнальные процессоры, 3) ЦУ на жесткой логике. Первые относятся к универсальным устройствам управления, вторые специализированны для приложений, третьи разрабатываются для конкретных устройств (например, цифровой фильтр, имеющийся в каждом еD АЦП).

Устройствами ввода и вывода в случае состыковки с аналоговыми сигналами являются АЦП и ЦАП-ы, а в случае состыковки с цифровыми сигналами - порты и интерфейсы.

В системах с ЦВМ, последние могут выполнять роли: 1) регулятора, 2) регулятора и устройства сравнения, 3) корректирующего устройства или 4) самого объекта.

Если ЦВМ универсальная (ЭВМ), то возможно построение многофункциональных САУ, когда одна ЦВМ обслуживает комплекс составляющих объект устройств. Например, в автомобиле: 1) система навигации, 2) система бортового электропитания, 3) АБС, 4) электронная подвеска, 5) управление топливоподачей, ... В подобных случаях в состав системы ЦУ должны входить аналоговые или цифровые мультиплексоры и демультиплексоры.

Во всех случаях ЦВМ предоставляет легко доступные информационные потоки, позволяющие кроме прямого управления осуществлять функции: 1) контроля, 2) оптимизации, 3) координации и 4) организации всех процессов.

Процессы протекающие в системах ЦУ

Рабочие файлы: [Субгармонические автоколебания]

Дискретная природа ЦВМ определила наличие 2-х процессов в системах ЦУ: 1) дискретизации сигналов по времени (получение решетчатой функции), и 2) квантования сигналов по уровню (АЦ и ЦА преобразования).

Дискретизация сигналов по времени делает систему дискретной, а квантование по уровню - нелинейной. Оба процесса сопровождаются возникновением методических погрешностей.

Выбор частоты дискретизации производится исходя из ширены полосы пропускания или из времени регулирования замкнутой системы. Разумные частоты дискретизации в 6..10 раз больше ширены полосы пропускания или от 2-х до 4-х дискретных отсчетов за время нарастания, в противном случае качество системы будет резко ухудшаться.

Количество ступеней квантования по уровню оказывает существенное влияние на динамические свойства систем. При недостаточном их количестве могут возникать периодические режимы переключений между дискретами (автоколебания).

Может случиться так, что выполняемые ЦВМ задачи (опрос датчиков, расчет программы, формирование информационных потоков, запись в порты вывода) могут быть выполнены только при систематической задержке синтезируемого воздействия на один такт дискретизации. В таком случае в системе с ЦВМ появится запаздывание t, которое должно быть учтено оператором запаздывания z -1 и, возможно, смещенной ПФ W(z, e).

Обычно количество ступеней квантования по уровню велико, поэтому его влиянием пренебрегают. Это делает систему, линейной и позволяет использовать математический аппарат импульсных систем.

Методика вывода дискретных ПФ

Система, управляемая ЦВМ (предполагается, что АЦП совместно с ЦАП-ом имеют единичный коэффициент усиления, т.е. в модели можно подобрать либо коэффициент усиления ключа и масштаб задания, либо коэффициент усиления экстраполятора)

Работу ЦВМ обеспечивают АЦП (квантователь) и ЦАП (экстраполятор нулевого порядка), следовательно:

Последовательно включенные ПФ с общим ключом нельзя по отдельности преобразовывать к эквивалентным дискретным ПФ (см. правило 2)...

Для нахождения z-изображения непрерывной ПФ W(s) по таблицам, последнюю надо разложить на элементарные дроби, т.е. преобразовать к параллельной структуре. Тогда на каждое простейшее звено сигнал будет поступать с квантователя (что и требуется при использовании таблиц):

где:

A (1+T1s) + Bs (1+T1s) + Cs2 = 1 ;
(BT1+C) s2 + (AT1+B) s + A = 0s2 + 0s + 1 ; =>
=> A = 1, B = -T1, C = T12 .

Коэффициент передачи ООС 1/Tц учитывать не надо (см. примечание к рис.).

О синтезе систем с ЦВМ методом логарифмических амплитудных характеристик

ЧХ импульсного фильтра, демонстрирующие: 1) их схожесть с ЧХ непрерывной части в области НЧ, и 2) поглощение частот кратных частоте дискретизации ЦВМ делил W(e^jwTц) на Tц

Изображенный дискретный фильтр имеет в области частот w ЛАЧХ & ЛФЧХ, использовать которые при синтезе неудобно.

Перевод с помощью v-преобразования ЧХ в область псевдочастот l, позволяет получить ЛАЧХ, которые по виду подобны ЛАЧХ непрерывных систем.

Последовательность преобразований следующая:

Wэ(s)Ч W(s) ® W(z) ® W(v) ® W(j l Tц/2).

Эти преобразования при использовании экстраполятора нулевого порядка могут быть формализованы. Пусть ПФ непрерывной части имеет вид:

.

Техническая реализуемость систем с ЦВМ позволяет ввести положения:

  1. Пусть для частоты среза непрерывной части выполняется условие wср < 2/Tц.
  2. Все постоянные времени знаменателя разделим на две группы - до и после диапазона от частоты среза до частоты дискретизации:

    T1, ..., Tq > (1/wср ... 1/wц) > Tq+1, ..., Tn.

  3. Постоянные времени в числителе t1, ..., t m пусть больше чем 1/wср.
  4. Поскольку система должна быть устойчива, пусть наклон ЛАЧХ на wср будет -20 дБ/дек.

Принятые положения, позволяют описать свойства систем в области низких и высоких частот двумя ПФ:

.

Теперь для формального перехода в область псевдочастот l (минуя промежуточные z и v-преобразования) достаточно подставить в ПФ Wo(s)НЧ вместо s j l и умножить ее на множитель (1-j l Tц/2), для низких частот приближенно равный 1.

А ПФ Wo(s)ВЧ будет соответствовать выражение:

.

Модуль которого: .

Результирующий фазовый сдвиг обеих областей:

.

Резюме:

  1. В области НЧ (w < 2/Tц) асимптотическая ЛАЧХ системы с ЦВМ практически сливается с ЛАЧХ непрерывной части (множитель (1-j l Tц/2) » 1) и можно положить l » w. Это позволяет один к одному использовать разработанную для непрерывных систем методику формирования НЧ части желаемой ЛАЧХ.
  2. В области ВЧ отличия вносит множитель (1-j l Tц/2), ухудшающий условия устойчивости. Поэтому при формировании запретной ВЧ области в расчетных формулах величина Tц/2 должна быть просуммирована с малыми постоянными времени:

Цифровая коррекция

Цифровая или дискретная коррекция весьма интересна с практической точки зрения в силу конструктивной универсальности устройств и гибкости настройки. Решения задач коррекции предполагают модификации низкочастотного и среднечастотного фрагментов ЛАЧХ, как правило, с уменьшением частоты среза wср. Известно, что в этом диапазоне системы с ЦВМ и их ЛАЧХ - L(l) не отличаются существенно по свойствам от непрерывных аналогов. Поэтому методика синтеза коррекции едина для цифровых и непрерывных систем. Проектирование же дискретной коррекции ведется в четыре этапа.

  1. Синтез ПФ непрерывного корректирующего устройства Wк(s) по методикам разработанным для непрерывных систем.
  2. Переход от непрерывной ПФ корректирующего устройства Wк(s) к эквивалентной дискретной Wк(z) посредствам последовательных переходов по изображениям:

    ,

    с помощью результирующей формулы билинейного преобразования (т.е. формальной подстановки):

    где: Tц - период дискретизации ЦВМ.

  3. Составление структурной схемы дискретной ПФ Wк(z), оптимизированной при реализации по объёму памяти, быстродействию или для контроля промежуточных фазовых координат системы.
  4. Написание программы для ЦВМ (периферийный контроллер, микроЭВМ, ЭВМ, цифровой сигнальный процессор - DSP) или разработка схемы на цифровых микросхемах.
  • Заметим, что из непрерывной ПФ можно получить бесконечное количество вариантов дискретной ПФ, при разных периодах дискретизации ЦВМ (этап 2).
  • Обычно частоту дискретизации fц=1/Tц выбирают в 6..10 раз больше частоты среза fср разомкнутой системы. Первоначально частоту дискретизации выбирают большой (fц=10..30fср), за тем, за две три попытки стремятся ее уменьшить (т.е. повторяют этап 2). При низких частотах дискретизации качество переходного процесса ухудшается настолько (в сравнении с непрерывной коррекцией), что платить за это понижением производительности ЦВМ не представляется возможным. Соответствующую ПФ Wк(z) используют в дальнейшем.
  • При синтезе ПФ Wк(s) или Wк(z) необходимо, что бы степень числителя Wк(s) не была больше степени знаменателя или свободный коэффициент a0 в знаменателе ПФ Wк(z) не был нулевым, иначе невозможно реализовать программу.
  • Если требуется обратный переход от Wк(z)НЧ к Wк(s)НЧ следует воспользоваться обратной формулой билинейного преобразования:

    Этот переход однозначен при известном периоде работы ЦВМ Tц.

Цифровые регуляторы

В непрерывных системах широко используются PID-регуляторы, которые представляются идеализированным уравнением:

.

где: KP - коэффициент усиления пропорционального канала; TIx - постоянная времени сопрягающего полюса интегрального канала; TDx - постоянная времени сопрягающего полюса дифференциального канала.

Для малых периодов дискретизации Tц уравнение может быть преобразовано в разностное без существенной потери в точности. Непрерывное интегрирование может быть представлено с помощью метода прямоугольников [image], или метода трапеций [image].

Используем метод прямоугольников для аппроксимации непрерывного интеграла и запишем PID-закон в дискретном виде:

Если в сумму включить и текущую выборку, то фазовый сдвиг интегрирующего канала будет чуть менее чем 90 градусов, а так он чуть более 90.

В результате получен нерекуррентный (позиционный) алгоритм управления, который требует сохранения всех предыдущих значений сигнала ошибки x[i], и в котором каждый раз заново вычисляется управляющий сигнал u[n].

Для реализации программ закона регулирования на ЦВМ более удобным является рекуррентный алгоритм. Он характеризуется тем, что для вычисления текущего значения сигнала u[n] используется его предыдущее значение u[n-1] и поправочный коэффициент, не требующий существенных вычислительных затрат. Определим его:

Если это РУ, но с не приведенными членами записать для изображений, затем перейти к z-ПФ представленной элементарными дробями, то получится PID регулятор с разделенными каналами, т.е. так можно получить дифференцирующий и интегрирующий дискретные элементы.

Перенесем u[n-1] в правую часть - получим "скоростной" алгоритм для программной реализации регулятора:

(*)

u[n] = u[n-1] + b0 x[n] + b1 x[n-1] + b2 x[n-2].

Если для аппроксимации непрерывного интеграла использовать метод трапеций, то разностное уравнение будет иметь вид:

.

Преобразования, аналогичные выше изложенным, при получении рекуррентного соотношения (*), выявляют отличия только для коэффициента b0:

.

Запишем РУ (*) для изображений в z-домене:

U [z] (1- z -1) = (b0 + b1 z -1 + b2 z -1) X [z] ,

и представим его в виде дискретной ПФ:

или Wpid(z) = K [ 1 + Tц/Ti (1/(z-1)) + Td/Tц (z-1)/z ].

Анализ ее коэффициентов показывает, что:

  1. Для исключения статической ошибки, ПФ должна иметь полюс zx=1.
  2. Если b2 = 0, то получим PI-регулятор.
  3. Если b0 = 0, а b1 = (1 + b2), то получим PD-регулятор.

Алгоритмы программ цифровых фильтров

Существует три основных алгоритма программной реализации дискретных передаточных функций (z-ПФ):

Алгоритм | Требуемое быстродействие | Объём памяти
Непосредственный а) с двумя буферами б) с одним буфером | 24(m+k+1) / Tц | 9m+9k+12
Последовательный | 52k / Tц | 20k+10
Параллельный | 50k / Tц | 19k+8

Дискретную ПФ можно представить в любой из форм:

W(z ) = | Y(z) | = | b0+b1z-1+...+bmz-m | - стандартная форма для дискретных ПФ
 | X(z) |  | a0+a1z-1+...+akz-k
W(z ) = | Y(z) | = | K | 1+e2z-1 | ... | 1+ekz-1 | - разложение z-ПФ на множители [1]
 | X(z) |  | 1+d1z-1 | 1+d2z-1 |  | 1+dkz-1
W(z ) = | Y(z) | = | P1 | + | P2 | +...+ | Pk | - разложение z-ПФ на элементарные дроби [1]
 | X(z) |  | 1+d1z-1 |  | 1+d2z-1 |  | 1+dkz-1

где: ei - нули z-ПФ; di - полюса z-ПФ; a0 - не равно нулю; Pi - коэффициенты разложения

Этим формам представления z-ПФ соответствуют структурные схемы изображенные на рис. 1.

Рис. 1

  • Разложения [image] и [image] делают параметры z-ПФ независимыми, позволяют контролировать ряд дополнительных фазовых координат: x1[n], x2[n], ..., xk-1[n]; или y1[n], y2[n], ..., yk[n] - что удобно при отладке систем.
  • Последовательная структура [image] удобна при синтезе дискретной коррекции.
  • Параллельная структура [image] удобна для построения цифровых регуляторов.
  • Разложение z-ПФ на элементарные дроби [image] позволяет реализовать z-ПФ на параллельно работающих ЦВМ для повышения быстродействия.

Перечисленные факторы определяют выбор алгоритма программы для ЦВМ.

После разложений, каждый из множителей в форме [image] или каждую из элементарных дробей в форме [image] следует представить в стандартной форме [image] (с отрицательными степенями оператора z). Переход к разностным уравнениям будет един. z-ПФ в форме [image] соответствует разностное уравнение (РУ):

Обший вид разностного уравнения (РУ БИХ-фильтра),

по которому и составляется программа. Поскольку текущее значение выходной координаты y[n] рассчитывается по предыдущим значениям y[n-1], y[n-2], y[n-k] - данное РУ называется рекурсивным.

Изобразим структурную схему цифрового фильтра для этого уравнения (см. рис. 2). Ее можно преобразовать, объединив два буфера (см. рис. 3). Цепочки элементов z-1 в программах будут соответствовать буферам из ячеек памяти, данные в которых сдвигаются на каждом такте дискретизации. Обе структурные схемы можно составить из простейших блоков программы VisSim.

Структурная схема рекурсивного цифрового фильтара

Структурной схеме соответствует алгоритм [image] а.
Условие физической реализуемости - а0 № 0
Рис. 2

Альтернативная структурная схема рекурсивного цифрового фильтара

Структурной схеме соответствует алгоритм [image] б.
Условие физической реализуемости - а0 № 0
Рис. 3

Если выбран последовательный [image] или параллельный [image] алгоритм, то структура каждого множителя или элементарной дроби первого порядка (см. рис. 1) будет иметь более простой вид (см. рис. 4).

Структурные схемы цифровых фильтров первого порядка
Рис. 4

Согласно структурной схеме рис. 2, составим процедуру реализующую дискретную ПФ второго порядка:

function y_zW(x) {
  y=( k * (x*b0+xz_1*b1+xz_2*b2)
        - (     yz_1*a1+yz_2*a2) ) / a0;
  xz_2=xz_1; xz_1=x;
  yz_2=yz_1; yz_1=y;
  return y;
};

где: xz_2, xz_1 и yz_2, yz_1 - ячейки двух буферов, т.е. регистры задержки - z -1.

Выберем коэффициенты z-ПФ для расчета переходной характеристики и построим ее:

K= |
b0= | b1= | b2=
a0= | a1= | a2=

Об эффекте квантования параметров

ПФ цифрового PID-регулятора имеет три коэффициента b0, b1, b2. Заметим, что только один коэффициент b1 содержит информацию о таком параметре регулятора как постоянная времени сопрягающего полюса интегрального канала TIx. Для объяснения сути эффекта квантования параметров рассмотрим не усугубляющий случай плотного расположения сопрягающих полюсов. Пусть TIx = 0,1; TDx = 0,01; при Tц = 0,0003. Рассчитаем коэффициент b1:

Заметим, что для любой системы отклонение любой постоянной времени в два раза не должно иметь критического значения, однако коэффициенты ПФ-ий, как показано, зависят от параметров отличающихся на порядки, поэтому скажем для отношения TDx/Tц, входящего во все коэффициенты числителя ПФ регулятора требуется сохранять мантиссу длиной 5 знакомест (17 двоичных разрядов), поскольку иначе информация о параметре TIx будет потеряна вследствие округления.

Существуют следующие методы преодоления эффекта квантования параметров при ограниченной длине мантиссы ЦВМ:

  1. Развязка параметров посредствам разложения z-ПФ высокого порядка либо на множители, либо на элементарные дроби.
  2. Подбор для реализации z-ПФ структурной схемы среди альтернативных, имеющих разные по плотности сетки возможных положений корней в единичной окружности.


БИХ-фильтры

Проектирование цифровых фильтров второго порядка с бесконечной импульсной характеристикой

Рабочие файлы: [Аналоговые прототипы дискретных фильтров]
Примеры ЧХ дискретного фильтра: [z2_tf_fr.vsm] [z2_tf_fr.mcd]

Передаточную функцию (ПФ) для дискретного фильтра любого типа можно получить из ПФ аналогового прототипа посредствам Билинейного преобразования (БЛП). Одновременно БЛП может быть использовано для масштабирующих операций в частотном домене. В частности для смещения полосы пропускания и регулировки ее ширины.

Дискретная ПФ фильтра второго порядка имеет вид:

(1)

            b0 + b1*z^-1 + b2*z^-2
    H(z) = ------------------------
            a0 + a1*z^-1 + a2*z^-2

Для сокращения нагрузки на ЦВМ шесть коэффициентов z-ПФ могут быть заменены эквивалентными, один из которых будет равен единице (одна из шести операций умножения будет сокращена). Если проектируемая z-ПФ лишь одна из нескольких включенных последовательно, то можно привести к единице еще один коэффициент, за счет коррекции общего коэффициента передачи цепочки фильтров или системы. Тогда z-ПФ будет иметь вид:

(2)

            (b0/a0) + (b1/a0)*z^-1 + (b2/a0)*z^-2
    H(z) = ---------------------------------------
               1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

или

(3)

                      1 + (b1/b0)*z^-1 + (b2/b0)*z^-2
    H(z) = (b0/a0) * ---------------------------------
                      1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

Дальнейшее сокращение операций умножения возможно, если z-ПФ имеет пары равных коэффициентов.

Рекуррентный алгоритм, реализующий z-ПФ (2), должен рассчитывать следующее разностное уравнение (РУ):

(4)

    y[n] = (b0/a0)*x[n] + (b1/a0)*x[n-1] + (b2/a0)*x[n-2]
                        - (a1/a0)*y[n-1] - (a2/a0)*y[n-2]

Параметры цифровых фильтров

1/dT = sampleRate
Частота дискретизации фильтра. Определяется как обратная величина от периода времени dT, через который цифровая вычислительная машина способна выполнять подпрограмму, рассчитывающую соответствующее разностное уравнение (4)
Частота (frequency)
В зависимости от типа фильтра - это "частота сопряжения" (оценивается по пересечению ЛАЧХ с уровнем -3 дБ), "резонансная частота" для полосового и режекторного фильтров, "центральная частота" полософормирующего фильтра, или "центральна частота наклонного участка" фильтра-ступени (фильтра-горки)
К в полосе (dBgain)
Коэффициент передачи на модифицируемом участке ЛАЧХ для полософормирующего фильтра и фильтра-ступени
Добротность (Q)
Отношение резонансной частоты фильтра к ширине его полосы. В зависимости от типа фильтра при формировании требований к ЧХ, бывает удобней пользоваться эквивалентными параметрами - "полосой" и "наклоном"
Полоса (bandwidth)
Ширина полосы рабочих частот фильтра. Для полосового и режекторного фильтров оценивается по пересечению их ЛАЧХ с уровнем -3 дБ. Для полософормирующего фильтра - по пересечению их ЛАЧХ с её средним уровнем (dBgain/2). Для фильтра-ступени - это длина наклонного участка
Наклон (shelf slope)
Модуль наклона ЛАЧХ фильтра-ступени. Максимально возможный наклон (без появления колебательности ЛАЧХ) равен 1 Белу за октаву. При задании малого значения наклона фильтр-ступень превращается в фильтр-лестницу (ЛАЧХ похожа на две ступеньки). Наклонный участок становится нелинейным

Вычисление коэффициентов цифровых фильтров

Аналоговые прототипы разрабатываются для приведенной (нормализованной) частоты. Данные прототипы, при оптимальной настройке, являются фильтрами Баттерворта (с максимально плоскими ЛАЧХ). Билинейное преобразование выполняется посредствам подстановки:

                1          1 - z^-1
   s  =  -------------- * ----------
          tan(omega/2)     1 + z^-1

Для вычисления тангенса при составлении программы используются тригонометрические тождества:

                 sin(w)                                 1 - cos(w)
   tan(w/2) = ------------              (tan(w/2))^2 = ------------
               1 + cos(w)                               1 + cos(w)

Расчет промежуточных переменных

A     = sqrt[ 10^(dBgain/20) ] =
      = 10^(dBgain/40)                    (только для полософормирующих фильтров)

omega = 2*pi*frequency/sampleRate

sin   = sin(omega)
cos   = cos(omega)

alpha = sin/(2*Q) =                                    (если задана Q)
      = sin*sinh[ ln(2)/2 * bandwidth * omega/sin ]    (если задана полоса)

    Отношение между шириной полосы и Q:
            1/Q = 2*sinh[ln(2)/2*bandwidth*omega/sin]  (для ЦФ на основе БЛП)
    or      1/Q = 2*sinh[ln(2)/2*bandwidth]            (для аналогового прототипа)

beta  = sqrt(A)/Q =                                    (только для фильтров-ступенек)
      = sqrt(A)*sqrt[ (A + 1/A)*(1/S - 1) + 2 ]        (если задан наклон горки)
      = sqrt[ (A^2 + 1)/S - (A-1)^2 ]

    Отношение между наклоном и Q:
            1/Q = sqrt[(A + 1/A)*(1/S - 1) + 2]
ФНЧ:	H(s) = 1 / (s^2 + s/Q + 1)

    b0 =  (1 - cos)/2
    b1 =   1 - cos
    b2 =  (1 - cos)/2
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

ФВЧ:	H(s) = s^2 / (s^2 + s/Q + 1)

    b0 =  (1 + cos)/2
    b1 = -(1 + cos)
    b2 =  (1 + cos)/2
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

ПФ:	H(s) = s / (s^2 + s/Q + 1)          (пик АЧХ = Q)

    b0 =   sin/2  =   Q*alpha
    b1 =   0
    b2 =  -sin/2  =  -Q*alpha
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

ПФ:	H(s) = (s/Q) / (s^2 + s/Q + 1)      (пик АЧХ = 0 dB)

    b0 =   alpha
    b1 =   0
    b2 =  -alpha
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

Режекторный фильтр или фильтр - пробка:
    H(s) = (s^2 + 1) / (s^2 + s/Q + 1)

    b0 =   1
    b1 =  -2*cos
    b2 =   1
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

Фазовращающий фильтр:
    H(s) = (s^2 - s/Q + 1) / (s^2 + s/Q + 1)

    b0 =   1 - alpha
    b1 =  -2*cos
    b2 =   1 + alpha
    a0 =   1 + alpha
    a1 =  -2*cos
    a2 =   1 - alpha

Полософормирующий фильтр (для эквалайзеров):
    H(s) = (s^2 + s*(A/Q) + 1) / (s^2 + s/(A*Q) + 1)

    b0 =   1 + alpha*A
    b1 =  -2*cos
    b2 =   1 - alpha*A
    a0 =   1 + alpha/A
    a1 =  -2*cos
    a2 =   1 - alpha/A

Фильтр - НЧ-ступень-лестница:
    H(s) = A * (s^2 + (sqrt(A)/Q)*s + A) / (A*s^2 + (sqrt(A)/Q)*s + 1)

    b0 =    A*[ (A+1) - (A-1)*cos + beta*sin ]
    b1 =  2*A*[ (A-1) - (A+1)*cos            ]
    b2 =    A*[ (A+1) - (A-1)*cos - beta*sin ]
    a0 =        (A+1) + (A-1)*cos + beta*sin
    a1 =   -2*[ (A-1) + (A+1)*cos            ]
    a2 =        (A+1) + (A-1)*cos - beta*sin

Фильтр - ВЧ-ступень-лестница:
    H(s) = A * (A*s^2 + (sqrt(A)/Q)*s + 1) / (s^2 + (sqrt(A)/Q)*s + A)

    b0 =    A*[ (A+1) + (A-1)*cos + beta*sin ]
    b1 = -2*A*[ (A-1) + (A+1)*cos            ]
    b2 =    A*[ (A+1) + (A-1)*cos - beta*sin ]
    a0 =        (A+1) - (A-1)*cos + beta*sin
    a1 =    2*[ (A-1) - (A+1)*cos            ]
    a2 =        (A+1) - (A-1)*cos - beta*sin

Мастер для генерации коэффициентов дискретного фильтра

Встроенный ниже в html-страницу мастер корректно визуализируется и функционирует в браузере MSIE 5.0. Отображение мастера меняется не существенно в браузере Opera 6.04, и логика работы с мастером не нарушается. В браузере Netscape 7.0 мастер не работает.

Три коэффициента числителя (b0, b1, b2) и три коэффициента знаменателя (a0, a1, a2) z-ПФ в соответствующем порядке выводятся мастером в двух нижних строках. В качестве разделителя используется пробел. Рекомендуется пользоваться клавиатурным копированием (Ctrl+c и Ctrl+v) для переноса коэффициентов в блок "Передаточная функция" моделирующей программы. Для перехода между полями формы используйте клавиши Tab и Shift+Tab.

БИХ-фильтр второго порядка
Тип:
: = f/Df
: = f/Df
К в полосе: [дБ]
Аналоговый прототип (w=1):
k:
Числ:
Знам:
Дискретный фильтр:
1/dT: [Гц]
Частота: [Гц]
Числ:
Знам:

Приведенная ниже форма позволяет на основе коэффициентов рассчитанных мастером построить частотные характеристики соответствующего дискретного фильтра. Скрипт считает ЧХ именно дискретной системы, а не ее линеаризованного аппроксиматора (в большинстве моделирующих программ для построения ЧХ дискретной системы выполняется обратное БЛП и строятся ЧХ линеаризованного аппроксиматора). С ознакомительными целями Вы можете выполнить расчеты для выбранных по умолчанию установок. Поскольку графики строятся в Excel'е, Вы должны ответить положительно на вопрос системы безопасности программы MSIE о том запускать ActiveX компонент (Excel) или нет.

Построение ЛАЧХ & ЛФЧХ (в Excel'e)
Начальная частота: [рад/с]
Считать для декад: (100 точек / дек)
+ АЧХ & ФЧХ: ( + 30 сек )


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

ПРИМЕРЫ ДЛЯ САМОСТОЯТЕЛЬНОГО ИЗУЧЕНИЯ И СПРАВОЧНЫЙ МАТЕРИАЛ

Моделирование в программе VisSim

К пояснению взаимосвязей между шагом симуляции, методами интегрирования и частотным анализом: | [1_s_x_2.vsm]
Переходный процесс в "RLC" схеме: | [rlc.vsm]
Модели измерителей электрических величин: | [rms_ex.vsm] [meter.vsm]
Поиск корней уравнения: | [roots.vsm]
Звенья с модулированным сигналом: | [fil_resp.vsm] [pwm_ex.vsm]
Звено чистого запаздывания: | [vtcdelay.vsm]
Релейные САР: | [roomctrl.vsm]
Импульсные САР: | [bworth.vsm]
Диаграмма Вышнеградского: | [vishngrd.vsm]
Линии уровня показателя колебательности М: | [m.vsm]
W(s) на основе характеристического полинома D(s): | [order3.vsm]
Коррекция САР, коррекция жесткой ОС & изодромный блок на апериодическом звене: | [2ou+kor.ca4] [ouhik&f1.vsm] [kor_ooc1.vsm & kor_ooc2.vsm]
Дельта-сигма АЦП: | [adc_dsigm.vsm]
Импульсная характеристика КИХ-фильтра: | [fir.vsm]
Универсальные блок-схемы для составления моделей: | [tf_univr.vsm]
Прямое и обратное быстрые преобразования Фурье (БПФ): | [fft.vsm]
Ряды Фурье: | [furye1.vsm]
Измерение ЧХ КИХ и БИХ систем по их импульсной характеристике: | [fr_FIR_fft50.vsm] [fr_IIR_fft50.vsm]
Оценка мощности спектра сигнала: | [psd.vsm]
Генераторы на z-ПФ с начальными условиями: | [gen_z.vsm]
Прототип электронного аналогового синусоидального преобразователя: | [sin.vsm]

Моделирование в программе Electronics Workbench

Модели устройств выборки хранения (УВХ): | [yvx1.ca4] [yvx2.ca4] [yvx3.ca4] [yvx4.ca4]
ЦАП на ШИ-модуляторе: | [dac_pwm.ca4]
Последовательный ЦАП на переключаемых конденсаторах: | [dac_2c.ca4]
Параллельный ЦАП на R-2R матрице постоянного импеданса: | [dac_r2r.ca4]
Параллельный ЦАП на коммутируемых конденсаторах: | [dac_nc.ca4]
ZCS-1/2 FM ИИВЭП | [zcs_01.ca4]

ПЛАН РАЗВИТИЯ ДАННОГО РУКОВОДСТВА

  1. Разработка лабораторных работ для второго семестра (нелинейные и цифровые системы) (к февралю 2001г.).
  2. Дальнейшая взаимная интеграция моделей из разных моделирующих пакетов. Организация одновременной работы моделей (в разных пакетах) в динамическом режиме посредствам технологий динамического обмена данными (DDE - dinamic data exchange, на базе ActiveX). Пример: регулятор в пакете Electronics Workbench, объект в пакете VisSim, - должны работать совместно.
  3. Разработка моделей, предполагающих наличие в контуре модели реального технического устройства, подключенного посредством платы сбора данных - (DAQ-board).
  4. Подготовка моделей для альтернативных моделирующих пакетов, например "МВТУ" (если будет договоренность с разработчиками).

30.10.2000

Сделать "D-разбиение" по вариантам см. задачник.

1. Цель работы | 2. Предварительное домашнее задание | 3. Содержание работы
4. Обработка результатов | 5. Методические указания к моделированию и рекомендации к содержанию отчета | 6. Контрольные вопросы

Работа 4

3.7. Провести исследование устойчивости модели электронного усилителя на трехкаскадном ОУ (файлы ou3.vsm и ou2+1.ca4)
3.8. Исследовать влияние контурного коэффициента усиления на полосу пропускания замкнутой системы на примере электронного усилителя на ОУ.

Работа 5?[err_pid.vsm] [PIDTUNE.vsm]

Выяснение сути корневых методов оценки качества.

Работа 6?[ASTATIC.vsm]

Изучение основных методов повышения точности САР: 1) увеличение коэффициента усиления разомкнутой цепи, 2) применение регулирования по производным от ошибки с увеличением контурного коэффициента усиления, 3) повышение степени астатизма, 4) применение неединичных обратных связей или масштабирующих устройств на входе / выходе и 5) комбинированного управления.

4.3. Выполнить количественное исследование результатов применения методов повышения точности САР на основе исследований (измерений) ошибки x(t). По необходимости рекомендуется использовать тест-сигналы задания g(t): единичную ступенчатую функцию 1(t), синусоидальный, меняющийся с постоянной скоростью или ускорением (см. сигнал g(t) в файле err_ast3.vsm). Для измерений ошибки рекомендуется использовать: датчики скорости и ускорения (дифференцирующие звенья), преобразователи построенные в соответствии с интегральными оценками качества, а так же измерители действующего или средневыпрямленного значений. Выбор схемы измерения ошибки x(t) следует обосновать.
3.6. Определить первые коэффициенты ошибок систем до и после применения методов повышения точности.
(можно измерить первые коэффициенты ошибок систем до и после повышения точности).

4.1. Один из методов повышения точности САР - это повышение степени астатизма. Метод реализуется применением либо интегрирующего, либо изодромного звена включаемого в разрыв контура регулирования. Качественно описать результаты применения упомянутых технических решений (в сравнении). Сформулировать достоинства, недостатки (ограничения в применении). Привести поясняющие графические зависимости (информацию удобно представить в режиме пререкрытия графиков).

Работа 8 [Ak_wk.vsm] [wo.vsm]

Среди предложенных моделей идентифицировать устойчивые в разомкнутом состоянии.
3.2. Для неустойчивых в разомкнутом состоянии систем спроектировать последовательные компенсационные звенья.


Цветовая маркировка резисторов E24

Цветовая маркировка резисторов E24 и E96

Резистор: 000e+0 Ом; 5%, ряд E24 (золотое кольцо)
0 черный Кликая мышкой по столбцу цветовой палитры можно "заполнить цветами кольца резистора". Процедура заполнения цветовых колец зациклена, и возможно повторение процедуры дешифровки номинала. Если кликнуть по кольцу кода точности резистора, то добавится третье "кольцо номинала" для прецизионных резисторов. Следует помнить, что "кольцо точности" может быть и других цветов, а так же то, что встречаются резисторы с кольцом "ТКС" (самое последнее; не показано).
1 коричневый
2 красный
3 оранжевый
4 желтый
5 зеленый
6 синий
7 фиолетовый
8 серый
9 белый
-1 золотой
-2 серебряный

Значения мантисс рядов (E3, E6, E12, E24, E48, E98, E192) не четко соответствуют формуле:

for (i=0; i<24; ++i) Math.round( 10^(1+1/24*i) );

Мантиссы E24: 10,11,12,13,15,16,18,20,22,24,27,30,33,36,39,43,47,51,56,62,68,75,82,91


ЛИТЕРАТУРА

  1. Бесекерский В.А., Попов Е.П. Теория систем автоматического регулирования. - М.: Наука, 1975.
  2. Лукас В. А. Теория автоматического управления. – М.: Недра, 1990. – 416 с.
  3. Брюханов В. Н. и др. Теория автоматического управления. –М: Высшая школа, 2000 г.
  4. Острём К., Виттенмарк Б. Системы управления с ЭВМ: Пер. с англ. - М.: Мир, 1987. - 480 с., ил.
  5. Оппенгейм Э., Шафер Р. Цифровая обработка сигналов/ Пер. с англ./ Под ред. С. Я. Шаца. - М.: Связь, 1979. - 416 с.
  6. Антонью А. Цифровые фильтры: анализ и проектирование/ Пер. с англ. - М.: Радио и связь, 1983. - 320 с.
  7. Гольденберг Л. М., Матюшкин Б. Д., Поляк М. Н. Цифровая обработка сигналов: Справочник. - М.: Радио и связь, 1985. -312 с., ил.
  8. Дженкинс Г., Ваттс Д. Спектральный анализ и его приложения: В 2 т./ Пер. с англ. Ф. М. Писаренко с предисловием А. М. Яглома - М.: Мир, 1971.
  9. Сборник задач по теории автоматического регулирования и управления/ Под редакцией В. А. Бесекерского. - M.: Наука, 1978.
  10. Бронштейн И.Н., Семендяев К.Н. Справочник по математике для инженеров и учащихся вузов. - М.: Наука,1986.
  11. Титце У., Шенк К. Полупроводниковая схемотехника: Справочное руководство/ Пер. с нем. - М.: Мир, 1982.
  12. Хоровиц П., Хилл У. Искусство схемотехники: В 3 т./ Пер. с англ. - М.: Мир, 1993


Теория систем автоматического регулирования

681.5(07)
К493 		VisSim.nm.ru & VisSim.com

Н. В. Клиначёв

МОДЕЛИРОВАНИЕ ОБЫКНОВЕННЫХ
И ОСОБЫХ ЛИНЕЙНЫХ СИСТЕМ

ТАУ, ЭЛЕКТРОНИКА

Руководство к лабораторным работам в пакетах
VisSim и Electronics Workbench


УДК 681.5(07) K493

УДК 681.51.01(076.5)+621.51.015.26(076.5)+621.382.81(076.5)
K493

Клиначёв Н. В. Моделирование обыкновенных и особых линейных систем. ТАУ, Электроника: Руководство к лабораторным работам в пакетах VisSim и Electronics Workbench. - Offline версия 3.4. - Челябинск, 2004. - 98 файлов, ил.

Руководство предназначено для студентов электротехнических специальностей, изучающих курсы "Теория автоматического управления" (ТАУ), "Моделирование систем управления" и им подобных. Лабораторные исследования проводятся на персональных ЭВМ с применением моделирующих пакетов VisSim и Electronics Workbench. Совокупность учебных моделей разбита на две группы. Ядром являются модели для пакета VisSim, которые не отражают особенности конкретных систем, являются чисто математическими и построены на основе задания структурных схем и передаточных функций. Они могут быть использованы для любой специальности вплоть до нетехнических. Вторая группа моделей для пакета Electronics Workbench предназначена для студентов электротехнических специальностей и отражает особенности технических решений из схемотехники устройств на операционных усилителях (ОУ). Совокупность работ закрывает потребность в лабораторном практикуме по обыкновенным и особым линейным системам автоматического регулирования и рассчитана на выполнение в течение двух семестров.

Ил. 27, табл. 10, учебных моделей 74, список лит. - 12 назв.

Одобрено учебно-методической комиссией автотракторного факультета Южно-Уральского государственного университета.

Рецензенты: зав. кафедрой "Автоматика и телемеханика" Дальневосточного государственного университета путей сообщения, д.т.н., профессор Г. П. Малай, и зам. зав. кафедры "Автоматизация и управление" Азербайджанского технического университета, к.т.н., доц. М. Б. Намазов.

© Н.В. Клиначёв, 2000-2004.

Инструкции

Данное руководство - это электронная версия документа tau.doc или tau_a5.doc. Назначение электронной версии - быстрый и систематизированный доступ во время занятий к тексту пособия, к изучаемым моделям, а так же, при необходимости, к конспекту лекций, и к тестам. Операционная система установленная на компьютерах должна распознавать расширения рабочих файлов (*.vsm и *.ca4) и, при активации в руководстве соответствующих гипертекстовых ссылок, должна автоматически запускать приложения VisSim и Electronics Workbench. Информация о версиях пакетов, их изготовителях и архиве моделей приведена в разделе "Требуемые программные пакеты". Достаточно, если студенты будут проинструктированы о порядке запуска электронного руководства (tau_knv.chm).

Требуемые программные пакеты

  1. Электронное руководство к лабораторным работам вошедшее в учебно-методический комплекс (файл tau_knv.chm) выполнено в соответствии со стандартом Windows-HTML-справки. Оно представляет собой один файл, в котором заархивированы html-страницы, учебные модели (рабочие файлы программ VisSim и Electronics Workbench), рисунки и необходимые скрипты. Файл пособия автоматически распознается и запускается операционной системой Windows 98 (NT, 2000), точнее браузером MSIE версии не ниже 4.0. Пользователям Windows 95 (NT) возможно потребуется установить Windows-HTML-справку. Для чего на сайте фирмы Microsoft следует найти установочный файл hhupd.exe (733 KB).
  2. Для организации учебного процесса следует получить пакет VisSim FAP 3.0 по "Бесплатной Академической Программе" (http://www.vissim.com). См. также сайт "VisSim в России" (http://www.vissim.nm.ru). Большинство работ можно выполнить, используя старую версию пакета - VisSim 1.2, в которой нет годографа Найквиста и оптимизации. Достоинство этого варианта в том, что руководство, модели и пакет умещаются на одной дискете и легко могут быть предоставлены студентам для самостоятельной работы дома. В первой работе имеется ссылка на демонстрационный файл csd_new.scm, который можно получить по адресу http://www.vissim.com/downloads/demos.html. В форме нужно отметить пункт «Control system design demo». Отсутствие файла может быть компенсировано рассказом преподавателя о пакете.
  3. Требуемая версия пакета Electronics Workbench - 4.1. Часть моделей имеет настройки элементов отличные от библиотечных. Замечено, что старшие версии программы не считывают их из файлов. Адрес сайта изготовителя - http://www.electronicsworkbench.com.

Обновленные версии руководства доступны на сайте "VisSim в России". Архив руководства можно получить по электронной почте, направив письмо-запрос автору (klinacherv_nv@mail.ru). При возможных изменениях в адресах рекомендуется воспользоваться поисковыми системами, используя ключевые слова: VisSim, симуляция движения, моделирование, Nikolay Klinachyov. Клиначёв Николай Васильевич


Лабораторные по ТАУ

Перечень лабораторных занятий по дисциплине
"Теория систем автоматического регулирования"

ЧАСТЬ 1

1. Знакомство с моделирующим ПО
2. Типовые динамические звенья
3. Принципы и законы регули-вания
4. Анализ устойчивости САР
5. Оценка качества регулирования
6. Повышение точности САР
7. Коррекция САР
8. Синтез САР

ЧАСТЬ 2

09. САР с var-параметрами
10. Системы с запаздванием
11. Импульсные системы
12. Цифровые системы
13. Релейные системы

Справочный материал


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 1
ПРИНЦИПЫ ФУНКЦИОНИРОВАНИЯ МОДЕЛИРУЮЩИХ ПАКЕТОВ

Рабочие файлы: [csd_new.scm] [rlc.vsm] [rlc.ca4]

1. Цель работы

Приобретение навыков работы с моделирующими программами VisSim и Electronics Workbench. Ознакомление с этапами моделирования. Определение общих методов представления результатов. Выяснение сути задания параметров симуляции, параметров модели и начальных условий ее энергетического состояния.

2. Содержание работы

2.1. Выяснить порядок запуска используемых программных пакетов VisSim и Electronics Workbench.

2.2. Ознакомиться с демонстрационным роликом о работе с программой VisSim (при наличии доступа к файлу csd_new.scm - download "control system design demo"). Преподаватель может организовать собственную демонстрацию для студентов. Выявить: а) назначение программы, б) основные этапы работы с программой.

2.3. Запустить программу VisSim. Загрузить файл rlc.vsm. Записать соответствующую блок-схеме систему уравнений. Выполнить сравнение уравнений модели с формами записи закона Ома для "R", "L" и "C"-элементов. Предложить схемы электрических цепей, которые описываются данной системой уравнений. Идентифицировать на чертеже блок-схемы параметры моделируемых элементов и выяснить начальные условия в схеме. Изучить характер влияния параметров, а за тем и начальных условий на вид переходного процесса.

2.4. Запустить программу Electronics Workbench. Загрузить файл rlc.ca4. Изменить начальные условия и параметры модели по собственному усмотрению (ваш отчет будет уникальным). Вновь загрузить файл rlc.vsm с начальными настройками. Изменить их таким образом, чтобы переходные процессы в VisSim'е совпали с соответствующими в Electronics Workbench'е.

2.5. По вариантам (см. табл.) спроектировать модели источников периодического сигнала в пакете VisSim. Измерить, и, при необходимости, компенсировать постоянную составляющую в сигнале. Использовать блок plot для осциллографирования.

Вариант | Форма сигнала | Частота, кГц | Амплитуда, ед.
1 | Прямоугольный скважность 1:2 | 10 | 10
2 | Треугольный | 20 | 20
3 | Линейно нарастающий | 30 | 30
4 | Нарастающий по параболе | 40 | 40
5 | Модуль синусоиды | 50 | 50

3. Методические указания к моделированию и рекомендации к содержанию отчета

3.1. Кратко описать отличие в принципе функционирования программ VisSim и Electronics Workbench от математических пакетов подобных Mathcad'у.

3.2. Привести распечатки, подтверждающие выполнение всех пунктов экспериментальной части и текстовые пояснения к ним.

3.3. При изучении характера влияния параметров на вид переходного процесса не следует менять их одновременно (см. пп. 2.3). Проверьте тенденции при вариации одного, произвольно выбранного параметра. Такой же подход необходим при изучении характера влияния начальных условий на вид переходного процесса.

3.4. Для измерения постоянной составляющей (см. пп. 2.5) следует составить блок-схему соответствующую магнитоэлектрическому измерительному механизму, который реагирует на среднее значение. Главный блок в модели измерительного преобразователя - интегратор.

3.5. Выводы.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 2
ТИПОВЫЕ ДИНАМИЧЕСКИЕ ЗВЕНЬЯ

Рабочие файлы: [zvenya.vsm] [k((1+tp)(1+tp))^-1.ca4] [k(1+2etp+(tp)^2)^-1.ca4] [k(p^-1).ca4] [kp.ca4] [функц. устр. на ОУ]

1. Цель работы

Исследование взаимосвязей между параметрами типовых динамических звеньев и их характеристиками. Идентификация реальных технических устройств - схем на операционных усилителях с типовыми звеньями (т.е. с математическим описанием). Приобретение навыков использования типовых возмущающих воздействий и инструментов частотного анализа для исследования систем.

2. Предварительное домашнее задание

2.1. Составить уравнения и вывести передаточные функции W(s) для всех блоков файла zvenya.vsm. Сравнить полученные передаточные функции с типовыми, идентифицировать блоки по названиям.

3. Содержание работы

3.1. В программе VisSim ознакомиться с моделями единичной ступенчатой функции - 1(t) и дельта-функции - 1'(t) (файл zvenya.vsm). Выявить положенные допущения (неидеальности) в моделях.

3.2. В программе VisSim (файл zvenya.vsm) выполнить исследование типовых динамических звеньев (см. п. "Методические указания к моделированию и рекомендации к содержанию отчета"). По ходу работы необходимо изменить постоянные времени, коэффициенты затухания и усиления по своему усмотрению. Убедится, что дифференцирование переходной функции звена - h(t) дает его функцию веса - w(t); и наоборот, интегрирование функции веса звена - w(t) дает его переходную функцию - h(t).

3.3. Выполнить измерения виртуальными приборами (анализатор, осциллограф) в схемах на операционных усилителях (файлы *.ca4 для программы Electronics Workbench) с целью идентификации моделей с типовыми динамическими звеньями. Настроить схемы по совпадению вида ЛАЧХ & ЛФЧХ, а так же реакций подобных переходной функции и функции веса. Допустимо несовпадение только коэффициентов усиления.

3.4. Подавая на вход типовых динамических звеньев синусоидальный сигнал, убедиться, что изменение коэффициента усиления вне полосы пропускания за одну декаду составляет либо 20 дб (10 раз), либо 40 дб (100 раз).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Привести названия и графики использованных типовых возмущающих воздействий. Описать изменения в реакции типовых звеньев на варьирование параметров воздействий.

4.2. Для каждого звена привести: а) название звена; б) структурную схему (подписав входную величину, выходную, сигнал ошибки и обратной связи); в) вывод передаточной функции (подставить коэффициенты усиления и постоянные времени; проверить соответствие с линеаризованной передаточной функцией, которую рассчитывает программа VisSim (Analyze, Transfer Function Info); записать значения нулей и полюсов); г) список параметров с описанием характера влияния на переходные процессы, на ЛАЧХ & ЛФЧХ; д) переходную функцию; е) функцию веса; ж) ЛАЧХ & ЛФЧХ; з) диаграмму Найквиста (отметить траекторию для положительных частот; точки, в которых частота стремится к нулю и к бесконечности).

4.3. Указать на неидеальности, присущие свойствам, которыми обладают реальные дифференцирующие устройства и их компьютерные дискретные модели. Пояснить причину неидеальности в дискретных моделях.

4.4. Кроме осциллограмм, ЛАЧХ & ЛФЧХ подтверждающих результаты настройки схем по пп. 3.3 необходимо привести схемы проведения измерений (включая источники тест-сигналов) и дать пояснения к ним.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 3
ПРИНЦИПЫ И ЗАКОНЫ РЕГУЛИРОВАНИЯ

Рабочие файлы: [open.vsm] [closed.vsm] [pid.ca4]

1. Цель работы

Ознакомление с принципами разомкнутого и замкнутого регулирования. Исследование процессов преобразования сигналов в каналах типового ПИД-регулятора. Изучение свойств непрерывных законов регулирования: пропорционального (П), интегрального (И), изодромного (ПИ) и вариантов с дифференцирующим каналом (ПД, ПИД).

2. Предварительное домашнее задание

2.1. Составить передаточные функции W(s) для всех блоков структурных схем рабочих файлов.

3. Содержание работы

3.1. Изучить параметры сигнала задания g(t) в файле open.vsm. Определить интервалы, где координата задания постоянна, меняется с постоянной скоростью или с постоянным ускорением.

3.2. Опираясь на принцип суперпозиции и понятие о ряде Тейлора, изучить как каналы ПИД-регулятора формируют сигнал воздействия на объект - u(t) из первичной информации - x(t). С помощью эксперимента доказать линейность свойств каналов ПИД-регулятора (файл open.vsm).

3.3. Изучить реализацию ПИД-регулятора на ОУ (файл pid.ca4). Определить коэффициенты усиления каналов регулятора тремя способами:

  • по номиналам схемы электрической принципиальной;
  • опираясь на результаты измерений в частотном домене (по снятым ЛАЧХ & ЛФЧХ);
  • опираясь на результаты измерений во временном домене (по результатам осциллографирования процесса обработки синусоидальных сигналов (в трех точках частотной шкалы)).

3.4. В файлах open.vsm и closed.vsm коэффициенты усиления регуляторов оптимально настроены для управления объектом в соответствии с принципами Понселе (без ОС) и Ползунова-Уатта (с ОС). По своему усмотрению изменить параметры объекта и сравнить последствия. Вновь настроить регуляторы.

3.5. Построить два семейства зависимостей приведенной статической погрешности от изменения коэффициента усиления объекта при разных коэффициентах передачи пропорционального канала регулятора. В первом случае - для управления с ОС, во втором - без ОС. Первое семейство погрешностей привести к сигналу задания 1(t), второе - к среднему значению коэффициента усиления для каждой вариации (семейство вырождается в один график). Пояснить результаты.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Привести общее описание типового ПИД-регулятора (структурная схема, дифференциальное уравнение, передаточная функция, параметры).

4.2. При формальном изучении характера трансформаций каналами ПИД-регулятора составляющих ряда Тейлора во входном сигнале следует так же описать особые свойства или эффекты присущие каналам, фиксируемые в опытах. Следует так же дать разъяснения, по какой причине для изучения свойств регулятора предложены идеализированные сигналы, несмотря на то, что в реальных САР они таковыми не являются. Так же следует разъяснить, по какой причине предложена поканальная схема изучения регулятора, несмотря на то, что чаще каналы используются одновременно.

4.3. Описать, какие ограничения накладывает частотная характеристика типового ОУ на свойства ПИД-регулятора и как их следует учитывать при проектировании САР. При уточнении коэффициентов усиления регулятора на основе измерений во временном домене следует выбирать частоту синусоидального сигнала ориентируясь на характерных сдвиг фаз в интегрирующей, пропорциональной и дифференцирующей областях. Следует помнить, что предложенная схема ПИД-регулятора дополнительно инвертирует сигнал.

4.4. При осуществлении настройки коэффициентов ПИД-регулятора можно ориентироваться на интеграл квадрата ошибки регулирования.

4.5. Постоянные времени объекта и дифференцирующий канал регулятора не оказывают ни какого влияния на любую САР в неподвижном состоянии. Рекомендуется учесть этот факт при измерении статической составляющей ошибки.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 4
АНАЛИЗ УСТОЙЧИВОСТИ ЛИНЕЙНЫХ САР

Рабочие файлы: [mihaylo4.vsm] [d_4_k&t.vsm] [nyquist.vsm] [ou3.vsm] [ou2+1.ca4]

1. Цель работы

Приобретение навыков использования критериев устойчивости Михайлова и Найквиста. Исследование влияний параметров систем на их устойчивость. Изучение методики применения D-разбиения.

2. Предварительное домашнее задание

2.1. По передаточной функции разомкнутой системы (файл mihaylo4.vsm) записать ее характеристический полином D(s), определить его коэффициенты, выделить мнимую и вещественную составляющие.

2.2. Без применения программных инструментов построить асимптотические ЛАЧХ & ЛФЧХ для передаточных функций:

W(s) = 4 | 0,5s+1 | ; W(s) = 1 | 2s+1 | ; W(s) = 1 | 2s2+s+1
 | s2-s |  | 0,15s3+s2 |  | s3

2.3. Для передаточных функций W(s) (файл nyquist.vsm) вывести передаточные функции соответствующих замкнутых систем Ф(s).

2.4. Самостоятельно познакомиться с сутью итерационных алгоритмов.

3. Содержание работы

3.1. Исследовать границу устойчивости (типы границы устойчивости), используя возможность пакета VisSim задать передаточную функцию с помощью перечисления корней (нулей и полюсов её числителя и знаменателя). Убедиться, что только корни-полюсы с неотрицательной вещественной частью приводят к расходящемуся переходному процессу.

3.2. Исследовать влияние корней характеристического полинома на вид годографа Михайлова (файл mihaylo4.vsm).

3.3. Изучить влияние контурного коэффициента усиления на устойчивость системы и вид годографа Михайлова.

3.4. Задавая постоянную времени T2 по варианту (см. табл.), подбором найти коэффициент усиления системы, при котором она будет находиться на колебательной границе устойчивости. В качестве признака границы использовать критерий Михайлова.

Вариант | 1 | 2 | 3 | 4 | 5
T2 | 0,14; 0,42; 0,72 | 0,18; 0,48; 0,78 | 0,24; 0,54; 0,84 | 0,30; 0,60; 0,90 | 0,36; 0,66; 0,96

3.5. Познакомиться с применением D-разбиения (файл d_4_k&t.vsm). Убедиться, что параметры, см. пп. 3.4, образуют точки на границе разбиения. Определить частоты для этих точек.

3.6. Исследовать на устойчивость передаточные функции, предложенные в файле nyquist.vsm, применяя годограф Найквиста и логарифмические частотные характеристики.

3.7. Изучить характер влияния контурного коэффициента усиления на устойчивость и на полосу пропускания замкнутой системы - модели электронного усилителя на трехкаскадном ОУ (файлы ou3.vsm и ou2+1.ca4). Менять контурный коэффициент усиления предполагается делителем в цепи обратной связи.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Для произвольно спроектированных передаточных функций привести переходные процессы, соответствующие наличию: а) одного и двух нулевых корней-полюсов; б) паре чисто мнимых корней-полюсов; в) корню-полюсу с положительной вещественной частью.

4.2. Убедиться, что каждый корень-полюс с отрицательной вещественной частью разворачивает годограф Михайлова на 90 градусов против часовой стрелки, а с положительной - на 90 градусов по часовой.

4.3. Продемонстрировать влияние коэффициента усиления на вид переходных процессов и вид годографа Михайлова (в режиме перекрытия графиков).

4.4. Для D-разбиения, указать область устойчивости (подтвердить моделированием) и выяснить влияние параметров на ее размер.

4.5. Среди предложенных к изучению с помощью годографа Найквиста и логарифмических частотных характеристик найти передаточные функции, отвечающие следующим признакам: а) астатические (указать порядок); б) имеющие корни-полюсы с положительной вещественной частью (Transfer Function Info); б) неустойчивые в разомкнутом состоянии; в) неустойчивые в замкнутом состоянии; ж) в которых понижение коэффициента усиления приведет к появлению неустойчивости в замкнутом состоянии; з) в которых повышение коэффициента усиления приведет к появлению неустойчивости в замкнутом состоянии; д) условно устойчивые; г) абсолютно устойчивые. Результаты свести в таблицу с отметками "+" и "-". Методика получения результатов должна быть отображена.

4.6. Пункт 3.7 предполагает построение семейств ЛАЧХ & ЛФЧХ для разомкнутой и замкнутой систем, при варьировании контурного коэффициента усиления электронного усилителя. Для замкнутой системы дополнительно требуется получить семейство переходных характеристик. Кроме пояснения графических результатов, в отчете привести описание модели трехкаскадного ОУ. Модель для пакета Electronics Workbench (ou2+1.ca4) предполагается использовать для сравнительного контроля полученных результатов.

4.7. Описать с точки зрения удобства применения в исследованиях годографы Михайлова, Найквиста и ЛАЧХ.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 5
ОЦЕНКА КАЧЕСТВА РЕГУЛИРОВАНИЯ

Рабочие файлы: [err_ast3.vsm] [err_s^-1.vsm]

1. Цель работы

Ознакомление с основными группами критериев качества (оценивающими точность, устойчивость, быстродействие и обобщенные свойства САР). Изучение методики использования интегральных оценок качества при исследовании ошибок систем в типовых режимах движения. Приобретение навыков оценки качества по переходной характеристике и по АЧХ замкнутой системы.

2. Предварительное домашнее задание

Приравнивая в структурной схеме (файл err_ast3.vsm) коэффициенты усиления (KI1 & KI2 & KI3), или (KI2 & KI3) или (KI3) к нулю, можно получить модели САР с астатизмом от нулевого до третьего порядков (считая исходную).

2.1. Начальные значения коэффициентов усиления установить в соответствии с вариантом (см. табл.). Вывести передаточные функции по ошибке Фx(s) для четырех моделей САР при астатизме от нулевого до третьего порядка.

Вариант | 1 | 2 | 3 | 4 | 5
KI1; KI2; KI3 | 25; 50; 60 | 30; 50; 70 | 35; 50; 80 | 45; 50; 90 | 50; 50; 100

2.2. Для тех же моделей вывести формулы расчёта первых четырёх коэффициентов ошибки и определить их числовые значения.

2.3. Описать суть интегральной и улучшенной интегральной оценок качества.

2.4. Составить функцию цены из блоков пакета VisSim, подсчитывающую количество переходов через ноль ошибки САР в переходном процессе.

3. Содержание работы

3.1. Изучить сигнал задания g(t) спроектированный для введения систем в режимы типового движения (файл err_ast3.vsm). Заполнить таблицу.

Временной промежуток постоянства параметров сигнала
Параметр сигнала и его значение

3.2. Измерить значения первых четырех установившихся ошибок по: положению q0, скорости qu, ускорению qe, и приращению ускорения qg''' для систем с астатизмом от нулевого до третьего порядков (файл err_ast3.vsm). Параметры моделей должны соответствовать расчетному заданию. Опираясь на экспериментальные данные определить коэффициент усиления систем в области низких частот K, а так же добротности по скорости Ku, ускорению K e и приращению ускорения Kg'''. Определить численные значения коэффициентов ошибок по положению, скорости, ускорению и приращению ускорения - c0, c1, c2, c3. Заполнить таблицу.

Система \ Ошибки | q0 & K & c0 | qu & Ku & c1 | qe & K e & c2 | qg''' & Kg''' & c3
W(s)=1/s^0 * ... |  |  |  |
W(s)=1/s^1 * ... |  |  |  |
W(s)=1/s^2 * ... |  |  |  |
W(s)=1/s^3 * ... |  |  |  |

3.3. Изучить влияние (качественно) на вид переходной функции h(t) системы с астатизмом третьего порядка возмущающего воздействия f(t). В качестве f(t) использовать сигнал задания g(t) спроектированный для изучения типовых режимов движения систем. Возмущающее воздействие подавать до и после интегрирующих элементов, менять его знак и подбирать амплитуду так, чтобы ошибка от возмущения в установившемся режиме составляла 10...30 % от h(t) и была наглядна при визуальном наблюдении (информацию удобно представить в режиме перекрытия графиков).

3.4. Минимум три раза оптимально настроить ПИД-регулятор для модели системы регулирования (файл err_s^-1.vsm), используя разные функции цены - интегральные оценки качества. Для каждого случая заполнить таблицу.

KP | KI | KD
Функция цены и переходная характеристика h(t)

3.5. Оценить запас устойчивости и быстродействие по переходным характеристикам системы при различных настройках ПИД-регулятора, используя показатели качества: перерегулирование s, длительность переходного процесса tП, частота колебаний f, допустимое число колебаний, время запаздывания tЗ, время нарастания tН. Величиной допустимых отклонений 2D для определения длительности переходного процесса задаться самостоятельно.

3.6. Для тех же вариантов настроек ПИД-регулятора, используя АЧХ замкнутой системы |Ф(j w)| определить показатель колебательности М и показатели быстродействия: резонансную частоту wР, полосу пропускания wП, частоту среза wС, и эквивалентную полосу пропускания wЭ.

3.7. Для тех же случаев, определить запас устойчивости по амплитуде (модулю) L и по фазе m, используя АФХ (годограф Найквиста). Повторить определение по ЛАЧХ & ЛФЧХ.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Исследование точности в типовых режимах (пп. 3.1, 3.2, 3.3) следует проиллюстрировать временными зависимостями с подробными пояснениями. Внесенные в таблицы данные, должны быть отражены на графиках. Рекомендуется использовать режим графического наложения результатов моделирования при изменении знака и точки ввода воздействий.

4.2. Сравнить экспериментальные значения коэффициентов ошибки с расчетными.

4.3. В основе функций цены для итерационного процесса оптимизации должны быть: интегральная оценка качества; улучшенная интегральная оценка; и оценка дополнительно использующая параметры переходного процесса - перерегулирование или количество колебаний. Сравнить эффективность оценок, качественно характеризуя принципиально достижимые результаты.

4.4. Показатели качества найденные в пп. 3.5 и 3.7, нанести на переходные характеристики h(t), АЧХ замкнутой системы |Ф(j w)|, АФХ и ЛАЧХ & ЛФЧХ разомкнутой системы соответственно. Сравнить качество настроек ПИД-регулятора в трех случаях. АЧХ замкнутой системы |Ф(j w)| - это ее ЛАЧХ, у которой ось модуля не логарифмическая (снимите соответствующую галочку в свойствах графика). При определении ЛАЧХ & ЛФЧХ разомкнутой системы следует выделить требуемые блоки структурной схемы и отметить точки входа и выхода сигнала (Select Input/Output Points).


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 6
ПОВЫШЕНИЕ ТОЧНОСТИ САР

Рабочие файлы: [1.vsm] [2.vsm] [3.vsm] [4.vsm] [5.vsm]

1. Цель работы

Освоение основных методов повышения точности САР: 1) увеличения коэффициента усиления разомкнутой цепи, 2) регулирования по производным от ошибки с увеличением контурного коэффициента усиления, 3) повышения степени астатизма, 4) применения неединичных обратных связей и масштабирующих устройств на входе / выходе, 5) введения комбинированного управления.

2. Предварительное домашнее задание

2.1. Дано пять систем. Каждая обладает совокупностью уникальных свойств (см. табл.). В работе изучается пять методов повышения точности САР. Выбрать наиболее эффективный или единственно возможный метод повышения точности для каждой САР. Выбор обосновать.

Nо | Свойства САР (состоящих из минимально фазовых звеньев) | Метод, файл
1 | САР статическая. Контурный коэффициент мал (<10). Объект и чувствительный элемент являются одним конструктивным элементом (нет возможности изменить вид ЛАЧХ прямого канала) |
 | ИЛИ: ЛАЧХ разомкнутой системы в области низких частот имеет наклон -20 или -40 дб/дек. При этом либо в измерительном канале (на входе, вне контура регулирования) неединичный коэффициент передачи, либо в цепи обратной связи установлен делитель сигнала
2 | Объект моделируется двумя звеньями: колебательным (с большим подавлением) и апериодическим. Сопрягающая частота апериодического звена на две декады меньше резонансной частоты колебательного звена |
3 | ЛАЧХ разомкнутой системы имеет вид 20-0-20-40 (участок с нулевым наклоном не продолжителен). Предъявлены требования: минимально возможное перерегулирование, и малые собственные шумы САР. В точке единичного усиления фаза, уменьшаясь, пересекает значение -90 градусов с небольшим приращением |
4 | Объект моделируется двумя звеньями: колебательным (с большим подавлением) и апериодическим. Сопрягающая частота апериодического звена на две декады больше резонансной частоты колебательного звена |
5 | ЛАЧХ разомкнутой системы в области низких частот имеет наклон 0 дб/дек. Контурный коэффициент объекта не стабилен в той же полосе частот (в области низких частот); или предъявлено требование равенства нулю первой или первой и второй составляющих ошибки |

3. Содержание работы

3.1. Ознакомиться с предложенными моделями, идентифицировать их с описаниями в таблице.

3.2. Определить цель применения изучаемых методов повышения точности для каждой модели (повышение точности в установившихся режимах, увеличение запаса устойчивости или повышение быстродействия).

3.3. Повысить точность систем в соответствии с выбранными методами.

3.4. Качественно описать результаты применения методов повышения точности. Рекомендуется использовать переходную функцию h(t). Графическую информацию удобно представить в режиме наложения (перекрытия) результатов моделирования.

3.5. Используя инструменты частотного исследования систем (ЛАЧХ & ЛФЧХ) сформулировать ограничения в применении каждого метода повышения точности.

3.6. Выполнить количественное исследование результатов применения методов повышения точности САР на основе исследований (измерений) ошибки x(t). Можно измерить значения первых установившихся составляющих ошибки по: положению q0, скорости qu, ... - до и после применения методов повышения точности. По необходимости рекомендуется использовать тест-сигналы задания g(t): единичную ступенчатую функцию 1(t), синусоидальный, меняющийся с постоянной скоростью или ускорением (см. сигнал g(t) в файле err_ast3.vsm). Для измерений ошибки рекомендуется использовать: датчики скорости и ускорения (дифференцирующие звенья), преобразователи построенные в соответствии с интегральными оценками качества, а так же измерители действующего или средневыпрямленного значений (см. файл rms_ex.vsm). Выбор схемы измерения ошибки x(t) следует обосновать.

3.7. Рассмотреть все блоки (звенья), которые применялись для повышения точности. Назвать техническое устройство их практической реализации. Рассмотрев все модифицированные модели САР, указать необходимые диапазоны для подстраиваемых параметров этого устройства.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Готовые звенья для изменений в структурных схемах моделей находятся в блоке Instruments. Только требуемое звено и соответствующий регулятор настройки нужно перенести и подключить к модели. Изменения в структурных схемах отразить в отчете.

4.2. Если моделирование занимает много времени (10...20 с, VisSim 1.2), то отключите второстепенные визуализирующие приборы - такие как блок Display. Синхронный с разверткой вывод на экран информации на каждом шаге расчёта растягивает последний до 1/50 секунды.

4.3. В случае применения неединичных обратных связей или масштабирующих устройств на входе / выходе или комбинированного управления использование выходного сигнала чувствительного элемента системы (сумматора) для исследования ошибки x(t) не имеет смысла. Необходимо вычесть выходной сигнал y(t) из входного g(t) дополнительным сумматором.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 7
КОРРЕКЦИЯ САР

Рабочие файлы: [k1.vsm] [k2.vsm] [k3.vsm] [k4.vsm] [kor_ou3.ca4] [kor_c_in.ca4] [kor_cout.ca4] [kor_2_ou.ca4] [kor_derv.ca4] [kor_ooc.vsm] [функц. устр. на ОУ]

1. Цель работы

Освоение основных методов повышения запаса устойчивости (коррекции) САР: 1) демпфирования с подавлением высоких частот, 2) демпфирования с подавлением средних частот, 3) демпфирования с подавлением низких частот. Приобретение навыков решения типовых задач коррекции схем на операционных усилителях. Ознакомление с основными видами корректирующих обратных связей: 1) гибкими ООС, 2) жесткими ООС, 3) положительными (изодромное звено на апериодическом звене).

2. Предварительное домашнее задание

2.1. Дано четыре системы. Каждая обладает совокупностью уникальных свойств (см. табл.). Подобрать наиболее оптимальное или единственно возможное, последовательное корректирующее звено для каждой САР (апериодическое, пассивное дифференцирующее, пассивное интегрирующее, пассивное интегро-дифференцирующее). Выбор обосновать.

Nо | Свойства САР (состоящих из минимально фазовых звеньев) | метод, звено, файл
1 | ЛФЧХ разомкнутой системы чуть ниже частоты среза (в пределах декады) меняет свое значение от -90 до -270 градусов. Допустима минимально возможная потеря частотных свойств (площади ограниченной ЛАЧХ и осью частот) |
2 | ЛАЧХ разомкнутой САР соответствует трехкаскадному операционному усилителю без внутренней коррекции (звено с большим коэффициентом усиления и три апериодических звена с близкими сопрягающими частотами), и пересекает ось частот с наклоном -60 дб/дек. Допустима существенная потеря полосы пропускания |
3 | ЛФЧХ системы вплоть до частоты среза приобретает значения около -180 градусов. Для исключения условий, при которых возможно появление неустойчивости в большом, дополнительные отрицательные фазовые сдвиги не допустимы |
4 | Вблизи частоты среза и ниже по частоте более декады наклон ЛАЧХ разомкнутой системы составляет -40 дб/дек. Допустима минимально возможная потеря частотных свойств |

2.2. Составить структурную схему и построить ЛАЧХ & ЛФЧХ для передаточной функции корректирующего звена: W(s)=1/(1+T1s)+(0,1)+T2s/(1+T2s); T1=0,1; T2=0,0001. Определиться с его названием. Разобраться, какие изменения в структурной схеме звена надо сделать, чтобы получить: апериодическое, или пассивное дифференцирующее или пассивное интегрирующее звено.

3. Содержание работы

3.1. Ознакомиться с первыми четырьмя предложенными моделями систем, идентифицировать их с описаниями в таблице. Изменить параметры моделей так, чтобы их логарифмические частотные характеристики сместились вдоль частотной шкалы.

3.2. Скорректировать системы в соответствии с выбранными методами (ввести соответствующие корректирующие звенья в контур и настроить их, добиваясь устойчивости в замкнутом состоянии).

3.3. Дать количественную характеристику результатам коррекции, оценивая: полученный запас устойчивости (L & m или M), потери точности (K или Ku или K e), и уменьшение быстродействия (wП, wС).

3.4. По указанию преподавателя, для одной из исследуемых моделей составить подобную на операционных усилителях в пакете Electronics Workbench. Рекомендуется использовать модели из лаб. раб. №2. Смотри так же рабочий файл "функциональные устройства на ОУ".

3.5. Изучить модели *.ca4, в которых рассмотрены стандартные задачи коррекции схем на операционных усилителях. Описать суть способов коррекции. Дать количественную характеристику результатам, оценивая их аналогично пп. 3.3.

3.6. В соответствии с вариантом (см. табл.), составить подобную схеме на операционном усилителе модель из блоков пакета VisSim.

Вариант, модель | Описание типовых задач коррекции схем на ОУ
1 kor_ou3.ca4 | Выходное сопротивление ОУ и паразитная емкость монтажа выходных цепей образуют третий полюс ЛАЧХ, ведущий к неустойчивости. Модель можно рассматривать как схему на трехкаскадном ОУ без или с частичной внутренней коррекцией
2 kor_c_in.ca4 | Паразитная емкость монтажа входных цепей ОУ и большое сопротивление обратной связи образуют апериодическое звено первого порядка, которое может привести к неустойчивости схем на ОУ
3 kor_cout.ca4 | Необходимость работы ОУ на емкостную нагрузку приводит к тому, что выходное сопротивление ОУ и емкость нагрузки образуют третий полюс ЛАЧХ, ведущий к неустойчивости. Малое сопротивление емкости нагрузки на высоких частотах может перегрузить выход ОУ
4 kor_2_ou.ca4 | Стремление получить в схемах высокую точность и быстродействие приводит к необходимости использования двух ОУ (точного и быстродействующего). Но простое последовательное включение приводит к неустойчивости схемы, поскольку минимальное фазовое запаздывание для двух, даже корректированных ОУ составляет 180 градусов
5 kor_derv.ca4 | Построение дифференциатора на ОУ вызывает затруднения: а) в петле ОС ОУ оказывается включенным апериодическое звено с большой постоянной времени, что увеличивает результирующее запаздывание по фазе свыше значения 180 градусов и приводит к неустойчивости схемы; б) входное емкостное сопротивление дифференциатора может вызвать неустойчивость и в предыдущем каскаде на ОУ; в) коэффициент усиления схемы по высокой частоте велик и это ухудшает соотношение сигнал/шум

3.7. Ознакомиться с тремя наиболее часто используемыми видами корректирующих обратных связей (файл kor_ooc.vsm). Определить, какими последовательными корректирующими звеньями можно добиться тех же результатов.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. Определить ЛАЧХ & ЛФЧХ разомкнутой системы в пакете VisSim можно без размыкания контура - необходимо выделить все блоки файла, а за тем отменить выделение только для источника сигнала и сумматора. Если САР неустойчива, то нужно разорвать контур. Для описанного выделения выполните два действия: а) установите мышь на свободное место и нажмите Shift+[правая клавиша мыши] (выделение всей схемы), б) повторная отметка указанной комбинацией любого элемента схемы отменит выделение для него. В некоторых случаях потребуется принудительно отметить вход и выход. Далее - стандартно.

4.2. При составлении моделей по пп. 3.4, допускается произвольная инверсия сигналов в схемах на операционных усилителях, но следует обратить внимание на результирующий фазовый сдвиг от инверсии.

4.3. Схемотехника инвертирующих включений операционных усилителей предполагает введение входного сигнала в корректирующую цепь. Если при построении моделей в пакете VisSim по пп. 3.6 это вызывает затруднения, то можно перейти к неинвертирующему включению операционного усилителя.

4.4. В пакете Electronics Workbench методика использования виртуального прибора - анализатора сильно упрощена. На практике, подобные подключения прибора не позволят снять частотную характеристику операционного усилителя с разорванной обратной связью. Дайте пояснения.

4.5. В файле kor_ooc.vsm корректирующие обратные связи должны включатся не одновременно.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 8
СИНТЕЗ САР

Рабочие файлы: [w1.vsm] [w2.vsm]

1. Цель работы

Приобретение навыков использования метода логарифмических частотных характеристик и метода корневых годографов для синтеза САР.

2. Предварительное домашнее задание

2.1. В соответствии с вариантом (см. табл.) построить располагаемую ЛАЧХ объекта регулирования. Учитывая требования к точности и к устойчивости, нанести на график низкочастотную и высокочастотную запретные области.

Параметры

Значения

 Вариант
Располагаемая передаточная функция
объекта
Wo(s) = | 100 | 1 | w1.vsm
 | 1+0,33s | s2/30002+2*0,04s/3000+1
 1, 2
Wo(s) = | 100 | 40 | 1 | w2.vsm
 | s | 1+0,0033s | s2/30002+2*0,04s/3000+1
 3, 4
Требования
к точности 		Vm =10 ед./с; Em = 100 ед./с2; Xm =0,01 ед. 1, 3
wK = 0,3 рад/с; Dj = 0,573e-3 град; d = 9e-6 % | 2, 4
к устойчивости | M < 1,16 | 1,2,3,4

2.2. Определить передаточные функции последовательных (возможно последовательно-параллельных) корректирующих устройств, которые рекомендуется разбить на типовые звенья. Составить структурную схему системы с устройствами коррекции.

3. Содержание работы

3.1. Дополнить структурные схемы в рабочих файлах рассчитанными последовательными корректирующими звеньями. Проверить, имеет ли ЛАЧХ системы желаемый вид.

3.2. Пустые блоки "1" и "2" определяют места возможного подключения средств коррекции к реальной системе. Заменить часть последовательных корректирующих устройств эквивалентной обратной связью, в соответствии с заданной структурой системы.

3.3. Точно настроить устройства коррекции и выполнить измерения, подтверждающие верность результатов синтеза, подавая тест сигналы с необходимыми параметрами.

3.4. Используя корневой годограф, определить параметр затухания z для сопряженных комплексных корней передаточной функции синтезированной системы при единичной обратной связи. А также определить во сколько раз должен увеличиться контурный коэффициент усиления (добротность по скорости), чтобы система оказалась на границе устойчивости (проверить по переходной функции).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. При синтезе низкочастотных корректирующих устройств следует полагать, что подъём ЛАЧХ от запретной области не допустим, по причине возможного возрастания влияния помех и наводок на входе.

4.2. При выполнении измерений, цель которых - определить точность замкнутой системы, следует подавать синусоидальные сигналы как на участках границы запретной области с разным наклоном, так и на сопрягающей частоте. Только фазовую ошибку Dj допустимо измерить, прибегая к функциям частотного анализа (необходимо задаваться очень узким частотным диапазоном).

4.3. При точной настройке системы по показателю колебательности M следует помнить, что второй пик АЧХ замкнутой системы |Ф(j w)| так же не должен достигать уровня M.

4.4. Для построения годографа корней в пакете VisSim нужно выделять разомкнутую систему W(s).

4.5. VisSim строит годограф корней - 1+KocW(s)=0 - характеристического уравнения замкнутой системы Ф(s) с варьируемым коэффициентом передачи в цепи обратной связи Koc, для выделенных блоков, которые принимает за разомкнутую систему W(s):

  1. Если Koc=0, то корни уравнения 1+KocW(s)=0 устремляются к корням-полюсам W(s), которые отмечены крестами (только при Koc=0!).
  2. Если Kос стремится к бесконечности, то часть корней уравнения 1+KocW(s)=0 устремляется к корням-нулям W(s), а часть - к бесконечности.
  3. Если Koc=1, то характеристическое уравнение соответствует единичной обратной связи.

4.6. Если уточнять координаты корней на траекториях годографов, то дополнительно будут высвечиваться три соответствующие корню параметра: 1) Koc; 2) параметр затухания - z (в программе VisSim - z); 3) угловая частота свободных колебаний - w. По значению Koc, можно оценить: при каких значениях контурного коэффициента усиления K*Koc система станет не устойчивой, а также быстродействие системы. Степень быстродействия определяется по самому ближнему к мнимой оси корню на траекториях при заданном значении Koc. Параметр затухания - z и угловую частоту свободных колебаний - w легко интерпретировать, если вспомнить, что передаточная функция замкнутой системы с комплексными корнями Ф(s) часто может быть аппроксимирована колебательным звеном.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 10
СИСТЕМЫ С ЗАПАЗДЫВАНИЕМ

Рабочие файлы: [e^(-st).vsm] [Вар1 e^(-st)2.vsm] [Вар2 e^(-st)2.vsm] [Вар3 e^(-st)2.vsm] [Вар4 e^(-st)2.vsm]

1. Цель работы

Идентификация влияния временного запаздывания на устойчивость и точностные параметры систем. Ознакомление с различными моделями-аппроксиматорами звена временного запаздывания. Приобретение навыков обоснования применения моделей с допущениями.

2. Предварительное домашнее задание

2.1. Рассчитать критическое запаздывание для системы (файл e^(-st)2.vsm) (по вариантам).

2.2. Построить асимптотические ЛАЧХ & ЛФЧХ для звена с передаточной функцией W(s)=(1-Ts)/(1+Ts).

3. Содержание работы

3.1. Ознакомиться с процессом симуляции в звене временного запаздывания, построенном на буфере (блок "timeDelay"). Изучить структурное построение двух предложенных линеаризовананных моделей-аппроксиматоров звена временного запаздывания (файл e^(-st).vsm).

3.2. Оценить адекватность получаемых результатов при использовании каждой из трех альтернатив звена в моделях систем, если ставятся задачи: а) симуляции движения (файл e^(-st).vsm); б) оценки точности (файл e^(-st)2.vsm); в) оценки запаса устойчивости (файл e^(-st)2.vsm).

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. При использовании линеаризованных моделей-аппроксиматоров звена временного запаздывания наиболее схожими переходные процессы будут в случае использования простейших методов интегрирования - Эйлера, и трапециидального. В пакете VisSim все функции анализа для блока "timeDelay" не доступны.

4.2. Выполняя пункт 3.1, следует назвать звенья составляющие модели-аппроксиматоры звена временного запаздывания и указать, каким образом следует изменить их структуру для более точной аппроксимации.

4.3. Оценить адекватность симуляции движения (пп. 3.2.а) необходимо исходя из положений: а) сигнал на входе системы имеет широкий спектр (может меняться с большими скоростями и ускорениями); б) сигнал на входе звена, в силу инерционных свойств системы, имеет ограниченный спектр.

4.4. Оценить адекватность результатов при исследовании точностных параметров систем (пп. 3.2.б) необходимо для двух методик. Первая предполагает измерение ошибок в типовых режимах движения (см. л.р. No 5). Вторая - изучение параметров ЛАЧХ в области низких частот (см. л.р. No 8).

4.5. Оценить адекватность результатов при исследовании запасов устойчивости систем (определении критического запаздывания), (пп. 3.2.в) необходимо для двух методик. Первая предполагает подбор запаздывания при симуляции движения до получения переходного процесса соответствующего границе устойчивости. Вторая базируется на изучении частотных свойств разомкнутой системы в области частоты среза либо по ЛАЧХ & ЛФЧХ, либо по АФХ (годограф Найквиста).

4.6. Выводы по работе должны содержать рекомендации о том, каким из аналогов звена временного запаздывания наиболее целесообразно пользоваться и для каких целей.


ТАУ - РУКОВОДСТВО К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ

Лабораторная работа 12
ЦИФРОВЫЕ СИСТЕМЫ

Рабочие файлы: [Приложение 1] [Приложение 2] [Рис. 1] [Рис. 2] [err_s^-1.vsm] [k3.vsm]

1. Цель работы

Приобретение навыков составления программ для ЦВМ реализующих дискретные передаточные функции. Уяснение технических различий между непосредственным, последовательным и параллельным алгоритмами программной реализации дискретных фильтров.

2. Предварительное домашнее задание

2.1. Выбрать язык программирования для выполнения лабораторной работы - Pascal или Си++. Ознакомится с технологией создания внешних dll-моделей для моделирующей программы VisSim (см. прил. 1, 2).

2.2. Адаптировать предложенный шаблон программы для реализации рекурсивного цифрового фильтра второго порядка. По умолчанию можно выбрать произвольные значения для коэффициентов фильтра, но они должны быть доступны для изменения пользователем. Фильтр должен иметь дополнительный вход для сигнала синхронизации выполнения программы. Если номер варианта 1, 2, 5, 6, ..., то нужно воспользоваться непосредственным алгоритмом с одним буфером; если - 3, 4, 7, 8, ..., то тем же алгоритмом, но с двумя буферами (см. рис. 1, 2).

3. Содержание работы

Изучаемая методика построения цифровых регуляторов или устройств коррекции предполагает переход к дискретным реализациям от непрерывных аналогов. Нечетные варианты должны реализовать цифровой ПИД-регулятор (файл err_s^-1.vsm), четные - цифровое корректирующее устройство (файл k3.vsm). Далее по тексту для четных вариантов вместо названия "ПИД-регулятор" следует читать "корректирующее устройство".

3.1. В рабочем файле *.vsm настроить ПИД-регулятор определив качественные показатели по своему усмотрению. Изменить параметры системы так, чтобы ЛАЧХ & ЛФЧХ сместились вдоль частотной шкалы в пределах двух декад.

3.2. Заменить структурную схему ПИД-регулятора одним блоком "transferFunction" с эквивалентными параметрами. Проконтролировать неизменность переходного процесса.

3.3. Несколько раз осуществить переход от непрерывной передаточной функции ПИД-регулятора (transferFunction) к дискретной, отыскивая наибольший период дискретизации, при котором качество переходного процесса не ухудшается значительно.

3.4. Перенести коэффициенты дискретной передаточной функции регулятора в подготовленный текст программы, выполнить её компиляцию и подключить полученную динамически загружаемую библиотеку (файл *.dll) к рабочему файлу посредствам блока "userFunction". Убедиться в схожести переходного процесса.

3.5. Разложить дискретную передаточную функцию регулятора на множители и на элементарные дроби, для написания разделённых программ в соответствии с последовательным и параллельным алгоритмами. В соответствии с этими алгоритмами в рабочем файле регулятор должен состоять из блоков "userFunction" включенных последовательно или параллельно.

4. Методические указания к моделированию и рекомендации к содержанию отчета

4.1. При выполнении работы рекомендуется использовать простейший метод интегрирования - Эйлера.

4.2. При настройке ПИД-регулятора рекомендуется убедиться в отсутствии комплексных нулей у его передаточной функции. Если таковые имеются, следует поднять коэффициент в пропорциональном канале.

4.3. Получить коэффициенты полиномов числителя и знаменателя, а также значения их корней для выделенной части структурной схемы можно воспользовавшись пунктами меню "Analyze", "Transfer Function Info".

4.4. Для осуществления перехода от непрерывной передаточной функции к дискретной, на вкладке свойств блока "transferFunction" следует нажать кнопку "Convert S->Z" и ввести период дискретизации больший, чем шаг моделирования.

4.5. При манипуляциях с коэффициентами полиномов числителя и знаменателя дискретных фильтров следует воздержаться от округлений - переход от изображения Лапласа к Z-изображению описывается свертыванием правой полуплоскости "устойчивых" корней в несравнимо малую окружность единичного радиуса, т.е. точность позиционирования корня должна быть эквивалентно выше.

4.6. Разложение на множители и на элементарные дроби не обязательно выполнять для дискретной передаточной функции, можно выполнить его и для непрерывной, а потом уже перейти к дискретным фильтрам первого порядка. При этом возможности пакета VisSim освобождают от расчетов.

4.7. Для выявления других технических особенностей каждого из трех алгоритмов следует попытаться идентифицировать частотные свойства для разделенных блоков, составляющих ПИД-регулятор (см. пп. 3.5) и выявить параметры, которые отвечают за его настройки.


Рабочая программа дисциплины ТАУ

Для написания собственной рабочей программы Вам следует сохранить архив vissim.nm.ru/rp_tau.zip на своем диске, разархивировать содержащийся в нем документ программы MS Word. Внести требуемые изменения и распечатать.

Предлагаемый макет программы не содержит информацию для служебного пользования (билеты к экзамену, и пр.), поскольку предполагается передача учебно-методического комплекса в данной комплектации студентам.


Вопросы к экзамену по ТАУ

Клиначёв Николай Васильевич

Вопросы к экзамену по курсу ТАУ

Примеры автоматических систем. Принципы автоматического регулирования. Классификация автоматических систем. Программы и законы регулирования. Демонстрационные примеры адаптивных систем.

Линеаризация дифференциальных уравнений (ДУ) систем автоматического регулирования (САР). Геометрическая трактовка линеаризации. Формы записи линеаризованных уравнений. Единичная функция, дельта-функция, переходная функция и функция веса. Частотная передаточная функция (ПФ), частотные характеристики. Позиционные звенья. Интегрирующие звенья. Дифференцирующие звенья. Составление исходных ДУ САР (форма Коши; решенные относительно: ошибки, относительно регулируемой величины). ПФ используемые для описания систем (W(p), Wf(p), Ф(p), Фх(p)). Линейные непрерывные законы регулирования (пропорциональное регулирование, интегральное регулирование, изодромное регулирование, регулирование с использованием производных).

Понятие устойчивости для линейных САР. Условия устойчивости, типы границы устойчивости. Необходимое условие устойчивости САР, достаточное для систем 1-ого и 2-ого порядков. Критерий устойчивости Гурвица. Критерий устойчивости Михайлова. Свойства, примеры годографов Михайлова. Построение областей устойчивости D-разбиение. Критерий устойчивости Найквиста. Свойства, примеры годографов Найквиста. Определение устойчивости по ЛАЧХ & ЛФЧХ. Методика построения асимптотических ЛАЧХ & ЛФЧХ линейных систем.

Основные подходы к оценке качества систем и общие понятия о соответствующих критериях. Точность САР в типовых режимах. Коэффициенты ошибок. Оценка запаса устойчивости и быстродействия по переходной характеристике. Корневые методы оценки качества (колебательность, степень быстродействия). Понятие о среднегеометрическом корне. Мажоранта и миноранта переходного процесса. Интегральные оценки качества (линейная, квадратичная, улучшенная). Частотные критерии качества. Показатель колебательности.

Постановка задачи повышения точности систем, обзор используемых методов. Увеличение коэффициента усиления разомкнутой цепи, как метод повышения точности. Повышение степени астатизма, как метод повышения точности. Применение регулирования по производным, как метод повышения точности. Комбинированное управление. Введение неединичных обратных связей.

Постановка задачи коррекции систем, обзор используемых методов. Способы введения корректирующих звеньев. Практическая реализация последовательных корректирующих звеньев. Демпфирование с подавлением высоких частот. Демпфирование с подавлением средних частот. Демпфирование с подавлением низких частот или эквивалентным поднятием высоких. Демпфирование с введением отрицательных фазовых сдвигов. Применение корректирующих обратных связей.

Постановка задачи синтеза систем, обзор используемых методов. Метод логарифмических амплитудных характеристик. Требования к низкочастотной части (НЧ) желаемой ЛАЧХ. Построение НЧ части желаемой ЛАЧХ. Требования к высокочастотной части (ВЧ) желаемой ЛАЧХ. Построение ВЧ части желаемой ЛАЧХ. Корневой метод синтеза. Метод корневых годографов.

Системы с переменными (var) параметрами и их реакции на стандартные возмущения 1(t) и d(t). Отыскание ПФ систем с var-параметрами. Устойчивость и качество регулирования систем с var-параметрами. Синтез параметрических систем.

Системы с запаздыванием; ПФ звена чистого запаздывания. Линеаризованные аппроксиматоры звена времянного запаздывания, вопросы адекватности. Устойчивость и качество регулирования систем с запаздыванием.

Импульсные системы; виды модуляции. Типовая структура импульсной системы. Решетчатые функции. Математические операции с решетчатыми функциями. Разностные уравнения. Z-преобразование. Математическая модель реального импульсного элемента. Понятие дискретной ПФ. Правила преобразования структурных схем дискретных систем. ПФ системы с экстраполятором нулевого порядка и звеном запаздывания. ПФ системы с экстраполятором, осуществляющим АМ первого и второго рода. ПФ замкнутой дискретной системы (для регулируемой координаты, для ошибки, для возмущений). Дискретная синусоидальная последовательность, теорема Котельникова, частота Найквиста. Частотные ПФ импульсных систем. Устойчивость и качество импульсных систем. W-преобразование.

Системы с ЦВМ, общие понятия. Процессы, протекающие в системах с ЦВМ. Методика вывода дискретных ПФ. О синтезе систем с ЦВМ методом логарифмических амплитудных характеристик. Дискретная коррекция. Дискретное представление непрерывных регуляторов. Модифицированные законы регулирования. Алгоритмы составления программ, реализующих ПФ на ЦВМ. Примеры составления программ для ЦВМ.


Вопросы к экзамену по ТАУ

Клиначёв Николай Васильевич

Билеты-задачи по ТАУ к государственному экзамену

Задача № 1 ТАУ

Выбрать оптимальный метод и повысить точность системы, если известна её частотная характеристика в разомкнутом состоянии (система имеет единичную обратную связь (ОС)).

Совокупность возможных методов повышения точности ограничена требованием сохранить линейность системы. Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. Блок-схему (модель) системы составить и сдать комиссии до подхода к ЭВМ.

Задача № 2 ТАУ

Выбрать оптимальный метод, и выполнить коррекцию системы, модель которой изображена на рисунке.

Совокупность возможных методов коррекции ограничена требованием сохранить линейность системы. Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. Асимптотические ЛАЧХ & ЛФЧХ построить и сдать комиссии, указав название метода коррекции, до подхода к ЭВМ.

Задача № 3 ТАУ

Указать настройки ПИД-регулятора, формирующего управляющее воздействие на объект, передаточная функция которого изображена на рисунке (система имеет единичную ОС). Требования к точности системы: Vm=10ед./с; Em=100ед./с2; Xm=0,01ед. Требование к устойчивости: M < 1,16.

Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. Фрагменты ЛАЧХ & ЛФЧХ, удовлетворяющие предъявленным к системе требованиям построить и сдать комиссии до подхода к ЭВМ.

Задача № 4 ТАУ

Выполнить проектирование дискретной коррекции для замкнутой системы с единичной ОС, чьи ЛАЧХ & ЛФЧХ для разомкнутого состояния и ПФ непрерывного корректирующего устройства приведены на рисунках. Дискретное корректирующее устройство должно быть представлено в виде блок-схемы на регистрах задержки (предъявлять текст программы необязательно).

Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. ЛАЧХ & ЛФЧХ разомкнутой, некорректированной системы, а так же ее блок-схему построить и сдать комиссии до подхода к ЭВМ.

Задача № 5 ТАУ

Определить запасы устойчивости по амплитуде и фазе для системы изображенной на рисунке. Найти выражение для ошибки системы x(t) в установившемся режиме работы при заданном входном сигнале.

Решение задачи должно быть выполнено (подтверждено моделированием) системы в пакете VisSim. До подхода к ЭВМ предъявить комиссии асимптотические ЛАЧХ & ЛФЧХ разомкнутой системы, выражение для сигнала задания g(t) и значения первых трех коэффициентов ошибок замкнутой системы.


Каталог ссылок - Симуляция движения (моделирование)

Интерактивный каталог ссылок

(Каталог виден только при наличии подключения к Интернету)


e-Группa "Симуляция движения (моделирование)"

VisSim.nm.ru & VisSim.com

Приглашение к членству в дискуссионной группе
"Симуляция движения" (моделирование)

Уважаемые коллеги, приглашаем Вас вступить в почтовую дискуссионную группу "Симуляция движения". Будучи членом группы вы сможете обратиться с актуальными для вас вопросами к ведущим специалистам России в области моделирования. Сегодня почетными членами группы являются три коллектива разработчиков программ математического моделирования динамических систем:

  • Peter Darnell, президент фирмы Visual Solutions, Inc., которая разрабатывает пакет VisSim и Клиначёв Николай Васильевич, координирующий русскоязычных пользователей пакета VisSim.
  • Козлов Олег Степанович, представитель московского коллектива разработчиков пакета MBTY (Моделирование В Технических Устройствах).
  • Сениченков Юрий Борисович, представитель санкт-петербургского коллектива разработчиков программы MVS (Model Vision Studium).

Дискуссии в группе связаны с аспектами использования специализированных пакетов математического моделирования динамических систем – VisSim, Simulink (MATLAB), SystemBuild (MATRIXx), Anylogic (Model Vision Studium), MBTY, 20-sim, ITI-SIM, DyMoLa, SIMPLORER, DYNAST, hAMSter, Easy5, DASE, Electronics Workbench и т.д. Наиболее активными членами группы являются преподаватели дисциплины "Теория систем автоматического регулирования" и аспиранты соответствующих кафедр. Так же мы рады студентам.

Ключевые слова для обсуждаемых тем: симуляция движения, моделирование, управление; системы (объекты) линейные, нелинейные, непрерывные, дискретные, гибридные; инструменты частотные, корневые, вариационные, нейронные, компилирующие, оценки качества, устойчивости, быстродействия, синтеза, коррекции, оптимизации, линеаризации, программирования цифровых сигнальных процессоров - DSP, отладки в контуре модели реальных объектов.

Дискуссионные группы работают 24 часа в день, 7 дней в неделю, 365 дней в году. Их тысячи. Их работа контролируется почтовыми роботами. Робот – это специальная программа, работающая с почтой на сервере в сети. Именно она обеспечит вам общение с членами группы. Процедура следующая. Вы пишите письмо и направляете его в группу (роботу). Робот проверяет, являетесь ли вы членом группы, и, если это так, то рассылает ваше письмо всем членам. Любой член группы может написать вам ответ. Таким образом, для участия в дискуссиях вам необходимо иметь лишь желание общаться и адрес электронной почты (e-mail).

АДРЕСНАЯ ИНФОРМАЦИЯ ДЛЯ УПРАВЛЕНИЯ ПОДПИСКОЙ (команды почтовому роботу)
Подписка (вступление в группу): vissim-subscribe@yahoogroups.com | пустое письмо
Почтовое сообщение ко всем членам (доступно только члену группы): vissim@yahoogroups.com |
Прекращение членства: vissim-unsubscribe@yahoogroups.com | пустое письмо
Письмо ведущему: vissim-owner@yahoo... |
Приостановка подписки (вы ушли в отпуск): vissim-nomail@yahoogroups.com | пустое письмо
Переход в режим дайджеста (удобен для наблюдателей): vissim-digest@yahoogroups.com | пустое письмо
Возврат в нормальный режим: vissim-normal@yahoogroups.com | пустое письмо
Изменение почтовых настроек: http://groups.yahoo.com/mygroups |
Адрес группы: http://groups.yahoo.com/group/vissim |

Поясним порядок вступления в группу:

  1. Вы посылаете пустое письмо по адресу vissim-subscribe@yahoogroups.com. Его получает робот группы, и, минут через 15, Вы получите его ответ. Поскольку сервис Yahoo является международным, ответ робота будет на английском языке. Суть письма, сформированного для вас роботом, состоит в том, что вам предлагается два способа подтверждения подписки.
  2. Для подтверждения вашего желания подписаться рекомендуется просто отослать письмо робота обратно, воспользовавшись кнопкой "Ответить отправителю" в инструментальной панели почтовой программы (ни каких изменений в письме делать не нужно). Получив ваш ответ, робот включит вас в список членов группы, вышлет вам приветственное сообщение и правила дискуссионной группы (уже на русском языке).
  3. После получения правил дискуссионной группы вы можете приступать к общению с ее членами. Для этого нужно писать письма по адресу vissim@yahoogroups.com.

По адресу группы имеются дополнительные возможности:

  • В архив, доступный членам группы, можно положить свою интересную модель.
  • Вы найдете коллекцию интересных нашей группе ссылок и внесете свои.
  • Можете инициировать голосование и принять в нем участие.
  • Можете обсудить вопросы в тематическом web-форуме.
  • Составить краткую справку о себе для членов группы.
  • Настроить способ получения почты.

Если сейчас у вас нет возможности отправить письмо (т.е. вы за чужим компьютером) – воспользуйтесь желтой формой, которая приведена ниже.

Online подписка на VisSim
Сервис groups.yahoo.com

PS Более 650 российских специалистов в области АСУ ТП уже выбрали подобный инструмент общения (asutp-subscribe@yahoogroups.com), оценив этот сервис выше услуг серверов новостей (группа news:fido7.ru.scada SCADA - системы автоматизации). Есть группа, обсуждающая вопросы использования в России программной и аппаратной продукции корпорации National Instruments (LabVIEW_ru-subscribe@yahoogroups.com).

19.10.2000


Основы моделирования систем

VisSim.nm.ru & VisSim.com 519.8(07)
К493

Н. В. Клиначёв

ОСНОВЫ МОДЕЛИРОВАНИЯ СИСТЕМ
ИЛИ 7 ДОМЕНОВ ЗАКОНОВ
ОМА И КИРХГОФА

Избранные фрагменты


Оглавление лекций Клиначёва по основам моделирования систем

Основы моделирования систем

  1. Введение в дисциплину
    • Проблематика, задачи и цель моделирования
    • Технологии функционирования моделирующих программ
    • Обзор и классификация моделирующих программ
    • Решатели моделирующих программ
    • Понятие о структурном и мультидоменном физическом моделировании
    • Идея мультидоменного физического моделирования
    • Понятие об управляемом событиями моделировании
    • Инструментарий моделирующих программ
  2. Введение в технологию моделирования на основе направленных графов
    • Принцип поточного исполнения блок-схем (моделей)
    • Библиотеки блоков графических языков
    • Блоки обладающие эффектом памяти
    • Понятие о начальных условиях модели
    • Понятие о параметрах модели
    • Понятие о методах интегрирования
    • Выбор шага симуляции и метода интегрирования
  3. Введение в технологию моделирования на основе ненаправленных графов
    • Принципы построения графа схемы физической принципиальной
    • Элементы ненаправленного графа
    • Пассивные элементы ненаправленного графа (потребители энергии)
      • Безинерционный элемент (активное сопротивление)
      • Реактивный элемент 1
      • Реактивный элемент 2
    • Активные элементы ненаправленного графа (источники энергии)
      • Источник движущей силы (генератор энергетических потенциалов)
      • Источник потока (генератор потока материи)
      • Прерыватель алгебраических петель (инициатор потока материи)
      • Заземлитель потенциала
    • Узлы ненаправленного графа
      • Распределяющий (материю) узел
      • Аккумулирующий (материю) узел
    • Рекомендации к использованию библиотеки элементов
  4. Обзор методов анализа моделей, систем и сигналов
    • Идентификация моделей
    • Символьный анализ математического описания моделей
      • Билинейное преобразование
      • Разложение математического описания модели САР в степенной ряд
    • Частотный анализ моделей и систем
      • Вычислительные алгоритмы идентификации ЧХ моделей
      • Измерительные алгоритмы идентификации ЧХ моделей и систем
      • Алгоритмы идентификации ЧХ систем на основе технологий распознавания образов
  5. Литература
  6. Приложение 1. Архитектура моделирующих программ
  7. Приложение 2. О структурном кризисе в методике преподавания блока дисциплин связанных с расчетом цепей преобразования энергий


Введение в дисциплину "Основы моделирования систем"

Рабочие файлы: [Истинная и ложная модели]

Моделирование
1) Искусство построения истинных или ложных (по соответствию физической природе) моделей систем.
2) Совокупность действий по созданию модели реальной системы, последующая цель которых – изучение природы системы, возможностей ее структурного развития или прогнозирование поведения.
Симуляция движения
Процесс движения координат модели направленный на получение адекватных результатов.

Модели систем могут иметь разную физическую природу. Компьютеры и соответствующее ПО являются наиболее адаптивными физическими объектами, из тех, которые могут быть основой для построения моделей. Дальнейшее изложение связано с программами математического моделирования динамических систем, к которым относятся: VisSim, Simulink (MATLAB), SystemBuild (MATRIXx), Anylogic (Model Vision Studium), MBTY, 20-sim, ITI-SIM, DyMoLa, SIMPLORER, DYNAST, hAMSter, Easy5, DASE и др.

Проблематика, задачи и цели моделирования

В теории моделирования основными являются проблемы: разработки универсальных подходов к построению моделей, точности симуляции движения их координат, оценки величин погрешностей, адекватности получаемых результатов, идентификации изучаемых систем, синтеза технических устройств и гипотез.

Задачи общей теории моделирования заключаются в решении перечисленных проблем. При поиске решений используются:

  1. Методы теории подобия
  2. Методы теории расчета цепей
  3. Методы теории систем автоматического управления
  4. Численные методы

Глобальными целями моделирования являются вопросы изучения природы систем, возможностей их структурного развития и прогнозирование поведения.

Технологии функционирования моделирующих программ

Каждая из программ математического моделирования динамических систем основана на одной из двух технологий:

  1. Первая технология предполагает использование поточной модели управления при выполнении математических преобразований (функций) составляющих модель.
  2. Вторая технология предполагает представление модели в виде текстовой записи системы уравнений, которую решатели моделирующих программ обрабатывают в пакетном режиме.
Поточная модель управления (Data Flow)
Модель программирования, в которой инструкции, процедуры или функции выполняются только тогда, когда все входные данные (т.е. параметры и аргументы) готовы.

Все потенциальные возможности программ с поточной моделью управления можно оценить, ознакомившись с программным комплексом LabVIEW (это не моделирующая программа, а лишь блестящий пример возможностей технологии). Вторая технология наиболее понятно и открыто представлена в программе Dynast.

Обзор и классификация моделирующих программ

Наблюдается устойчивая тенденция к выравниванию возможностей разных моделирующих программ. Специалист, привыкший к тому или другому пакету не испытывает жесткой потребности в смене программы по причине баланса возможностей. Есть только один причинный критерий, который нужно принимать во внимание при выборе – это технология функционирования математического ядра моделирующей программы. Согласно этому признаку популярные программы сведены в таблицу.

Программы с поточной моделью управления
VisSim MBTY Simulink Easy5 | "+" Эти программы легко интегрируются с системами сбора данных, благодаря чему возможно создание (компьютерных) моделей с физическими объектами в контуре. В большинстве из них возможно программирование цифровых сигнальных процессоров. Структура их моделей может меняться в процессе симуляции без затрат времени, согласно событийному управлению.
Программы – интерпретаторы систем уравнений
Dynast 20-sim Dymola Simplorer ITI-sim Pspice Multisim Micro-Cap | "+" Эти программы, в скрытом от пользователя режиме, легко преобразуют текстовую запись систем уравнений к требуемому решателям виду. Фактически с пользователя снята, задача подключения к модели итерационного решателя алгебраических уравнений. Эти особенности технологии позволили не ограничиваться моделями в виде передаточных функций, и, временно, эти программы заняли лидирующие позиции в области мультидоменного моделирования. Они предоставляют пользователю возможность строить модели в виде схем физических принципиальных.

Недостатки первой группы моделирующих программ связаны с достоинствами второй и наоборот. Существует технология построения моделей элементов физических устройств с помощью бинаправленных (не направленных) графов связи, которая дает шанс программам первой группы однозначно занять лидирующую позицию.

Главным затруднением для разработчиков моделирующих программ является графический интерфейс, который, по сути, должен быть полноценным редактором векторной графики. По этой причине любая интеграция моделирующих программ с пакетами Visio или CorelDRAW должна приветствоваться пользователями.

Решатели моделирующих программ

Рабочие файлы: [Метод Ньютона] [Метод секущих] [Формулы] [СЛАУ] [СНАУ] [ДСНАУ]

Явный решатель моделирующей программы
Это библиотека классических подпрограмм (функций), которые реализуют операцию интегрирования. (Дискретные квази-аналоги интеграторов используются для решения дифференциальных уравнений).
Неявный (итерационный) решатель моделирующей программы
Это библиотека классических подпрограмм, которые предназначены для решения алгебраических уравнений путем итерационного подбора независимых переменных.
Оптимизирующий решатель моделирующей программы
Это разновидность неявного решателя, которая предназначена для минимизации значения функции в процессе итерационного подбора ее независимых переменных.

Демонстрация использования неявного (итерационного) решателя для поиска корней квадратного (т.е. алгебраического) уравнения

На рис. показана техника подключения неявного решателя (блоков unknown и constraint – неизвестная и нулевой_баланс) к алгебраическому полиному с целью поиска корней уравнения. На каждом шаге симуляции неявный решатель, в итерационном процессе, подбирает такое значение на выходе блока неизвестная (этот блок, по сути, является генератором сигнала), которое, будучи подставлено в полином обнулит его. За фактом обнуления следит датчик решателя – блок нулевой_баланс. Если инициировать решатель (блок неизвестная) разными начальными значениями, то можно найти оба корня.

Понятие о структурном и мультидоменном физическом моделировании

Структурное моделирование
Техника моделирования основанная на использовании моделей в виде преобразующих сигналы блоков. Связи между входными и выходными сигналами устанавливаются посредством задания передаточных функций. Поскольку структурные блоки имеют выраженные входы и выходы, построенные согласно этой технике модели иногда называют направленными сигнальными графами (см. рис. 1).
Мультидоменное физическое моделирование
Техника моделирования основанная на использовании универсальной библиотеки моделей элементов физических устройств, из которых можно составлять схемы физические принципиальные. Поскольку в энергетических цепях поток материи может менять направление, построенные согласно этой технике модели иногда называют ненаправленными или бинаправленными сигнальными графами (см. рис. 2).
Естественно-физическое моделирование
Переходная техника физического моделирования не использующая модели элементов физических устройств и предполагающая задание системы уравнений либо в графической, либо в текстовой форме (см. рис. 3).

Математический аппарат теории систем автоматического регулирования предполагает исключение алгебраических уравнений со свободными переменными из моделей технических устройств. Таким образом, техника структурного моделирования, использующая модели в форме передаточных функций, требует наличия лишь явного решателя. Явный решатель подключается ко всем интеграторам модели (блоки 1/S), и, с той или иной точностью (на что влияет выбор метода интегрирования), интегрирует соответствующие сигналы, обеспечивая тем самым решение дифференциальных уравнений.

Модель - направленный сигнальный граф
Рис. 1

Неявный решатель позволяет перейти к иной технике построения моделей, которая предусматривает закрепление за группами уравнений условных графических обозначений элементов энергетических цепей (резистора, транзистора, магнитного сердечника, пневмоцилиндра и пр.).

Модель - ненаправленный сигнальный граф
Рис. 2

Следует отметить, что в программах с поточной моделью управления подключение неявного решателя возложено на пользователя. Задача составления моделей физических элементов, с такой структурой, дабы при составлении из них произвольных энергетических цепей корректно стыковались алгебраические уравнения, вызывала затруднения. По этой причине данный класс программ отстал в технике мультидоменного физического моделирования и в них распространена устаревающая техника естественно-физического моделирования.

Модель - система уравнений
Рис. 3

На рисунках, для сравнения, демонстрируются модели одной и той же электрической схемы построенные согласно описанным техникам.

Идея мультидоменного физического моделирования

Существуют фундаментальные физические постулаты. Первый постулат гласит, что материя не может появиться ни откуда и не может исчезнуть в никуда. Второй постулат утверждает то же самое в отношении энергетического потенциала. Эти постулаты имеют частные формулировки для каждого энергетического домена. Например, для электрического домена это первый и второй законы Кирхгофа.

Каждый из энергетических доменов характеризуется двумя физическими величинами первого и второго рода (их произведение всегда есть мощность). В случае электрического домена – это электрические ток и напряжение соответственно. Эти парные физические величины, в каждом энергетическом домене, связаны между собой законом Ома в соответствующей формулировке.

Электрические схемы замещения - модели энергетических цепей

Демонстрируется система подобий между энергетическими доменами. Формулы для расчета мощности приведены с целью указания тех парных физических величин первого и второго рода, которые определяют вид закона Ома для соответствующего энергетического домена

Таким образом, в каждом из энергетических доменов потребителями энергии являются электрическое, магнитное, тепловое, гидравлическое, акустическое, механическое, ротационное и др. сопротивления. Во всех случаях это простые физические устройства, подразделяемые по принципу действия на три класса (R, L, C). Можно сказать, что для семи названных энергетических доменов закон Ома имеет 21 формулировку. Формулы закона Ома записываются тремя способами:

Электрические элементы

Закон Ома для электрических элементов

Три формы записи закона Ома определяют три формальных примитива, которые являются пассивными элементами ненаправленных графов, т.е. моделями потребителей энергии. В каждом из энергетических доменов для них существуют собственные условные графические обозначения, однако математическая суть соответствующих библиотечных элементов неизменна:

Гидравлические элементы
Закон Ома для гидравлических элементов

Тепловые элементы
Закон Ома для тепловых элементов

Магнитные элементы
Закон Ома для магнитных элементов

Механические элементы
Закон Ома для механических элементов

Ротационные элементы
Закон Ома для ротационных элементов

Девять формальных примитивов ненаправленных графов – потребители энергии, источники, узлы и заземлитель потенциала – позволяют разработать универсальную библиотеку элементов физических устройств любого масштаба и уровня детализации.

Резюме: Идея мультидоменного физического моделирования заключена в том, что модель любого технического устройства строится как преобразующая энергию цепь. В распоряжении пользователя предоставляется библиотека элементов физических устройств разных энергетических доменов. При этом вне зависимости от природы преобразуемой энергии, все библиотечные элементы подобны и строятся в соответствии с законом Ома и постулатами о сохранении материи и энергетического потенциала (первый и второй законы Кирхгофа).

Понятие об управляемом событиями моделировании

Инструментарий моделирующих программ

Обзор способов расчета энергетических цепей
или Постановка задачи на создание модели
Способы расчета энергетических цепей

Т.е. написать параграф, в котором будут описаны техники моделирования, предполагающие
получение результатов с разными уровнями детализации:

  1. моделирование систем с постоянными источниками,
    не учитывающее переходных и волновых процессов.
  2. моделирование систем с источниками периодических сигналов,
    не учитывающее переходных и волновых процессов.
  3. моделирование систем с источниками непериодических сигналов,
    не учитывающее переходных и волновых процессов.
  4. моделирование систем с источниками непериодических сигналов,
    учитывающее переходные процессы и не учитывающее волновые.
  5. моделирование систем с источниками непериодических сигналов,
    учитывающее переходные и волновые процессы.


Введение в технологию моделирования на основе направленных графов

Графов теория
Учение об общих топологических свойствах графов и о вытекающих из них расчетных методах. Две ветви теории: теория направленных графов и теория ненаправленных графов являются основой для технологий структурного и мультидоменного физического моделирования.
Граф направленный (сигнальный)
Диаграмма прохождения сигнала, состоящая из совокупности узлов (сумматоров) и соединяющих их ветвей. Стрелки на ветвях указывают направление передачи сигнала или воздействия от одного узла к другому. Ветви в направленном графе характеризуются передаточными функциями. Направленный граф является графической формой записи системы уравнений описывающих динамическую систему, и не может отражать ее топологию (модульную структуру).
Узел направленного графа
Сумматор координат модели динамической системы с одним выходом (поэтому узел направленного графа называют координатой). Обычно в каждом энергетическом домене в качестве координат выступают парные физические величины, чье произведение есть мощность. В пакетах математического моделирования эти парные физические величины называются координатами первого и второго рода. Выходные координаты ветвей собираются в узлы направленного графа согласно постулатам о сохранении материи и энергетического потенциала (первый и второй законы Кирхгофа1). Узлы направленного графа, ровно как и сам граф, не отражают различий в физической природе координат первого и второго рода (это непреодолимый недостаток направленных графов).
Ветвь направленного графа
Графический образ закона преобразования сигнала, который называется передаточной функцией. Если направленный граф есть истинная модель динамической системы и узлы графа отражают все ее координаты (граф не приведен), то передаточные функции ветвей есть либо закон Ома2, сформулированный для соответствующего энергетического домена и связывающий его физические величины первого и второго рода, либо другие физические законы, связывающие физические величины первого и второго рода разных энергетических доменов.
Контур
Для направленных и ненаправленных графов, это замкнутый путь, проходящий через несколько узлов и ветвей.

1) Для каждого энергетического домена разработаны альтернативные, матричные методы расчета соответствующих систем. Например, в электрическом домене к ним относятся: "Метод контурных токов", "Метод узловых потенциалов" - они тоже могут использоваться для составления графов. Вспомним цель разработки этих методов. Она состояла только в одном - в сокращении размерности системы уравнений, причем за счет отдаления математического описания от физического смысла. Компьютерное моделирование понижает ценность этих методов, поэтому для унификации подхода рекомендуется составлять графы согласно методу расчета, использующему первый и второй законы Кирхгофа.

2) И для одного энергетического домена закон Ома может иметь несколько форм записи. Например, для электрического домена формула закона Ома отлична для активного сопротивления, индуктивного и емкостного.

Принцип поточного исполнения блок-схем (моделей)

Программы математического моделирования динамических систем относятся к графическим средам разработки иерархически структурированных программ верхнего уровня, и часть из них основана на поточной модели управления. Поточная модель управления – это основополагающее понятие для таких програм, как VisSim, MBTY, Simulink, Easy5. Приведем определение:

Поточная модель управления (Data Flow)
Модель программирования, в которой инструкции, процедуры или функции выполняются только тогда, когда все входные данные (т.е. параметры и аргументы) готовы. Альтернативной моделью программирования является командное управление (Control Flow) в которой счетчик команд контролирует переход в памяти программ от одной команды к другой при их последовательном выполнении.

Рассмотрим пример:

Система уравнений модели
составленная пользователем 		Упорядоченный программой
информационный поток
a) w = log(r)
b) e = 1
c) r = e - q
d) q = sin(e) 		1) e = 1
2) q = sin(e)
3) r = e - q
4) w = log(r)

Для написания программ (создания моделей) используются графические языки, с помощью которых выполняется описание процессов преобразования данных в форме функциональных схем, блок-схем, схем физических принципиальных, мнемосхем, и прочее. Представим блок-схему для рассмотренного в примере информационного потока.

Исполнение информационного потока

Статический информационный поток, составленный с помощью элементарных библиотечных блоков программы VisSim

Анализируя рисунок, легко заметить, что в любом информационном потоке данные распространяются от источников сигнала к приемникам. Очевидно, что в одном потоке могут существовать ветви, параллельные каналы и обратные связи. Могут существовать зависимые и независимые параллельные потоки. В случае если с течением времени источники сигнала меняют свое значение, то появляется смысл в повторном расчете потока. Такой информационный поток называется динамическим, а каждый повторный расчет называется шагом симуляции. Наиболее развитые языки графического программирования (G-язык среды программирования LabVIEW) кроме формирования информационных потоков позволяют программировать их исполнение, а в случае определения независимых параллельных потоков (мультизадачности) обеспечивают требуемый вид синхронизации.

Библиотеки блоков графических языков

В графических инструментальных средах информационные потоки определяются блоками, которые могут иметь входы и выходы. В библиотеках программ может присутствовать несколько сотен блоков. Блоки можно классифицировать:

  1. Блоки - источники сигналов
  2. Блоки - преобразователи сигналов
  3. Блоки - приемники сигналов
  4. Блоки, которые одновременно являются источниками, приемниками и преобразователями сигналов, т.е. это блоки обладающие эффектом памяти (кроме "УВХ")
  5. Блоки (структуры) для программирования потока
  6. Блоки (структуры) для синхронизации потоков

Большое количество блоков может наблюдаться только в группе преобразователей сигналов. Минимально необходимым является количество 100+/-10 блоков. Это блоки элементарных математических операций:

  1. Арифметические
  2. Логические
  3. Трансцендентные
  4. Матричные
  5. Нелинейные
  6. Обладающие эффектом памяти

Практически все языки графического программирования поддерживают инкапсуляцию смыслового фрагмента информационного потока, т.е. небольшого фрагмента блок-схемы, в одном составном блоке. Этот механизм является основой при составлении иерархически структурированных программ (моделей), а так же позволяет расширить библиотеку базовых блоков блоками пользователя, которые, в последствии, можно многократно использовать (например, типовые динамические звенья).

Блоки обладающие эффектом памяти

Фундаментальными для построения моделей являются блоки обладающие эффектом памяти. В этой группе два элементарных блока:

  • 1/S – "Интегратор" (дискретный квазианалог интегратора)
  • 1/Z – "Регистр задержки"

Интеграторы используются для построения моделей, которые имеют непрерывную природу, регистры задержки составляют основу моделей с дискретной природой.

В библиотеках программ математического моделирования можно найти еще ряд блоков обладающих эффектом памяти:

  • Блок "Передаточная функция"
  • Блок "Пространство состояний"
  • Блок "Звено чистого запаздывания"
  • Блок "Устройство выборки-хранения"1

Эффект памяти необходим так же при создании некоторых нелинейных блоков, таких как компаратор с гистерезисом. Но, обычно, подобные блоки в базовую библиотеку специально не включаются.

Эффект памяти проявляется двояко. Если речь идет, об интеграторах, то, очевидно, что их выходное значение зависит не только от текущего входного значения, но и от всей истории входных значений:

y[n] = y[-1] + m=0n-1е x[m] ,

где: x[n] - входной сигнал, y[n] - выходной сигнал, n - индекс решетчатой функции.

В регистрах задержки эффект памяти проявляется в том, что выборки сигнала задерживаются (а для этого запоминаются) на одну дискрету времени, период которой определяет внешняя синхронизирующая последовательность (внешний синхросигнал). Математическая запись соответствующей операции имеет вид:

y [n] = y [n-1] .

1) Следует помнить, что УВХ является лишь преобразователем сигнала, т.е. не порождает информационный поток.

Понятие о начальных условиях модели (Initial Condition)

Рабочие файлы: [Начальные условия / Параметры & h(t)]

Начальные условия
Значения физических величин первого или второго рода (чье произведение всегда есть мощность) характеризующие динамическое состояние процесса преобразования энергии в системе в интересующий момент времени (обычно это начало функционирования). При моделировании систем начальные условия задаются в силу существования законов коммутации для реактивных по своей природе физических устройств, т.к. их энергетическое состояние не может измениться мгновенно. Начальным условием может быть либо величина потока материи (электрической, магнитной, тепловой, гидравлической, механической, акустической или ротационной) в L-сопротивлении, либо разность энергетических потенциалов (соответствующей природы) на выводах C-сопротивления.

Если рассматривать первый шаг симуляции (n=0), то из сотен библиотечных блоков только те, что обладают эффектом памяти, могут иметь на своих выходах ненулевые значения y[-1]. Эти значения как раз таки и являются начальными условиями и устанавливаются вручную для блоков 1/S и 1/Z (а так же для тех, что построены на их основе).

Реальные системы начинают функционировать при самых разных начальных условиях. Повторное включение электрической схемы, в которой конденсаторы не разрядились полностью. Самовозбуждение машины постоянного тока от остаточного магнитного потока такой-то величины. Охлаждение утюга до комнатной температуры от нагретого до такой-то температуры состояния. Самостоятельный разгон ракеты, которой начальную скорость придал несущий ее самолет. Функционирование логической схемы с элементами памяти (с триггерами) от предустановленного состояния и т.д.

Понятие о параметрах модели

Параметры модели
Физические величины, которые характеризуют модель независимо от ее текущего динамического состояния. К параметрам относятся: сопротивления1 (электрическое, магнитное, термальное, гидравлическое, механическое, акустическое, ротационное, и т.д.); отношения сопротивлений (коэффициенты передачи); меры инерционности (постоянные времени).

1) Если речь идет о сопротивлениях реактивного характера, то в качестве параметров могут выступать физические величины их определяющие (например, индуктивность катушки, емкость конденсатора, и т.д.).

Понятие о методах интегрирования

Рабочие файлы: [Интеграторы]

На компьютерах, дискретных по своей природе, реализовать интегратор, лишенный методических погрешностей невозможно. Существует группа классических подпрограмм (функций), которые реализуют операцию интегрирования. В простейшем случае математическая функция, закрепленная за всеми интеграторами модели, имеет вид: y [n] = y [n-1] + x [n], - где: x [n] - входной аргумент, y [n] - возвращаемое значение. Погрешности у этих подпрограмм в конкретных ситуациях проявляются по-разному, поэтому все программы математического моделирования в своих настройках содержат переключатель методов интегрирования. Обычно в список входят следующие методы:

  • Эйлера (с запаздыванием)
  • Трапециидальный
  • Рунге-Кутта 2-ого порядка
  • Рунге-Кутта 4-ого порядка
  • Адаптивный Рунге-Кутта 5-ого порядка
  • Адаптивный Булирша-Стоера
  • Эйлера (с упреждением)

На рисунке для справки представлены блок-схемы, передаточные функции и частотные характеристики основных дискретных квазианалогов интеграторов. Особенность блок-схем интеграторов построенных согласно методам Эйлера с упреждением и трапеций состоит в том, что их пропорциональный канал разорван с помощью неявного решателя. В противном случае их нельзя было бы использовать в блок-схемах с обратными связями.

Блок-схемы, передаточные функции и частотные характеристики дискретных квазианалогов интеграторов (метод Эйлера с упреждением, метод трапеций, метод Эйлера с запаздыванием)

Выбор шага симуляции и метода интегрирования

Рабочие файлы: [Шум сопроцессора]

Шаг симуляции
Фундаментальный параметр процесса симуляции компьютерной модели. Равен интервалу между временными значениями, для которых вычисляются все координаты модели (т.е. рассчитывается весь поток процедур и функций реализующий модель).

При компьютерном моделировании существенными следует считать четыре источника погрешности:

  • Трансцендентные функции, которые вычисляются компьютером путем аппроксимации полиномиальными или степенными рядами:
    Разложения трансцендентных функций в степенные ряды для их вычисления компьютером
  • Дискретный квазианалог интегратора (блок 1/S).
  • Итерационный решатель (тот или иной классический алгоритм, предназначенный для решения алгебраических уравнений путем подбора независимых переменных до заданной точности).
  • Математический сопроцессор компьютера, чья дискретная природа требует округлений, которые, в свою очередь, обычно проявляются в виде шума при дифференцировании меняющихся в большом диапазоне параболических сигналов n-ого порядка.

Погрешности дискретных квазианалогов интеграторов играют решающую роль в компьютерном моделировании. На рисунке показано, как дискретный квазианалог интегратора (блок 1/S) обрабатывает сигнал синусоидальной формы. Наглядно видно, что при уменьшении шага симуляции погрешность интегрирования дискретным квазианалогом интегратора снижается. Это основное правило, которому надо следовать при настройке параметров симуляции.

Демонстрация погрешности симуляции от величины шага

Очевидно, что разные методы дискретного интегрирования будут иметь разные величины погрешности. Эту погрешность лучше представить в виде декомпозиции на амплитудную и фазовую составляющие и оценивать их величины в частотном домене. Максимальное влияние проявляется от фазовой погрешности.

Простейшая модель синусоидального генератора на двух интеграторах позволяет убедиться в том, что погрешности всех классических методов интегрирования лежат в том диапазоне, который определен двумя методами Эйлера с запаздыванием и с упреждением. Таким образом при выборе шага симуляции следует уменьшать его до тех пор, пока вариация переходного процесса (от переключения упомянутых методов) не будет укладываться в заданный допуск.

Характер проявления фазовой погрешности методов интегрирования

Переходные процессы в системе вызваны ненулевыми начальными условиями. Частотная характеристика разомкнутой системы очевидна (-40 дБ/дек. & -180°). Методу Эйлера с запаздыванием соответствует расходящийся переходный процесс; методу Эйлера с упреждением – сходящийся; методу трапеций – синусоида с постоянной амплитудой

Каскадные алгебраические петли

Если исходные уравнения модели системы можно представить включенными последовательно блоками, то, очевидно, что программы математического моделирования динамических систем могут однозначно выявить порядок вычислений (составить информационный поток), проверяя готовность аргументов у преобразующих данные функций. Подобный пример был рассмотрен выше.

Однако гораздо чаще в блок-схемах наблюдаются обратные связи (ОС). На рисунке приведена структурная схема апериодического звена первого порядка. Систему уравнений, соответствующую этой блок-схеме, составить легко:

a) g = 1
b) x = g - y
c) u = 3 * x
d) y = oҐ т u dt
e) график = y

А как составить информационный поток? Для вычисления координаты x надо знать координату y; для вычисления координаты y надо знать координату u; а для вычисления координаты u надо знать координату x. Ситуация кажется тупиковой, но это не так, и только лишь потому, что в контуре (петле) присутствует блок обладающий эффектом памяти (1/S).

Обратимся к функции, которая используется для вычисления интеграла в дискретной форме согласно методу Эйлера с запаздыванием:

y[n] = y[-1] + m=0n-1е u[m] .

Текущее значение входного сигнала в формуле обозначено индексом n-1, выходное значение индексом n. Легко понять, что на текущем шаге выходное значение дискретного квазианалога интегратора ни как не определено текущим входным значением (связь между текущим входным значением и выходным значением на следующем шаге симуляции не отвергается). Повторим эту мысль в более общей формулировке. На текущем шаге симуляции состояние выходов всех блоков обладающих эффектом памяти не зависит от входного сигнала.

Вернемся к вопросу формирования информационного потока. В свете сказанного становится очевидно, что выходы блоков обладающих эффектом памяти порождают информационные потоки, а входы их замыкают (см. рис.).

Теперь петля разомкнута, и программа может однозначно сформировать два упорядоченных, зависимых информационных потока для расчета модели:

1) g = 1 | 1') y = reg[n-1] + y[-1]
2) x = g - y | 2') график = y
3) u = 3 * x |
reg[n] = reg[n-1] + u

где: reg – внутренний регистр дискретного квазианалога интегратора, хранящий текущее значение интеграла; y[-1] - начальное условие.

Если на месте интегратора будет безинерционная функция, то составить информационный поток невозможно - это и есть алгебраическая петля. Алгебраические петли появляются либо при неверном методическом подходе к решению неявных уравнений, либо при ошибочном проектировании цепей обратной связи САР (см. красную цепь на рисунке).

Реальные САР всегда обладают инерционными свойствами. Поэтому более точные математические модели САР обычно не содержат алгебраических петель.

Для решения неявных уравнений программы математического моделирования должны содержать неявные решатели, которые находят решение в процессе итерационного подбора. Наличие подобных решателей в программах – это следующая ступень в их развитии. Программы, преодолевшие этот барьер, как правило, позволяют описывать модели не только направленными, но и ненаправленными графами, т.е. в их библиотеках кроме математических блоков появляются физические элементы: резисторы, транзисторы, двигатели, и пр.

Каскодные алгебраические петли

В отличие от каскадных, каскодные алгебраические петли появляются в структурах функционирующих параллельно (см. рис.). В системах автоматического регулирования они встречаются редко, но любая попытка исследователя составить модель, со структурой, четко соответствующей физическим модулям реальной системы (речь о ненаправленных графах) приведет к появлению подобных структур.

Каскодная алгебраическая петля и способы ее разрыва

Существует несколько способов разрыва подобной петли. Разные программы математического моделирования, использующие направленные графы (VisSim, Simulink и пр.) разрывают каскодные алгебраические петли так, как показалось правильным их авторам (не предупреждая об этом пользователя). Часто точка разрыва каскодной петли, а, следовательно, и результаты симуляции меняются в зависимости от того, какие блоки подключены к выходам (происходит это по причине разной приоритетности математических операций).


Технология мультидоменного физического моделирования с применением ненаправленных графов

Введение в технологию мультидоменного физического моделирования с применением ненаправленных графов

Главной задачей, решаемой программами математического моделирования динамических систем, является симуляция движения их координат. Сегодня можно выделить два эволюционных этапа развития решателей этих программ. На первом этапе в программах появляется явный решатель. Это библиотека классических подпрограмм (функций), которые реализуют операцию интегрирования. Таким образом, используя дискретные квази-аналоги интеграторов, пользователь может решать дифференциальные уравнения. Лишь на втором этапе в моделирующих программах появляется неявный решатель. Это библиотека классических подпрограмм, которые предназначены для итерационного поиска корней алгебраических уравнений.

Если моделирующая программа может грамотно использовать неявный решатель, то из программы для моделирования систем автоматического регулирования она может перейти в разряд программ для мультидоменного моделирования физических систем, с применением схем физических принципиальных (например, электрических).

Основу представляемой технологии моделирования составляют модели девяти примитивов, которые используются при составлении схем замещений. Упомянутым примитивам (моделям) присвоены условные графические обозначения, заимствованные из схем электрических принципиальных, но суть моделей распространяется на любой из семи энергетических доменов: электрический, магнитный, тепловой, гидравлический, акустический, механический и ротационный.

Принципы построения графа схемы физической принципиальной

Принцип 1 (для шин)

Все элементы и узлы ненаправленного графа соединяются шинами, в которых есть два проводника распространяющие сигналы в противоположных направлениях. (Упомянутые сигналы – это физические величины первого и второго рода конкретного энергетического домена, для которых формулируются постулаты о сохранении материи и энергетического потенциала).

Принцип 2 (для элементов)

Все элементы графа должны быть двухвыводными. (Схема замещения любого устройства с большим количеством выводов должна состоять из фундаментальных двухвыводных элементов и узлов). Оба вывода у элементов должны быть оборудованы разъемами для подключения двухпроводных шин.

Принцип 3 (для узлов)

Узлы бывают двух типов: распределяющие и аккумулирующие. Узлы ненаправленного графа трехвыводные. (Узлы, в которых сходится большее количество ветвей, строятся каскадированием трехвыводных узлов). Каждый вывод узла должен иметь разъем для подключения двухпроводных шин.

Принцип 4 (для разъемов)

Элементы графа и его шины оборудуются разъемами "мама" и "папа". Половина узлов ненаправленного графа оборудуется одним разъемом "папа" и двумя разъемами "мама". Вторая половина узлов оборудуется одним разъемом "мама" и двумя разъемами "папа". (Графический интерфейс моделирующих программ не должен отображать этой особенности ненаправленного графа. Программы самостоятельно выбирают тип узлов, "скрыто переворачивают" элементы графа и шины для правильной коммутации).

Элементы ненаправленного графа

Графические образы девяти простейших библиотечных элементов ненаправленных графов, а так же поясняющая технику подключений схема приведены на рисунке. При сборке схемы выводы разных цветов ни когда не соединяются между собой. Та же схема подключений помогает понять, почему направленные графы программ VisSim, Simulink, MVTY (при использовании описываемой методики моделирования) называют ненаправленным или бинаправленным.

Графические образы простейших библиотечных элементов ненаправленных графов

Пассивные элементы ненаправленного графа (потребители энергии)

В каждом из энергетических доменов существует от одного до трех (известных) простейших физических устройств, которые называются электрическим, магнитным, тепловым, гидравлическим, акустическим, механическим, ротационным и др. сопротивлениями. Таким образом, чуть округлив, можно сказать, что для названных энергетических доменов закон Ома имеет 21 формулировку. Формулы закона Ома записываются тремя способами:

Формы записи закона Ома

Три формы записи закона Ома определяют три формальных примитива, которые являются пассивными элементами ненаправленного графа, т.е. моделями потребителей энергии.

Определимся так же с тем, что все элементы ненаправленного графа будут асимметричными, т.е. с тем, что именно поток материи по элементам будет определять разность энергетических потенциалов на их выводах, а не наоборот.

Безинерционный элемент (активное сопротивление)

Иконка безинерционного потребителя энергии, а так же его внутренняя структурная схема показаны на рисунке. От верхнего разъема к нижнему (зеленые контакты) по элементу протекает поток материи i. Потенциал j2 на красном контакте нижнего разъема элемента известен (определяется другими элементами цепи). Потенциал j1 красного контакта верхнего разъема вычисляется с помощью закона Ома, поскольку величина потока i и сопротивление R для элемента известны: j1 = j2 + i R.

Структурная схема модели безинерционного элемента (активного сопротивления)

Реактивный элемент 1

Внутренняя структурная схема реактивных элементов принципиально не отличается от структурной схемы безинерционного потребителя энергии. Различие состоит лишь в способе расчета создаваемого потоком падения напряжения. В частности, реактивный элемент индуктивного характера должен обеспечивать в заданном масштабе (L) тем большую разность потенциалов, чем больше скорость изменения протекающего по нему потока (di/dt). Это падение напряжения вычисляется с помощью блоков unknown (неизвестная) и constraint (баланс_в_нуле) следующим образом (см. блок-схему). На каждом шаге симуляции неявный решатель моделирующей программы с помощью итерационного процесса подбирает такое выходное значение блока unknown, чтобы на входе блока constraint было нулевое значение. Однако интегратор – это блок обладающий эффектом памяти – он разрывает сигнальную цепь – сигнал на его входе на данном шаге симуляции ни как не определяет выходное значение (сигнал на входе интегратора определяет его выходное значение лишь на следующем, в данный момент еще не вычисляемом шаге симуляции). Баланс на входе блока constraint подбирается через цепь верхнего разъема, и ту схему, к которой элемент подключен. Т.е. фактически подбирается не выходное значение интегратора, а поток, протекающий по элементу. Если баланс будет вычислен, то значение сигнала на входе интегратора будет равно производной потока, а на входе делителя – искомому напряжению.

Структурная схема модели реактивного элемента первого типа (индуктивного сопротивления)

Приведенное описание принципа работы блок-схемы позволяет легко понять, что установка начального условия на интеграторе (Initial Condition), эквивалентна определению величины начального потока материи по элементу.

Реактивный элемент 2

Реактивный элемент емкостного характера должен обеспечивать в заданном масштабе (1/С) разность потенциалов пропорциональную интегралу протекающего по нему потока i, что и обеспечивается блок-схемой показанной на рисунке.

Структурная схема модели реактивного элемента второго типа (емкостного сопротивления)

Установка начального условия на интеграторе данной блок-схемы эквивалентна определению величины начального падения напряжения на элементе.

Активные элементы ненаправленного графа (источники энергии)

Источники энергий определяют само существование энергетических доменов. В разных энергетических доменах нам известно разное количество источников. Функционирование известных нам источников может быть описано одной из двух идеализированных моделей. Первая модель имеет название "Источник движущей силы", поскольку в рабочем режиме создает разность энергетических потенциалов неизменной величины. Вторая модель – "Источник потока" – отличается тем, что генерирует постоянный по величине поток материи (рабочего тела).

Источник движущей силы (генератор энергетических потенциалов)

Иконка источника движущей силы и его внутренняя структурная схема показаны на рисунке. Логику работы модели обеспечивает неявный решатель с помощью пары блоков unknown (неизвестная) и constraint (баланс_в_нуле) (оба блока, см. блок-схему, имеют малиновые рамки). На каждом шаге симуляции неявный решатель моделирующей программы с помощью итерационного процесса подбирает такое выходное значение блока unknown, чтобы на входе блока constraint было нулевое значение. Другими словами неявный решатель подбирает такое значение потока материи, который бы создал в подключенной к источнику цепи заданную разность потенциалов (в данной модели в качестве опорного генератора используется блок синусоидального сигнала).

Структурная схема модели генератора энергетических потенциалов (источкика движущей силы)

Второй блок unknown в модели (с красной рамкой) предназначен для обеспечения возможности изменения потенциалов источника в синфазном режиме. Парный этому блоку блок constraint расположен в модели физического элемента "заземлитель потенциала". Оставшийся в модели блок constraint обеспечивает нулевой баланс при возврате потока в источник (иначе, если в схеме несколько источников, то возможна ситуация, когда в данный источник вернется поток другой величины).

Источник потока (генератор потока материи)

Структурная схема источника потока материи изображена на рисунке. Величина и форма потока в данной модели задается опорным генератором – блоком синусоидального сигнала. Блок constraint заставляет неявный решатель, на каждом шаге симуляции, искать такой баланс энергетической цепи, при котором в данный источник вернется поток материи в полном объеме.

Структурная схема модели генератора потока материи (источкика потока)

Блок unknown (в блок-схеме имеет красную рамку), так же как в модели источника движущей силы, предназначен для обеспечения возможности изменения потенциалов источника в синфазном режиме. Парный этому блоку блок constraint расположен в модели физического элемента "заземлитель потенциала".

Прерыватель алгебраических петель (инициатор потока материи)

Модель прерывателя алгебраических петель – есть модель источника движущей силы нулевой величины (сравни структурные схемы). Включение идеального источника движущей силы нулевой величины в разрыв любой ветви энергетической цепи, не может изменить режим ее работы (это обусловлено нулевым внутренним сопротивлением такого источника).

Структурная схема модели прерывателья алгебраических петель

Существуют модели фрагментов энергетических цепей без источников энергии, движение материи в которых вызвано ненулевыми начальными условиями на реактивных элементах. Например, модель процесса разряда конденсатора на активное сопротивление. Если проанализировать блок-схемы потребителей энергетических цепей, то становится очевидным факт возможного появления алгебраических петель, а так же простых кольцевых замыканий линий связи (смотри проводники с зелеными контактами, передающие величину потока). Как было показано ранее, включение прерывателя алгебраических петель в RC-цепь не меняет режим ее работы, но инициирует в ней поток материи и разрывает алгебраические петли, – в этом и заключено его назначение.

Таким образом, прерыватель алгебраических петель – это служебный элемент моделирующей программы, который используется последней, для показанных нужд, автоматически (по мере необходимости). Он не входит в базовые библиотеки элементов и его присутствие в ненаправленном графе (в схеме физической принципиальной) ни как не отражается.

Заземлитель потенциала

Модель заземлителя потенциала состоит из одного блока constraint. Данный датчик неявного решателя будет уравновешиваться теми блоками unknown (с красной рамкой), что будут обнаружены в источниках той энергетической цепи, которую составит пользователь моделирующей программы. При этом заземлитель может быть подключен к любому ее потенциальному контакту.

Структурная схема модели заземлителя потенциала

Не следует путать заземлитель энергетического потенциала с условным графическим обозначением заземления на схемах электрических принципиальных. Заземлитель потенциала – это не проводник. Он может быть установлен в модели только один раз. В программах с развитым графическим интерфейсом за подключение этого блока отвечает сама моделирующая программа.

Узлы ненаправленного графа

Распределяющий (материю) узел

Основу распределяющего узла составляет обслуживаемый неявным решателем трехвыводной сумматор, математическое уравнение которого соответствует постулату о сохранении материи (например, это может быть I закон Кирхгофа). Соблюдение этого постулата обеспечивает датчик неявного решателя (блок constraint) на выходе сумматора. Перераспределение же потоков материи I2 и I3 контролирует второй датчик неявного решателя, фиксирующий разность потенциалов j2 и j3. Если (j2-j3) > 0, то баланс в цепи может быть найден при уменьшении потока I2 и увеличении I3. Если (j2-j3) < 0, то неявному решателю потребуется увеличить поток I2 и уменьшить I3. (Изменения потоков материи приводят к тому, что элементы ненаправленного графа меняют значения соответствующих потенциалов). Таким образом, принцип работы узла состоит в том, чтобы распределить поток материи I1 на потоки I2 и I3 так, чтобы соблюдалось равенство потенциалов j2 и j3 (после нахождения баланса цепи потенциал j1 будет равен потенциалам j2 и j3).

Структурная схема распределяющего (материю) узла

Аккумулирующий (материю) узел

Структурная схема аккумулирующего узла существенно проще (см. рис.) и особых комментариев не требует.

Структурная схема аккумулирующего (материю) узла

Рекомендации к использованию библиотеки элементов

Рабочие файлы: [Элементы] [RLC схема] [Схема электрическая] [Ее граф в VisSim'е]

Описанные модели элементов ненаправленного графа являются идеализированными, т.е. имеют стремящиеся к нулю внутренние сопротивления, обладают высокой добротностью, или совершенно не имеют инерционных свойств, как то и требуется для схем замещений. Отсюда следует, что неправильно составленный ненаправленный граф может привести к перегрузке мантиссы решателей. Приведем примеры для электрического энергетического домена:

  • Замыкание заряженного конденсатора или источника электродвижущей силы на нулевое сопротивление или конденсатор с другим падением напряжения.
  • Размыкание индуктивной катушки с электрическим током без подключения шунтирующего резистора.

Другой причиной проблем с решателями могут послужить элементы, установленные на рабочее поле, но не подключенные к графу. Далеко не у всех моделирующих программ неявные решатели умеют находить и исключать из расчетов те датчики нулевого баланса и блоки неизвестная, которые не связаны функциональной зависимостью (т.е. не подключены). По той же причине не следует создавать не связанные, хотя бы потенциально, энергетические цепи, поскольку в этом случае, так же образуются независимые области итерационного подбора.

Не следует так же забывать, что итерационный поиск баланса для десятков, а то и сотен координат (переменных) энергетических цепей выполняется на каждом шаге симуляции. Очевидно, что итерационный процесс будет тем короче, чем меньше приращения значений координат. Отсюда следует рекомендация отказываться, в критических случаях, от задающих генераторов, чьи выходные последовательности имеют разрывы: меандр, пила, и т.д. (Пропустите сигналы соответствующих источников опорного напряжения, через апериодические звенья первого порядка с малой постоянной времени).

Об альтернативном построении графа схемы физической принципиальной

Рабочие файлы: [Альтернативные элементы] [codirected_bond_graphs.vsm]

Большинство программ для математического моделирования динамических систем (VisSim, Simulink, MBTY) в своем графическом интерфейсе предоставляют возможность собрать проводники в шину. Но направления проводников в шинах должны совпадать. Это вызывает затруднения при использовании предложенной библиотеки элементов. Однако, следуя этому ограничению, можно составить альтернативную библиотеку, элементы которой можно будет соединять подобными шинами. Принципиальных отличий в построении альтернативной библиотеки нет, и требуемые модификации не существенны. В моделях пассивных элементов ненаправленного графа меняется знак на сумматоре при вычислении приращения потенциала, а та часть блок-схемы распределяющего узла, которая отвечает за баланс потенциалов, перемещается в аккумулирующий узел.


Обзор методов анализа моделей, систем и сигналов

В большинстве программ математического моделирования динамических систем совокупность методов анализа моделей, систем и сигналов вынесена в отдельную библиотеку и часто является дополнительным коммерческим продуктом. Их практическая ценность высока. К основным задачам, решаемым библиотекой анализа, относятся:

  • Идентификация моделей;
  • Символьный анализ математического описания;
  • Частотный анализ моделей и систем;
  • Спектральный анализ сигналов.

Идентификация моделей

Рабочие файлы: [ABCD.vsm]

Идентификация компьютерных моделей
Та или иная алгоритмическая процедура, в результате выполнения которой моделирующая программа получает численные значения коэффициентов модели, структура которой и параметры были выбраны пользователем произвольно. Искомые коэффициенты могут быть представлены либо в форме ABCD-матриц, либо в форме коэффициентов полиномов числителя и знаменателя передаточной функции. Цель поиска коэффициентов состоит в предоставлении исходных данных для частотного, корневого и других видов анализа.

Аналитическая процедура приведения направленного графа сложна для программной реализации. По этой причине библиотеки анализа программ математического моделирования не отслеживают ни схему соединений блоков, определяемую пользователем, ни их параметры. Т.е. подобная информация для идентификации модели им не нужна (см. рис. 1).

Модель системы, чью структуру и параметры нужно идентифицировать, поскольку они выбираются пользователем, и каждый раз могут быть разными

Рис. 1

Но, какова бы ни была структура модели линейной системы, она может быть описана в матричной форме именуемой "пространством состояний":

u' = A u + B x
y = C u + D x

Данная система уравнений для SISO-систем (модели с одним входом и выходом) имеет следующую масштабируемую топологию:

Легко увидеть, что в целях унификации вычислительных алгоритмов моделирующих программ можно объединить матрицы A, B, C и D, а так же матрицу U с координатой x, и матрицу U' с координатой y, как показано на рис. 2.

Унифицированная матричная блок-схема, являющаяся универсальной формой отображения любых линейных моделей пользователя с произвольными соединениями блоков

Рис. 2

Таким образом можно утверждать, что любую линейную модель можно преобразовать к универсальной блок-схеме изображенной на рис. 2. При этом в результате преобразования граф распространения сигнала в модели не претерпит изменений. Т.е. матричная блок-схема является универсальной формой отображения любых соединений блоков линейной модели, а не просто её эквивалентом.

Идея идентификации коэффициентов модели

Рис. 3

Теперь, возвращаясь к процедуре идентификации, можно описать сценарий работы библиотеки анализа, конечной целью которого является идентификация коэффициентов модели:

  1. Моделирующая программа для всех интеграторов модели (см. рис. 1) отключает вызов функции численного интегрирования, и, к освободившимся входам и выходам блоков 1/S, подключает библиотеку анализа. Дополнительными точками подключения библиотеки являются входная и выходная координаты модели. Библиотека анализа использует выходы блоков интеграторов для задания возмущений на граф модели, а их входы для фиксации отклика графа.
  2. В момент подключения (инициализации) библиотека анализа создает будущий (искомый) "образ модели" в виде обнуленной ABCD-матрицы.
  3. Далее, моделирующая программа инициирует процесс спец-симуляции модели длинной в n+1 шаг (на данном этапе функционирования, программы не используют графический интерфейс, т.е. скрывают свои действия от пользователя).
  4. На каждом шаге спец-симуляции, библиотека анализа поочередно устанавливает на выходе одного из интеграторов модели единицу (другие возмущения обнуляются), и фиксирует реакцию графа.
  5. Используя полученную совокупность отдельных реакций графа, библиотека анализа заполняет столбцы объединенной ABCD-матрицы в искомом "образе модели". Суть этой операции поясняет рис. 3.

Описанный сценарий легко поддается алгоритмизации и реализован в большинстве программ математического моделирования с поточной моделью управления. Следует отметить, что он может быть использован для идентификации мультичастотных дискретных, гибридных, а так же непрерывных систем со звеньями чистого запаздывания. В этом случае список блоков, к которым должна подключаться библиотека анализа расширяется регистрами задержки 1/Z и звеньями чистого запаздывания e -ts. Но, составляя вектор задания, библиотека анализа должна хранить информацию о том, каким устройством формируется та или иная координата модели и его параметры (Tц для 1/Z и t для e -ts), что требуется для процедуры расчета частотных характеристик.

Символьный анализ математического описания моделей

Символьные преобразования математического описания моделей
Те или иные алгоритмические процедуры, в результате исполнения которых моделирующая программа трансформирует математическое описание модели к желаемому виду (вплоть до изменения её структуры). В список основных символьных преобразований (чье наличие обязательно для библиотек анализа моделирующих программам) входят: билинейное преобразование, поиск корней алгебраических полиномов и разложение в степенной ряд (получение коэффициентов ошибок).

Билинейное преобразование

Рабочие файлы: [Аппроксиматоры]

Билинейное преобразование
Бинаправленная процедура пересчета коэффициентов линейной модели, используемая с целью нахождения соответствующего (дискретного или непрерывного) аналога, т.е. для трансформации моделей из s-домена в z-домен и обратно.

В действительности, при выполнении процедуры билинейного преобразования моделирующие программы никакого "символьного анализа" не выполняют (название отражает лишь суть результата). Для пересчета коэффициентов модели используются чуть модифицированная, а, по сути, та же процедура идентификации коэффициентов, которая была описана выше.

Если требуется перейти от непрерывного прототипа к дискретной модели, то процедура идентификации (в данном случае "перерассчитываемых") коэффициентов будет отличаться лишь тем, что библиотека анализа подключится не к выводам интеграторов модели, а к регистрам задержки, на которых эти (квазианалоговые) интеграторы реализованы. Следует уточнить, что в этой процедуре имеет смысл использовать лишь квазианалоговый интегратор первого порядка (на одном регистре), реализующий метод трапеций, поэтому библиотеки автоматически активируют этот метод интегрирования в настройках программ.

Если же требуется обратная трансформация модели, то процедура идентификации "перерассчитываемых" коэффициентов так же чуть модифицируется. Библиотека анализа замещает все регистры задержки модели их непрерывными аналогами – фазосдвигающими звеньями и подключается к интеграторам, на которых эти аппроксиматоры реализованы.

Идея билинейного преобразования коэффициентов модели (s-ABCD <-> z-ABCD)

Приведенное выше и проиллюстрированное рисунком смысловое описание процедуры трансформации моделей имеет следующее математическое обоснование. Известно разложение в ряд Тейлора экспоненциальной функции (передаточной функции регистра задержки), которое связывает дискретный домен с непрерывным. Одно из возможных усечений этого ряда до двух членов известно как "билинейное преобразование":

Формула обратного билинейного преобразования или Формула прямого билинейного преобразования .

Если каждую из формул чуть преобразовать и вспомнить известную формулу, связывающую передаточные функции замкнутой и разомкнутой системы, то легко можно составить структурные схемы, используемые библиотекой в процедуре трансформации моделей (см. рис.), а так же увидеть в них передаточные функции: регистра задержки, фазосдвигающего звена; интегратора, и квазианалогового интегратора реализующего метод трапеций:

Формулы билинейного преобразования в форме, отражающей их физический смысл .

Разложение математического описания модели САР в степенной ряд

Рабочие файлы: [ABCD ® с1с2с3]

Разложение математического описания модели в степенной ряд
Процедура разложения в степенной ряд системы дифференциальных уравнений САР решенной относительно требуемой координаты. Таким образом результат процедуры – первые коэффициенты разложения (коэффициенты ошибок, или коэффициенты отклика) – получается в результате трансформации либо ABCD-матрицы коэффициентов, либо коэффициентов числителя и знаменателя ПФ.

Известно, что например коэффициенты ошибок связывают коэффициенты разложения входного сигнала g(t) в ряд Тейлора с соответствующими составляющими ошибки x(t) в установившемся режиме движения:

x(t) = c0 g(t) + c1 g'(t) / 1! + c2 g''(t) / 2! + c3 g'''(t) / 3! + ...

Этот факт положен в основу техники разложения математического описания модели в степенной ряд. Идея заключена в том, что библиотека анализа моделирующей программы, за один процедурный шаг, балансирует модель в одном из возможных состояний установившихся режимов движения (неподвижное ненулевое состояние, движение с постоянной скоростью, и т.д.). Далее, измерив значения двух координат (относительно которых требуется выполнить разложение), вычисляет их отношение, находя тем самым соответствующий коэффициент искомого ряда.

В общем виде математическое обоснование техники разложения математического описания модели САР в степенной ряд объемно и опирается на аппарат матричных исчислений (лишь матричное описание позволяет учесть любые возможные взаимосвязи между координатами модели). Поэтому опишем лишь алгоритм, согласно которому функционируют соответствующая процедура библиотеки анализа моделирующих программ:

Блок-схема - подстановка, используемая для вычисления коэффициентов ошибок модели системы с произвольной топологией

  1. Пользователь указывает две координаты линейной непрерывной модели: вход и выход, – относительно которых требуется выполнить разложение и активирует соответствующую процедуру анализа.
  2. Библиотека анализа замещает все интеграторы модели специальной блок-схемой, изображенной на рисунке справа. К указанному пользователем входу библиотека подключает генератор импульса единичной амплитуды, и подготавливается к измерениям выходной координаты (начиная с этого шага алгоритма допустимо, чтобы программы не использовали графический интерфейс, т.е. скрывали технические подробности от пользователя).
  3. Далее, библиотека анализа инициирует процесс спец-симуляции модели. На каждом шаге выполняется измерение одного коэффициента разложения (в силу особенностей задающего сигнала значение выходной координаты равно коэффициенту разложения).

Достоинство описанного алгоритма заключается в том, что после упомянутой подстановки, величина шага симуляции моделирующей программы не имеет влияния на результат разложения. Однако процедура балансировки модели требует решения системы линейных алгебраических уравнений, порядок которой равен порядку исследуемой САР.

Если исходной информацией к разложению будут являться не ABCD-матрицы коэффициентов, а коэффициенты числителя и знаменателя ПФ разомкнутой САР, то балансировка модели в установившихся режимах движения может быть упрощена, поскольку итерационному решателю моделирующей программы достаточно прорешивать алгебраическое уравнение лишь первого порядка. Требуемые в этом случае трансформации исходной модели и результат разложения показаны на рисунке.

Техника разложения ПФ САР по ошибке в степенной ряд (т.е. вычисление коэффициентов ошибок по известным коэффициентам числителя и знаменателя ПФ разомкнутой системы)

Частотный анализ моделей и систем

Частотный анализ модели или системы
Процесс идентификации частотной характеристики модели или системы сопровождаемый уточнением соответствующей частотной передаточной функции. Цель частотного анализа состоит в предоставлении исходных данных для решения задач оценки качества, коррекции, синтеза САР.

Процедуры частотного анализа, реализованные в программах математического моделирования динамических систем, могут быть основаны на базе:

  • вычислительных алгоритмов;
  • измерительных алгоритмов;
  • алгоритмов распознавания образов.

Вычислительные алгоритмы идентификации частотных характеристик моделей

Рабочие файлы: [fr_ABCD.mcd] [fr_ABCD_sz.mcd]

Главная особенность вычислительных алгоритмов идентификации ЧХ состоит в том, что они ни коим образом не анализируют входной и выходной сигналы, а поэтому могут применяться только к математическим моделям. Исходной информацией для расчета ЧХ являются коэффициенты модели, поэтому предварительная процедура её идентификации является обязательной.

Если программе известны коэффициенты числителя и знаменателя ПФ модели, то алгоритмизация процедуры расчета ЧХ не вызывает затруднений. Гораздо чаще программы математического моделирования располагают результатом идентификации в матричной ABCD-форме. Выведем формулу расчета ЧХ для данного случая:

ЧХ дискретной системы так же можно рассчитать с помощью представленной формулы, но нужно выполнить постановку: j w ¬ е j w T. В случае если требуется построить частотную характеристику для домена псевдочастоты l (что может потребоваться при использовании устаревших методик), требуемая подстановка имеет вид: j w ¬ (2+ j l T)/(2- j l T).

Если же система является мультичастотной дискретной, гибридной, или же непрерывной, но со звеньями чистого запаздывания, то требуется корректное заполнение диагональной матрицы соответствующими частотными операторами. На сегодняшний день достоверность результатов в этом случае требует подтверждения методами основанными, на анализе входных и выходных сигналов.

Во избежание необоснованных обвинений моделирующих программ, каждый специалист должен знать, что рассчитанная на основе известных коэффициентов ЧХ ни как не учитывает тех погрешностей, которые не может не вносить ЦВМ, согласно своей природе, в процесс симуляции моделей (см. рис.). Например, для перехода в частотную область используется подстановка идеального частотного оператора s ¬ j w (без вещественной составляющей), который не учитывает погрешностей дискретных квазианалогов интеграторов моделирующих программ (что, впрочем, методически верно).

Характер проявления фазовой погрешности методов интегрирования

На рисунке показаны переходные процессы системы, вызванные ненулевыми начальными условиями. Частотная характеристика разомкнутой системы очевидна (-40 дБ/дек. & -180°), и вычислительные алгоритмы частотного анализа ее подтверждают. Но симуляция движения координат модели выявляет несоответствия между временным и частотным доменами при переключении методов интегрирования (методу Эйлера с запаздыванием соответствует расходящийся переходный процесс; методу Эйлера с упреждением – сходящийся; методу трапеций – синусоида с постоянной амплитудой)

Измерительные алгоритмы идентификации частотных характеристик моделей и систем

Процедуры идентификации ЧХ, основанные исключительно на спектральном или гармоническом анализе результатов измерений входного и выходного сигналов, имеют особую ценность в программах математического моделирования. Они обеспечивают наиболее эффективные и адекватные переходы от абстрактных математических моделей к проектируемым физическим прототипам и обратно, а так же являются одним из не многих инструментов оценки адекватности функционирования самих моделирующих программ в режиме симуляции.

Универсальных алгоритмов измерений ЧХ нет. Существуют три вида ограничений, которые порождают семейства методов измерений ЧХ, которые в той или иной степени могут быть оптимальными для исследования трех классов идентифицируемых линейных объектов (см. рис.). К упомянутым ограничениям относятся:

  1. Невозможность использования дельта-воздействий для объектов с эффектами насыщения.
  2. Затруднения в расширении диапазона частот свыше "трехдекадного барьера".
  3. Большие временные затраты на расширение динамического диапазона ниже уровня шума.

Если на вход системы подать весь спектр частот с единичными амплитудами, то определение частотной ПФ на основе измерительной информации упрощается:

W( j w) = Y( j w)/X( j w) | X( j w)=1 = Y( j w) .

Подобный единичный спектр имеет дельта-функция Дирака d(t). Реакция же систем на дельта-функцию называется функцией веса w(t), поэтому частотную ПФ можно получить вычислением её Фурье-изображения:

W( j w) = FT { w(t) } ,

или же, для дискретных сигналов:

W [ jk w] = DFT { w[n] } = n=0N-1 е w[n] е -jk w nT .

где: w – частота первой гармоники в спектре сигнала длинной в NT выборок; k – порядковый номер гармоники (независимая переменная); N – число выборок функции веса w[n] (обычно кратно степени двойки); k Ј N/2.

Подобный подход используется в простейших алгоритмах идентификации ЧХ и достаточно легко реализуется в любых математических программах:

Схема измерения частотных характеристик посредствам обработки импулсьной характеристики модели системы алгоритмом быстрого преобразования Фурье

Измерения частотных характеристик выполнены для двух дискретных фильтров с конечной импульсной характеристикой (FIR). Операция быстрого преобразования Фурье (нижний график) выполнена библиотечным блоком осциллограф программы VisSim (в свойствах блока осциллограф активирован режим вычисления БПФ для осциллограммы)

Демонстрация затруднения, возникающего при измерении частотных характеристик систем, обладающих бесконечной импульсной характеристикой. Логарифмический масштаб частотной оси и кратная двойке сетка выходного массива БПФ ограничивают разрешение по частоте в низкочастотном диапазоне

Измерения частотных характеристик выполнены для модели колебательного звена и инверсного фильтра Чебышева десятого порядка, т.е. для двух непрерывных систем с бесконечной импульсной характеристикой (IIR)

Сравнивая приведенные на рисунках ЧХ КИХ и БИХ-фильтров, легко понять суть "трехдекадного барьера" (присущего алгоритмам на базе БПФ), который проявляется при частотном анализе БИХ-фильтров, чьи ЧХ представляются в логарифмическом масштабе по оси частот. Очевидно, что, в этом случае, кратная двойке сетка анализируемых гармоник в выходном массиве процедуры БПФ ограничивает разрешение по частоте в НЧ диапазоне. Увеличение частотного диапазона на декаду требует увеличения времени симуляции в десять раз.

При измерении ЧХ реальных систем использование дельта-функции невозможно. Её замещают либо суперпозицией синусоид, либо белым шумом, либо другим сигналом конечной амплитуды. Основным методом расширения динамического диапазона ниже уровня шума является усреднение результатов повторных измерений. В случае использования алгоритмов измерения ЧХ на базе ДПФ для ослабления эффекта наложения частот используют методику взвешивания массива измерительной информации окнами Бартлета, Хэмминга, с хэннингом, Блэкмана, Хариса и т.д.

Алгоритмы идентификации частотных характеристик систем на основе технологий распознавания образов

Идея алгоритмов идентификации ЧХ систем на основе технологий распознавания образов заключена в уточнении априорных предположений о порядке системы и порядке её астатизма. Согласно сценарию, алгоритм создает образ идентифицируемой системы (модель), и, в итерационном процессе, так подгоняет положение асимптот его частотной характеристики, дабы реакции идентифицируемой системы и образа на произвольные сигналы совпадали.

Простейшие алгоритмы данной группы обеспечивают погрешности идентификации не превышающие трети декады и 6 дБ, что вполне приемлемо при проектировании систем управления. В целях снижения погрешностей для идентификации выбирают фрагменты осциллограмм сигналов с наиболее широким спектром (переходные режимы функционирования).

Безусловно, группа измерительных алгоритмов в любых случаях более предпочтительна. Но в условиях, когда возможность вывода системы из производственного процесса для исследований отсутствует, или же невозможно подать на систему требуемые измерительные воздействия выбора нет – нужно использовать те сигналы, которые есть.


Архитектура моделирующих программ

Обзор архитектурного построения программ математического моделирования динамических систем

Введение

Известно много хороших математических программ. Отнесем каждую к одной из двух групп:

  1. Мощные калькуляторы для статических вычислений (Matcad, Mathematica, Maple).
  2. Специализированные решатели для моделирования динамических процессов (DyMoLa, Dynast, Multisim, VisSim, MBTY, MVS, Simulink).

При использовании программ и той, и другой группы пользователю нужно определить последовательность математических функций, которые должны быть вычислены математическими ядрами. Фундаментальное отличие проявляется в том, что при использовании программ-калькуляторов пользователь должен рассчитывать лишь на однократное вычисление запрограммированной им последовательности функций, а при использовании динамических решателей может использовать возможности повторных вычислений. Таким образом, с одной стороны, если в вашем распоряжении программа-калькулятор, то вам нужно знать громадное количество методов, позволяющих сократить количество математических операций [2] (что спасет вас от мозоля на пальце). А с другой стороны, нельзя поспорить с тем, что при использовании динамических решателей для решений задач "в лоб" (т.е. в четком соответствии с их физической природой, без использования накрученных на физическую природу математических абстракций второго, третьего порядка или жестко формализованных (матричных) подходов), придется серьезно загрузить "бедный" процессор компьютера несколькими миллиардами математических операций аж на две или даже десять секунд.

Но оставим иронию. Компьютеры, безусловно, изобретались не для офисных приложений. Мозг же студента развивается не существенно от запоминания большого количества формализованных или жёстко алгоритмизированных методик, которые разрабатывались еще до появления компьютеров в целях уменьшения количества вычислений. Эти факты объясняют существенный интерес ведущих педагогов к программам математического моделирования динамических систем. Однако ограничения в доступности подобных программ, стремление производителей скрыть технологии их функционирования, плюс всенародная любовь к "калькуляторам" сдерживают их широкое распространение, порождают недоверие к ним, что, в конечном счете, сказывается на их качестве.

Статья раскрывает идеи и решения, составляющие основу программ математического моделирования динамических систем. Автор высказывает надежду, что статья разрушит хотя бы часть "барьеров недоверия" и будет способствовать появлению новых поклонников у "динамических решателей". Возможно, часть описанных решений будет использована разработчиками моделирующих программ, студентами-дипломниками и аспирантами.

Хотелось бы сказать несколько благодарственных слов корпорации Microsoft, которая, продавая свои готовые приложения за деньги, достаточно часто распространяет технологии, с помощью которых они были созданы на бесплатной основе.

Модульная структура программ математического моделирования динамических систем

Модульная структура моделирующих программ
Рис. 1

Сколь разными бы ни казались моделирующие программы, их модульная структура практически неизменна (см. рис. 1):

  • Графический интерфейс ориентирован на человека и отвечает за представление математической модели в виде, понятном широкому кругу специалистов. Это могут быть блок-схемы, схемы физические принципиальные, гибридные карты состояний и пр.
  • Система управления базой данных отвечает за хранение объектов составленной пользователем модели и требуемые трансформации структуры ее хранилища.
  • Математическое ядро берет на себя основную вычислительную нагрузку, и, в цикле, согласно заданной программе, руководствуясь готовностью аргументов, а в редких спорных случаях (появление которых всегда можно избежать) приоритетностью математических операций, обеспечивает исполнение потоков математических функций.
  • Серверы визуализации и Online воздействий обеспечивают интерфейс между функционирующим математическим ядром и пользователем. Серверы визуализации результатов — осциллографирующие, показывающие, и индицирующие приборы — в зависимости от ситуационных требований, могут работать либо в синхронном, либо в асинхронном режиме. Серверы же Online воздействий на модель жестко синхронизированы с математическим ядром.

К большому сожалению разработчики моделирующих программ при создании своих продуктов не придерживаются современных технологий модуляризации (COM, CORBA) и предпочитают все делать самостоятельно. Их консерватизм в этом отношении создает потенциально неустойчивую ситуацию на рынке. Все представленные на рис. 1 модули могут быть не просто автономными, а уже традиционно считаются независимыми программными продуктами. Ирония в том, что математическое ядро — это наиболее простой и легкий в создании модуль. Совершенно очевидно, что создание полноценного редактора векторной графики подобного Visio или CorelDraw или же движка реляционной базы данных — это задача не для фирмы со штатом из 3..10 человек. Именно усилия, потраченные на решение этих второстепенных задач, разорили далеко не одну компанию, а проигрывают от этого пользователи.

За последние десять лет ситуация изменилась не в пользу описанной позиции разработчиков моделирующих программ. Вспомогательные модули созданы конкурирующими между собой сторонними производителями, широко доступны, обеспечивают требуемые механизмы интеграции с другими программными комплексами и непрерывно совершенствуются профессионалами в своей области.

Рассмотрим вариант перспективного модульного состава моделирующей программы (см. рис. 2). Даже беглая оценка списочного состава модулей выдает владельца используемых программных технологий — корпорацию Microsoft. Далее мы лишь добавим парочку скриптов и COM-серверов, наиболее важным из которых является математическое ядро.

Итак, в качестве графического интерфейса из двух кандидатов был выбран пакет векторной графики Visio, который чуть более популярен у инженеров, чем у художников. Для управления текстовым хранилищем модели с XML-разметкой был выбран не большой, бесплатно распространяемый, имеющий качественную документацию, и присутствующий на каждой машине с ОС Windows движок реляционной базы данных — COM-сервер (файл msxml*.dll). Выбор последнего вспомогательного компонента — сервера визуализации (объекта MSGraph.Chart программы Excel) не оптимален, не перспективен и определен лишь фактом его широкого распространения на машинах читателей этой статьи. Безусловно, здесь более подойдет инструментарий визуализации практически любой SCADA-системы, а лучше — библиотеки "Mearsurement Studio" for Visual Basic and Visual C++ фирмы National Instruments [9].

Вариант модульной структуры моделирующей программы
Рис. 2

Архитектура математического ядра моделирующих программ с поточной моделью управления

Какими бы разными ни были моделирующие программы, вариации архитектуры их математических ядер довольно жестко ограничены возможностями компиляторов языков высокого уровня. Очевидно, что математическое ядро должно поддерживать от 100 до нескольких тысяч математических функций. Безусловно, требуется формализация интерфейса настройки и управления математического ядра, поскольку справиться с таким громадным количеством функций, используя их ручной вызов, невозможно.

Возможности современных версий языка Си++ позволяют решить поставленную задачу следующим образом. Пишется полиморфный класс CBlkTemplate с виртуальным методом Calc (см. табл. 1). Его наследуют классы, составляющие библиотеку математических функций. В частности, каждый потомок реализует метод Calc в виде уникальной математической функции. Уточним возможности, которые предоставляет подобная организация библиотеки.

Во первых, от каждого математического класса можно породить любое количество объектов. Это означает, что для обработки повторно встречающихся в модели математических функций будут использованы уникальные экземпляры объектов, каждый из которых будет иметь собственную область памяти для хранения возвращаемых значений Output[k]. В результате не будет наблюдаться "затирание" координат модели.

Во вторых, в силу действующих стандартов для компиляторов языка Си++, объекты порожденные от разных потомков полиморфного класса (CBlkTemplate) будут иметь реализации виртуальной таблицы функций (vtbl) одной размерности. Это означает, что их можно присвоить элементам одного массива MathBlock[i] (см. рис. 3). Что, в свою очередь, открывает возможности для создания автоматизированных процедур обслуживания объектов математического ядра. Так например, процедура исполнения шага симуляции модели в таких программах, как VisSim, Simulink, MBTY может иметь следующий вид:

Листинг 1

    for (i=0; i < numBlock; i++) {
        MathBlock[i]->Calc();
    }

Подобных процедур не много, и, в случае реализации математического ядра в виде COM-сервера, они образуют его интерфейсы (см. табл. 2).

Уделим внимание деталям реализации математического ядра. В табл. 1 приведён список важнейших атрибутов полиморфного класса, которые наследуются всеми его потомками. К ним относятся: массив указателей на аргументы pInput[j], массив возвращаемых функцией результатов Output[k] и массив параметров функции Param[n]. Размерность массивов задается значениями параметров конструкторов потомков, которые, в свою очередь, передаются им через интерфейс createBlock COM-сервера (см. табл. 2).

Таблица 1
Атрибуты полиморфного класса - общего
предка всех математических классов
CBlkTemplate.pInput[j]
CBlkTemplate.Output[k]
CBlkTemplate.Param[n]
CBlkTemplate.Calc() = 0; // virtual
CBlkTemplate. ...

В графическом представлении, экземпляры математических объектов — это блоки на блок-схеме (см. нижний фрагмент рис. 3). Наличие у каждого математического объекта массива указателей на аргументы pInput[j] делает возможным (в графическом представлении) их соединение линиями связи в требуемом порядке. Эта операция осуществляется через интерфейс createWire COM-сервера (см. табл. 2). Её результатом является присвоение значения указателя на элемент массива Output[k] одного объекта элементу массива pInput[j] другого объекта (см. цепочку повторяющихся фрагментов на рис. 3). Таким образом, совокупность показанных программных решений делает возможным создание моделей систем из любого требуемого набора математических функций, между которыми возможна любая требуемая схема передачи аргументов.

Идея архитектурного построения математического ядра моделирующих программ
Рис. 3

В целях ознакомления с интерфейсами математического ядра (COM-сервера) рассмотрим программу на VB, которая создает модель динамической системы и запускает процесс симуляции в пакетном режиме (для расшифровки параметров методов см. табл. 2).

Листинг 2

    ' Объявляем переменную, как математическое ядро
    Private WithEvents Mdl As SimKernel
    Private mySmplArr(100) As Double

    ' Создаём из COM-сервера объект - математическое ядро
    Set Mdl = CreateObject("Klinachyov.SimKernel")

    ' Устанавливаем свойства симуляции модели
    Mdl.setSimProp 0, 1, 0.01, 0

    ' Создаем блоки (математические объекты или функции)
    Mdl.createBlock L702, 0, 1, 0		' inpVector
    Mdl.createBlock L101, 2, 1, 2		' summingJunction
    Mdl.createBlock L100, 1, 1, 1		' gain
    Mdl.createBlock L951, 1, 1, 1		' 1/S
    Mdl.createBlock L802, 1, 0, 0		' outVector
    Mdl.createBlock L800, 2, 0, 0		' export

    ' Устанавливаем параметры блоков и начальные условия
    Mdl.setBlkParam 2, 1, 1
    Mdl.setBlkParam 2, 2, -1
    Mdl.setBlkParam 3, 1, 4
    Mdl.setBlkParam 4, 1, 0

    ' Создаем связи между блоками (схему передачи аргументов)
    Mdl.createWire 1, 1, 1, 2
    Mdl.createWire 2, 1, 1, 3
    Mdl.createWire 3, 1, 1, 4
    Mdl.createWire 4, 1, 2, 2
    Mdl.createWire 2, 1, 1, 6
    Mdl.createWire 4, 1, 2, 6
    Mdl.createWire 4, 1, 1, 5

    ' Устанавливаем очередность исполнения блоков
    Mdl.BildSimFlow

    ' Это не важно - задаем массив выборок для обработки моделью
    For i = 0 To 99
        mySmplArr(i) = Sin(i / 7)
    Next

    ' Передаем массив в математическое ядро
    Mdl.swapInputOutputSamples mySmplArr

    ' Запускаем процесс симуляции модели
    Mdl.Simulation

    ' Считываем обработанный моделью массив
    Mdl.swapInputOutputSamples mySmplArr

    ' Запускаем сервер визуализации результатов
    ' ...

Беглого взгляда на программу достаточно, дабы сделать вывод о том, что процесс создания модели унифицирован (для создания любого математического блока или же любой межблочной связи используется только один соответствующий метод (интерфейс)). Именно жесткая унификация интерфейсов делает возможным создание шлюзов между редакторами векторной графики и математическими ядрами.

Таблица 2 (SimKernel.dll)
Интерфейсы (методы) COM-сервера - математического ядра
SimKernel.setSimProp(timeStart, timeEnd, dT, mode)
SimKernel.createBlock(IDLIB, numInp, numOut, numPrm)
SimKernel.setBlkParam(idBlk, indexPrm, prmValue)
SimKernel.createWire(O_idBlk, indexOut, indexInp, I_idBlk)
SimKernel.BildSimFlow()
SimKernel.SimStep()
SimKernel.Simulation()
SimKernel.ResetStates()
SimKernel.SnapStates()
SimKernel.swapInputOutputSamples(Array)
SimKernel.getState(idBlk, indexOut)
SimKernel.ControlPoints.Item(i)
ControlPoint.onCalc(inpVector)
SimKernel.UserBlocks.Item(i)
UserBlock.onCalc(inpVector, outVector, prmVector)
UserBlock.onFstStep(inpVector, outVector, prmVector)
UserBlock.onEndStep(inpVector, outVector, prmVector)
UserBlock.onPrmSet(prmVector)

Завершая обзор математического ядра, отметим, что представленные архитектурные решения позволяют решать системы как чисто дифференциальных уравнений (т.е. ядро может быть явным решателем), так и системы алгебро-дифференциальных уравнений (т.е. ядро может быть неявным (итерационным) решателем). Архитектура ядра не препятствует созданию, ставших уже классическими для моделирующих программ, методов частотного анализа [1]. Пользователь может свободно замещать блоки обладающие эффектом памяти (1/S, 1/Z, e-dTs) собственными процедурами, и, в любой момент, может иметь доступ ко всем координатам модели getState.

Графический интерфейс программ математического моделирования динамических систем

Графический интерфейс — это самое "слабое место" программ математического моделирования динамических систем. Попробуем разобраться с тем, что может понимать русскоязычный специалист под скромным английским термином диаграмма (diagram), если с помощью неё требуется представить описание модели системы на том или ином уровне в графической форме:

  1. Блок-схемы или около десятка именованных направленных графов.
  2. Схемы физические принципиальные электрических, магнитных, тепловых, гидравлических, акустических, механических, ротационных, и др. цепей преобразования энергий. Они же ненаправленные или би(со)направленные графы.
  3. Гибридные карты состояния или импульсные потоковые графы, графы переходных состояний.
  4. Графы алгоритмов программ.
  5. Структурные схемы, функциональные схемы, мнемосхемы.
  6. И многое другое.

Разнообразие впечатляет. Однако цель перечисления не в потрясении воображения читателя, а в том, чтобы подвести к мысли о том, что задача создания графического интерфейса непроста и не соответствует квалификации разработчиков моделирующих программ. Конечный пользователь должен понимать, что без кооперации усилий нескольких фирм эту задачу не решить (спрос пользователя рождает предложение). С задачей качественного отображения всего перечисленного, в любых масштабах, на любых устройствах ввода вывода, могут справиться лишь редакторы векторной графики — это их прямая задача. Дополнительным требованием к претенденту на её выполнение является открытость объектной архитектуры и наличие документации.

Как бы ни было велико разнообразие способов графического описания моделей, четко просматриваются лишь две техники моделирования: структурное моделирование и мультидоменное физическое моделирование. Для поддержки структурного моделирования требуется решатель систем дифференциальных уравнений и блок-схемы [3]. Для поддержки мультидоменного физического моделирования требуется итерационный решатель систем алгебро-дифференциальных уравнений и схемы физические принципиальные [4]. Другие виды графов либо мало эффективны, либо являются предками направленных и ненаправленных графов соответственно. Моделирование же управляемое событиями не является новой техникой моделирования, а лишь дополняет названные совокупностью методов переключения и синхронизации фрагментов моделей в процессе симуляции, обеспечивая тем самым программный контроль над потоком. Т.е. программный контроль над процессом прогонки массива MathBlock[i] или его фрагментов в режиме симуляции:

Листинг 3

    Пока (не случилось любое событие) Циклически исполнять фрагмент модели
        for (i=0; i < numBlock-10; i++) MathBlock[i]->Calc();
    Если (случилось такое событие) Исполнить фрагмент модели
        for (i=numBlock-10; i < numBlock; i++) MathBlock[i]->Calc();
    ...
    ' Использован синтаксис языка Си, дабы не усложнять список интерфейсов в табл. 2

Шлюз Visio2SimKernel

Если проанализировать вводную информацию по графическому интерфейсу моделирующих программ, то становятся очевидны задачи, возлагаемые на шлюз Visio2SimKernel:

  1. Контроль над процессом создания рисунка блок-схемы или же схемы физической принципиальной (техника выполнения рисунка блок-схемы отличается от техники выполнения чертежа гайки и возможны специфические облегчения некоторых графических процедур; также требуется контролировать соблюдение некоторых правил создания блок-схем, например отсутствие коротких замыканий выходов и др.).
  2. Дешифровка рисунка направленного графа (блок-схемы) и трансформация информации в программирующие математическое ядро инструкции (см. листинг 2).
  3. Трансформация ненаправленного графа (схемы физической принципиальной), путем перебора уточняющих коммутаций, в виртуальный (неначерченный) направленный, точнее би- или сонаправленный граф.
  4. Дешифровка графических образов, отвечающих за программирование потока(ов), и их трансформация в инструкции переключений математического ядра, а лучше ядер, каждое из которых может отвечать за свой поток, т.е. за свой фрагмент модели.
  5. Дешифровка графических образов, отвечающих за синхронизацию потоков (ядер).
  6. Контроль над процессом симуляции модели; управление процессами визуализации результатов и синхронизации Online воздействий (фактически это еще один шлюз).

В случае использования Visio [8], в качестве графического интерфейса, модульная структура моделирующей программы, изображенная на рис. 1, может быть сокращена. Достаточно оставить Visio, COM-сервер математического ядра, а так же серверы визуализации и Online воздействий. Тому способствуют следующие благоприятные моменты. Последние версии Visio ориентированны на сохранение рисунков в файлах с XML разметкой. Роль библиотеки шаблонов блоков SimKernel_Lib.xml может выполнять определяемая пользователем библиотека графических примитивов Visio (vss-файл). Причем, последние могут иметь переопределяемые пользователем параметры, которые сохраняются в файле рисунка. Объектная модель Visio имеет разделённые коллекции для библиотечных графических примитивов (в нашем случае это блоки), для линий связи, и для коннектеров, что упрощает написание шлюза.

Для математических ядер разных производителей шлюз будет отличаться лишь синтаксисом интерфейсов (табл. 2), который должны уточнить сами производители. Реализация первых двух задач, возложенных на шлюз Visio2SimKernel весьма проста (программа на VB не превышает двух сотен строк). Данной, сокращенной версии шлюза достаточно, дабы перекрыть возможности графических интерфейсов таких программ как Simulink, VisSim, MBTY, т.е. закрыть потребности техники структурного моделирования.

Таким образом, производителю математического ядра достаточно поставить: графическую библиотеку блоков, собственный шлюз (Visio2VisSim, Visio2Simulink, Visio2MBTY) и настроенный шаблон документа Visio, дабы пользователь мог использовать его для создания новых моделей. Шлюз может быть оформлен либо в виде вмонтированного в шаблон документа макроса, либо в виде расширений: add-in'а — для контроля над процессом создания рисунка через механизм событий, и add-on'а — для исполнения процедур дешифраций рисунка, программирования математического ядра и управления серверами визуализации и Online-воздействий.

Завершая обзор шлюза, надо отметить, что благодаря гибкости графического интерфейса на основе редакторов векторной графики, впервые у конечного пользователя моделирующих программ появится возможность решить задачу трансформации ненаправленного графа в граф направленный независимо от производителя. А это означает, что техника мультидоменного физического моделирования сделает громадный рывок вперед, поскольку перестанет быть ноу-хау нескольких фирм (см. программы: Dynast, 20-sim, Dymola, Simplorer, ITI-sim, Micro-Cap, Pspice, Multisim).

XML хранилище модели

Анализ графических примитивов и правил, используемых для выполнения рисунков блок-схем, позволяет выявить ряд объектов и принадлежащих им атрибутов, которые требуется сохранять в файле модели. Отношения между объектами демонстрирует показанная на рис. 4 схема данных. Очевидно, что для поддержания подобной информационной структуры требуется реляционная СУБД с мощными механизмами масштабирования, поиска, сортировки, обеспечения целостности данных и сохранения.

Схема данных хранилища модели
Рис. 4. Схема данных хранилища модели

К большому сожалению разработчики моделирующих программ предпочитают реализовывать собственные СУБД. Судя по функционированию программ, для большинства эта задача оказывается сложной. Вторым досадным моментом является несовместимость хранилищ (рабочих файлов) разных производителей и невозможность их непосредственного восприятия человеком. Как было упомянуто ранее, проблему может снять бесплатный движок реляционной базы данных фирмы Microsoft — COM-сервер msxml*.dll [7], последние версии которого включены в платформу .NET.

Если ориентироваться на Visio, то данный пакет уже использует этот движок для сохранения рисунков. Однако схема данных хранилища объектов Visio отличается от представленной на рис. 4. Это означает, что она не будет оптимальной (речь о нормализации базы данных) для хранения моделей и, в частности, блок-схем. Следует так же отметить, что схема данных для хранения объектов направленного графа (блок-схемы) не подойдет для хранения объектов ненаправленного графа (схемы физической принципиальной). Но различия не существенны, поэтому последнюю не рассматриваем. Более того, при использовании хранилищ с XML-разметкой, производители моделирующих программ могут придерживаться собственных схем данных — это не ограничит пользователя. Таже СУБД предоставляет механизмы XSLT-трансформаций, позволяющие без привлечения производителей переформатировать рабочие файлы одной моделирующей программы (их структуру и синтаксис) в рабочие файлы другой программы.

Одна из возможных XML-схем хранилища направленного графа (блок-схемы) представлена в виде листинга 4 (атрибуты не показаны). Большинство реляционных отношений схемы данных (рис. 4) кодируется инкапсуляцией описания соответствующих объектов внутри тегов объектов-владельцев. Лишь отношение между таблицей входов и таблицей связей задается парными атрибутами тегов <input/> и <wire/>. При отрисовке блок-схем широко используется механизм иерархической инкапсуляции повторяющегося фрагмента модели в одном составном блоке. В хранилище такие блоки имеют тег <space/>. Принцип описания инкапсуляции можно отследить по положению тегов <block/>.

Листинг 4

    <!-- XML-схема хранилища направленного графа (рисунка блок-схемы) -->
    <!-- Created by ModelStoreGate.WSC.1.00 -->
    <directed_bond_graph>
        <block>
            <space>
                <block>...</block>
                <block>...</block>
                ...
                <input />
                ...
                <output>
                    <wire />
                    ...
                </output>
                ...
            </space>
            <param />
            ...
            <input />
            ...
            <output>
                <wire />
                ...
            </output>
            ...
            <model>
                <name />
                <simproperties />
                <autor />
                <data />
                <description />
                <ico />
                <library />
            </model>
        </block>
    </directed_bond_graph>

Для создания хранилища и записи его на диск под управлением СУБД msxml*.dll требуется промежуточный COM-сервер, который допустимо написать на скриптах VBScript или JScript [6], но лучше на VB. Листинг 5 демонстрирует порядок использования объекта ModelStoreGate.WSC из этого сервера для экспорта блок-схемы. Сравнение листингов 2 и 5 позволяет выявить их подобие, из которого следует возможность использования шлюза Visio2SimKernel не только для программирования математического ядра, но и для экспорта рисунка блок-схемы в рабочий файл модели той или иной моделирующей программы.

Листинг 5

    /* ************************* Head ***************************** */

    // Определяем имя рабочего файла блок-схемы
    NameMakingFile = "MDL_01c.XML";

    // Создаём из COM-сервера объект для работы с хранилищем
    var	Store = new ActiveXObject("ModelStoreGate.WSC");
        Store.reConnectToLibrary("1stSim_Lib_V2b.xml");
        Store.ModelName = "K/(1+Ts) on SUB_1/S";
        Store.ModelTimeStart = 0;
        Store.ModelTimeStep = 0.01;
        Store.ModelTimeEnd = 1;
        Store.ModelSimMode = 0;
        Store.Autor = "Nikolay Klinachyov";
        Store.Date = "10.11.2003";
        Store.Description = "Модель апериодического звена "
        + "на субмодели дискретного квазианалога интегратора";
        Store.Ico = "apper.ico";

    // Создаем корневой составной блок
    // Определяем указатель на субобласть составного блока
    rtB = Store.addBlock("L001", null);

    /* ************************* Begin **************************** */

    // Создаем блоки внутри корневого составного блока
    Store.addBlock("L701", rtB);		// 1(t-dT)
    Store.addBlock("L101", rtB);		// summingJunction
    Store.addBlock("L100", rtB);		// gain
    Store.addModel("SUB_1S.XML", rtB);	// 1/S: 6+1 блок
    Store.addBlock("L800", rtB);		// export

    // Добавляем дополнительные входы и выходы блокам
    // Store.addInput(2);
    // Store.addOutput(0);

    // Устанавливаем параметры блоков и начальные условия
    Store.setParam( 1, 1, 1.0);
    Store.setParam( 1, 2, 0.05);
    Store.setParam( 2, 2, -1.0);
    Store.setParam( 3, 1, 4.0);

    // Создаем связи между блоками (схему передачи аргументов)
    Store.addWire( 1, 1, 1, 2);
    Store.addWire( 2, 1, 1, 3);
    Store.addWire( 3, 1, 1, 4);
    Store.addWire( 4, 1, 2, 2);
    Store.addWire( 2, 1, 1,11);
    Store.addWire( 4, 1, 2,11);

    /* ************************* End ****************************** */

    // Сохраняем хранилище в файле
    Store.save( NameMakingFile );
    // WScript.Echo("File " + NameMakingFile + " successfully created");
    // Store.visualizationInMSIE( NameMakingFile );

Фактически, объект ModelStoreGate.WSC отвечает за трансформацию линейного потока команд в иерархическое хранилище. Безусловно, при считывании рабочего файла в целях визуализации редактором векторной графики или же для прямого программирования математического ядра требуется обратное преобразование. Оно может быть выполнено одной процедурой с соответствующими параметрами, примером которой является командный скрипт XML2SimKernelGate.WSF см. рис. 2.

Резюме

В статье описана модульная структура программ математического моделирования динамических систем. К основными компонентам отнесены: редактор векторной графики, СУБД, математическое ядро, серверы визуализации и Online-воздействий.

Представлен обзор программных решений, которые, с высокой степенью вероятности, положены в основу математических ядер моделирующих программ с поточной моделью управления. Предпринята попытка сформировать пользовательский спрос на математические ядра выполненные в виде COM-серверов.

Продемонстрирована возможность интеграции математических ядер разных производителей с редактором векторной графики Visio. Указано на неустойчивость рынка моделирующих программ, по причине наличия у корпорации Microsoft трех из четырех технологий, необходимых для выхода на этот рынок и его захвата.

Сформулированы задачи, которые должны решать модули стыковки основных компонент программ математического моделирования динамических систем. Предложена схема данных и XML-схема хранилища направленного графа (рисунка блок-схемы), что может вызвать интерес у разработчиков.

Литература

  1. Клиначёв Н. В. Основы моделирования систем или 7 доменов законов Ома и Кирхгофа: Избранные фрагменты. - Offline версия 3.1. - Челябинск, 2000-2004. - 68 файлов, ил.
    – Website: http://www.vissim.nm.ru/oms_lec.html.
  2. Клиначёв Н. В. О структурном кризисе в методике преподавания блока дисциплин связанных с расчетом цепей преобразования энергий. - Челябинск, 2003.
    - Website: http://www.vissim.nm.ru/lectures/sml_06.htm.
  3. Клиначёв Н. В. Введение в технологию моделирования на основе направленных графов. - Челябинск, 2003.
    – Website: http://www.vissim.nm.ru/lectures/sml_02.htm.
  4. Клиначёв Н. В. Введение в технологию мультидоменного физического моделирования с применением ненаправленных графов. - Челябинск, 2003.
    – Website: http://www.vissim.nm.ru/lectures/sml_03.htm.
  5. Герберт Шилдт. Самоучитель C/C++: пер. с англ. - 3-е издание. - СПб.: БХВ Петербург, 2001. - 688 с.
  6. Microsoft Corporation. Microsoft® Windows Script Technologies Development Center. – Website: http://msdn.microsoft.com/scripting.
  7. Microsoft Corporation. Microsoft® XML Development Center. – Website: http://msdn.microsoft.com/xml.
  8. Microsoft Corporation. Microsoft® Visio Development Center. – Website: http://msdn.microsoft.com/visio.
  9. National Instruments Corporation. NI® Measurement Studio Development Center. - Website: http://www.ni.com/mstudio.


О кризисе преподавания дисциплин связанных с расчетом цепей преобразования энергий

Что же с ТОЭ?
или
О структурном кризисе в методике преподавания блока дисциплин связанных с расчетом цепей преобразования энергий

На первый взгляд признаки кризиса в методике преподавания блока дисциплин связанных с расчетом цепей преобразования энергий, который, как предполагает автор этих строк, проявится к 2015..2020 годам, практически не видны. Более того, каждая из тех 7..9 дисциплин, на которые кризис повлияет, имеет не просто хорошие учебники, а самые лучшие, поскольку их содержимое шлифовалось талантливыми педагогами страны без изменений сути излагаемых вопросов уже более 30..50 лет. Для примера сравните учебники по ТОЭ, электроприводу, гидропневмоавтоматике и т.д., с переводной литературой, которую педагоги вынуждены использовать в качестве учебной по современным технологиям программирования.

Какова же причина грядущего кризиса, если сегодня у названных дисциплин имеется блестящее методическое обеспечение, наработанное на основе совокупности фундаментальных законов, в ряду которых не прогнозируются подвижки? Ответ прост – это появление нового вычислительного инструментария – программ мультидоменного математического моделирования динамических систем. Попробуем обосновать данное утверждение.

Уровни сложности задач расчета цепей преобразования энергий

Тип источников движущих сил и вид требуемой в итоге расчета информации о режиме работы цепи преобразования энергии позволяют выделить пять подходов к решению, отличающихся необходимостью использования разных математических аппаратов с повышающимся уровнем сложности:

  1. Расчет цепей с постоянными движущими силами
  2. Расчет цепей с синусоидальными движущими силами
  3. Расчет цепей с периодическими движущими силами
  4. Расчет цепей с непериодическими движущими силами
  5. Расчет цепей с волновыми процессами

Задачи принадлежащие первому уровню просты, и для их решения используются четыре математические операции: +, -, *, /. При решении задач второго уровня требуется выполнять упомянутые операции с величинами меняющимся по синусоидальному закону, поэтому используются либо "расчеты по модулям" (теорема Пифагора + векторная диаграмма), либо аппарат комплексных чисел. Третий уровень весьма условен. Здесь предполагается представление периодических движущих сил рядом Фурье и получение итогового результата согласно принципу суперпозиции с возвращением ко второму уровню, при выполнении расчетов для каждой из гармоник. Четвертый уровень предполагает описание энергетической цепи дифференциальными уравнениями и обычно используется для уточнения переходных режимов работы. На пятом уровне требуется решать дифференциальные уравнения в частных производных, учитывая индивидуальную геометрию энергетической цепи.

О том, как программы мультидоменного математического моделирования динамических систем "выкинули на помойку" учебники по теоретическим основам цепей

Известно много хороших математических программ. В наших целях каждую программу можно отнести к одной из двух групп:

  1. Мощные калькуляторы для статических вычислений (Matcad, Mathematica, Maple).
  2. Специализированные решатели для моделирования динамических процессов (DyMoLa, Dynast, Multisim, VisSim, MBTY, MVS, Simulink).

Применение в обучении первой группы программ для расчета цепей преобразования энергий возможно, не вызывает ни каких затруднений, гладко согласуется со всеми методиками изложенными в учебниках по "теоретическим основам", отвечает требованиям Министерства образования, но не имеет ни какого смысла. Вспомним о том, что лишь 20 страниц из учебников по "теоретическим основам цепей" дают студенту фундаментальные знания (о законах Ома и Кирхгофа). Остальная информация – это изложение жестко формализованных методов, не дающих студенту новых знаний (выберите направление токов, посчитайте количество узлов, и пр.). Сейчас уже мало кто помнит, но главной целью разработки всех альтернативных методов расчета цепей было сокращение объема вычислений. Сегодня любой "универсальный калькулятор" (Matcad, Mathematica, Maple) рассчитает любую цепь, любым методом за десятые доли секунды. Это прогресс, это замечательно, но надо сказать, что мгновенные вычисления на "калькуляторах" не добавляют знаний студентам. Возникает так же более серьезный вопрос. Как объяснить студенту, зачем ему требуется зубрить альтернативные методы, когда он может выполнить проектирование любой цепи, преобразующей энергию, разобравшись лишь с законом Ома и законами Кирхгофа? Уже сегодня вразумительного ответа на поставленный вопрос нет.

Однако кроме методов расчета цепей, учебники по "теоретическим основам" содержат описания подходов к решению задач, которые были упомянуты выше. Ценность этой информации низвели до нулевого уровня программы второй группы. Их разработчики справедливо предположили, что задачи первых трех уровней сложности (см. список выше), можно решать с помощью математического аппарата, применяемого для решения задач четвертого уровня. Таким образом из учебника по "теоретическим основам" упомянутые программы взяли на вооружение лишь законы Ома и Кирхгофа, используя их в дифференциальной форме.

Сценарий изменения методики преподавания "Теоретических основ цепей" и обзор затруднений

Показанные противоречия, бесспорно, требуют изменений в методике преподавания. Перед педагогами стоит серьезная задача. Согласно стратегическим взглядам Министерства образования требуется внедрить в процесс обучения компьютеры, и, за счет каких-то их мультимедийных, интерактивно-волшебных возможностей сократить количество лекционных занятий, увеличив при этом долю самостоятельной работы студентов.

"Теоретические основы цепей" всегда были самыми сложными дисциплинами. "Программы-калькуляторы" ни коем образом не позволят педагогу подготовить учебный материал в более наглядной и доступной форме, дабы его можно было вынести в часы самостоятельной работы студента. Поэтому опора на такие программы как Matcad, Mathematica, Maple; плюс стремление педагогов (впрочем, согласно требованиям стандартов Министерства образования) сохранить тематическое содержимое приводит к разрушению этих фундаментальных дисциплин.

Оценка всех возможных вариантов ужатий, сокращений, и интерактивно-волшебных возможностей компьютеров дает лишь один максимально безвредный сценарий изменения методики преподавания "теоретических основ цепей":

  1. Исключение из программ дисциплин всех тем, связанных с изучением особенностей подходов к решению задач первых трех уровней и обучение решению этих же задач с применением математического аппарата адекватного по уровню сложности задачам четвертого уровня.
  2. Использование специализированных решателей для моделирования динамических процессов (DyMoLa, Dynast, Multisim, Micro-Cap; VisSim, MBTY, MVS, Simulink).

Подобный переход не просто труден, а труден существенно. Так повальная гуманитаризация высшего технического образования в России привела к тому, что вследствие сокращения часов неспециалисты в итоге обучения знакомы с задачами расчета цепей преобразования энергий лишь первых двух уровней сложности. Предлагается же сразу перейти к четвертому уровню. Кроме того, крайне желательно, дабы на момент перехода были одновременно модифицированы рабочие программы нескольких дисциплин: физики, ТОЭ, гидропневмоавтоматики, механики линейных и ротационных перемещений, теплотехники, основ моделирования систем (или математики), а так же целого веера дисциплин стоящих за теоретическими основами каждого энергетического домена.

Отдельная и существенная проблема заключается в несерьезном отношении российского общества, как к моделированию технических систем, так и к покупке соответствующего программного обеспечения. Вот факты: В России лишь два коллектива разрабатывают программы, которые со временем, если не разорятся, будут поддерживать технологию мультидоменного физического моделирования с применением ненаправленных графов (MBTY и MVS). Разработчики тех же программ утверждают, что Российские вузы не покупают их продукт. При этом факт воровства программы MBTY работниками вышей школы, с попыткой дальнейшего коммерческого использования был зафиксирован на территории Казахстана в начале 2003 года. Промышленность России, за исключением атомной, вообще не интересуется подобными программами.

Чуть меньшим препятствием является стремление разработчиков программ для мультидоменного моделирования, таких как Multisim (EWB), Dynast, 20-sim, ITI-SIM, Simplorer и DyMoLa, скрыть принципы их функционирования. Как любое непознанное, это вызывает недоверие у преподавателей к данным программам и порождает сомнения в возможности отказа от большинства формализованных методов расчета цепей. Автор высказывает надежду, что данное пособие развеет часть этих сомнений.

Выводы

Для максимально плавного преодоления кризиса в методике преподавания дисциплин связанных с расчетом цепей преобразования энергий требуется выполнение следующих условий.

  1. Преподаватели не должны скрывать, от студентов тот факт, что большинство изучаемых методик расчета цепей доживают последние дни, поскольку были рассчитаны на ручные вычисления.
  2. Надо признать, что использование в учебном процессе для расчета цепей преобразования энергий широко известных математических программ для статических вычислений (Matcad, Mathematica, Maple) не даст положительного методического результата.
  3. Вузы России должны покупать специализированные программы для моделирования динамических процессов. Покупки должны быть централизованы. Программу должен покупать вуз, а не кафедра. Только в этом случае вузы смогут заставить разработчиков раскрыть технологии функционирования программ. Кроме того, вуз – это не рядовой потребитель (юзер), поэтому покупку каждой новой версии вуз должен превращать в финансирование нужных ему доработок в программе.
  4. Вузам требуется существенно увеличить количество аудиторий оборудованных компьютерной проекционной аппаратурой. Мел доска и текст, как средства обучения, должны уйти в прошлое.

Каков же прогноз протекания кризиса, если мы как всегда, дружно и все вместе, вспомним о нашей любимой поговорке: "Работа – не волк – в лес не убежит"? На взгляд автора через пятнадцать лет студенты будут заваливать преподавателей задачами прорешанными, к тому времени в чуть более совершенных программах. И преподавание фундаментальных технических дисциплин превратиться в такую же профанацию, какую мы имеем сегодня в тех гуманитарных дисциплинах, технология освоения которых предполагает написание реферативных работ.

Чем же страшен этот кризис? Ведь он, как и многие другие, будет пережит нами. Главная опасность в том, что существует не один, а два сценария посткризисного развития. Согласно первому сценарию в России появится еще ряд профессий, для которых будет справедливо высказывание Бернарда Шоу: "Всякая профессия – есть заговор против непосвященного". И последующие 50 лет мы будем говорить о необходимости "прозрачности" не только в финансовой отчетности предприятий, но и в технических решениях. (Кто сегодня помнит о том, что еще не так давно нельзя было продать телевизор или магнитофон без схемы электрической принципиальной)? Согласно второму сценарию дисциплины связанные с теорией расчета цепей преобразования энергий действительно станут простыми и легкими в изучении. Выбирать – нам.

9.09.2003


ЛИТЕРАТУРА

  1. Herman Mann, Michal Sevcenko. Multipole modeling of multidisciplinary systems. — Website: http://virtual.cvut.cz/course, Czech Technical University in Prague, 2001.
  2. Controllab Products B. V. Справочная система программы 20-Sim. — Website: http://www.20sim.com, Netherlands, 2001.
  3. Бессонов Л. А. Теоретические основы электротехники: Электрические цепи. — М: Высш. школа, 1978. — 528 с., ил.
  4. Клиначёв Н. В. Моделирование систем в программе VisSim: Справочная система. — Offline версия [vsmhlpru.zip]. — Website: http://vissim.nm.ru/vsmhlpru.zip, http://vissim.nm.ru/help/vissim.htm, Челябинск, 2002.

Искать в Rambler
Искать в Yandex
hh -decompile c:\__\ c:\__\tau_knv.chm


FAQ по ресурсу tau_knv.chm

Ответы на часто задаваемые вопросы

Когда я нажимаю на ссылки около слов "Рабочие файлы" я вижу непонятный текст. Что мне делать?

На вашем компьютере не установлена студенческая версия программы VisSim. Ее надо скачать и установить на ваш компьютер. Часть рабочих файлов заархивированных в данном ресурсе являются рабочими файлами программы Electronics WorkBench 4.1. Она так же должна быть установлена на вашем компьютере.

Пример "непонятного текста"
; VisSim Block Diagram Format (VBDF)
; Copyright ©1989-1999 Visual Solutions
PA=1
POa="Nikolay Klinachyov"
PV=3.000
PS=0
PE=0.5
PP=0.0001
PI=172
PX=0.0001
PN=1e-006
PL=5
PT=1e-005
Pn=-8,6,14,"MS Sans Serif"
...

Откуда загрузить студенческую версию программы VisSim?

См. раздел "Download" сайта "VisSim в России".

Является ли студенческая версия программы VisSim бесплатной?

Да, студенческая версия программы VisSim распространяется бесплатно. По условиям правомочного использования программы вам нужно зарегистрироваться.

Я установил программу VisSim, но когда я нажимаю на ссылки, указывающие на рабочие файлы программы VisSim, распаковка файла блокируется и выдается сообщение о том, что файл не доступен. Что мне делать?

Есть подозрение, что причина в антивирусной программе (Касперского), которая толи сама блокирует их запуск, толи меняет настройки у браузера MSIE в реестре и последний сам не запускает файлы по гиперссылке. Как правило, деактивация антивирусного монитора не дает желаемого результата (запрет на загрузку сохраняется где-то в реестре). Деархивируйте файл tau_knv.chm и запускайте файлы обычным образом из директории ...\EXMPL\.

Команда деархивации: hh -decompile c:\DIR\ c:\DIR\tau_knv.chm

Подобная же ситуация наблюдается на тех компьютерах, где на новую версию браузера MSIE была установлена старая. Сделанного не вернуть - деинсталляция новой версии браузера не удаляет ряд COM-объектов. Старая версия их не переписывает, а пользоваться ими корректно не умеет. Рекомендуется вернуться к новой версии браузера MSIE.

Я обнаружил, что в студенческой версии программы VisSim нет документации. Где ее можно взять?

Переведенную на русский язык справку программы можно найти на сайте "VisSim в России", см. раздел "Download", файл vsmhlpru.zip.

У меня есть вопросы о моделировании в программе VisSim. Кому я могу их задать?

Вам рекомендуется вступить в дискуссионную группу "Симуляция движения (моделирование)". В данном учебно-методическом комплексе (см. навигацию) есть подробные инструкции о том, как работать с дискуссионной группой.


Теория систем автоматического регулирования: УМК / Н. В. Клиначёв.

This page uses frames, but your browser doesn't support them.


Глоссарий терминов

Моделирование мультидисциплинарных систем - глоссарий терминов

Энергетические домены

Электрический
Переменные мощности: электрическое напряжение, электрический ток
Магнитный
Переменные мощности: магнитное напряжение, магнитный поток
Термальный
Переменные мощности: температура, поток энтропии
Гидравлический
Переменные мощности: давление, поток объема (расход)
Акустический
Переменные мощности: давление, поток объема (расход)
Механический
Переменные мощности: скорость, сила
Ротационный
Переменные мощности: угловая скорость, момент
Энергетические домены
 | Электрический | Переменные мощности: электрическое напряжение, электрический ток
 | Магнитный | Переменные мощности: магнитное напряжение, магнитный поток
 | Термальный | Переменные мощности: температура, поток энтропии
 | Гидравлический | Переменные мощности: давление, поток объема (расход)
 | Акустический | Переменные мощности: давление, поток объема (расход)
 | Механический | Переменные мощности: скорость, сила
 | Ротационный | Переменные мощности: угловая скорость, момент
Энергия
 | Входы | Области на поверхности модуля, к которым подводится энергия для последующего преобразования. Энергией, которая передается модулю по оставшейся поверхности пренебрегают
 | Взаимодействия | Энергетический поток (потребляемая мощность) через соответствующие входы на поверхности модуля системы
Эксперимент
 | Натурный | Процесс наблюдения за ходом преобразования энергии динамической системой, вследствие появления некоторых вынуждающих воздействий, обычно сопровождаемый измерениями
 | Симуляционный | Процесс наблюдения за ходом преобразования энергии в результате симуляции движения координат модели динамической системы, вследствие появления некоторых вынуждающих воздействий, обычно сопровождаемый измерениями
Уровни моделирования
 | Абстракция | Выделение атрибутов модели (например: концептуальных, функциональных, физических или технологических)
 | Идеализация | Выбор типов взаимодействий координат модели (например: линейные или нелинейные, инвариантные или зависимые от времени, с запаздыванием, в условиях распределенных параметров, и т.д.)
 | Детализация | Описание модулей системы (т.е. деталей, узлов или агрегатов устройств, из которых динамическая система собрана). Здесь же описываются динамические эффекты (физические явления) возникающие в системе
mechatronics |  | approach to the of intelligent dynamic systems integrated across engineering disciplines
Моделирование |  | Переход от динамической системы к модели требуемого уровня: абстракции, идеализации или детализации
Симуляция |  | Процесс вынужденного движения координат модели
 | Интервал адекватности | Интервалы времени, влияющих параметров и значений координат, в которых симуляция модели описывает динамическую систему с заданной погрешностью
Модель
 | Концептуальная | characterizes causes-and-effects in a dynamic system or system module respecting algebraic rules
 | Функциональная | characterizes interrelations of variables a dynamic system or system module respecting algebraic rules
 | Физическая | characterizes continuous-time continuous-level energetic interactions of system modules respecting physical laws
 | Технологическая | model of a technological process required to produce a dynamic system
 | Многоуровневая | model the parts of which are considered on a different level of modeling abstraction
 | Мультидоменная | physical model the parts of which belong to different energy domains
 | Дискретная | functional model the model variables of which are approximated by discrete-time and/or discrete-level functions
 | Гибридная | discrete model combined with a physical model or a continuous-time continuous-level functional model
Модель
 | Представление | Геометрическое (отражает геометрические размеры и координаты), структурное (отражает внутреннюю топологию), поведенческое (определяет реакцию на внешние эффекты)
 | Описание | уравнения, структурная схема (блок-схема), графы связи (bond graph), многополюсная диаграмма (с моделями физических элементов), и т.д. + каждое описание может контролироватся графом конечного автомата, те гибридной картой состояний (гибридное моделирование)
 | Идентификация | Процесс определения прараметров модели базирующийся на физических гипотезах и/или эксперементах
 | Истиная / Ложная |
 | Проверка адекватности | Процесс выполнения серии экспериментов с динамической системой и ее моделью (или модулем модели), цель которых - оценка величин погрешностей в движении координат и последующая проверка на удовлетворение допускам. (Сплошь и рядом результаты симуляции движения координат абсолютно ложных по природе моделей, при каких то допусках признаются адекватными - например, для геоцентрической модели Мира).
 | Пременные (координаты) | Характеризуют текущее динамическое состояние модели
 | Параметры | Характеризуют модель независимо от ее текущего динамического состояния (если конечно модель непараметрическая)
Модуль
 | Граница | geometric surface chosen in such a way that it completely encircles a system module without cutting into the boundary of any other module. The boundary itself has zero thickness, but it can be movable
 | Модель | Абстрактное, идеализированное представление модуля системы в той или иной форме математического описания, разработанное для ограниченного (определенного) класса симуляционных экспериментов
Многополюсник Мультиполюс |  | Модель модуля взаимодействий энергии модуля системы, управляемого тремя постулатами мультиполюса module model of energy interactions of a system module governed by the three multipole postulates
 | Полюс | Представление скалярного взаимодействия энергии входа энергии модуля системы representation of a scalar energy interaction of an energy entry of a system module
 | Секция | Подмножество полюсов мультиполюса, уважая постулат мультиполюса непрерывности subset of multipole poles respecting the multipole postulate of continuity
multipole postulate of
 | power intake | states that the energy interactions of a multipole are fully represented by its pole-across and pole-through variables
 | continuity | states that the sum of all the pole-through variables of a multipole section equals to zero
 | compatibility | states that across variable between poles in a multipole section equals to the difference of pole-across variables of the poles
prototype,
 | real | dynamic system built to verify correctness of a system design by experiments
 | virtual | system model set up to verify correctness of a system design by simulation experiments
reference,
 | across-variable | voltage of the electrical ground, temperature at the zero point on the absolute or Celsius' scale, pressure of free-space atmosphere, velocity of the absolute frame, etc.
Система
 | Динамическая | region in space filled with quantities of matter interrelated by energy interactions
 | Механическая | collection of bodies in which some or all of the bodies can move relative to one another
 | mechatronic | multidisciplinary system with intelligent control
 | Мульти- дисциплинарная | dynamic system the investigation of which requires experts from different traditional engineering disciplines
Систем
 | Анализ | Подмножество задач симуляции систем связаное с использованием библиотек анализа. Различаются различные виды анализа: символьный, частотный, корневой, измерительный - операющиеся как на аналитические, так и на численные методы
 | Проектирование | Процесс определения структуры и параметров динамической системы, направленный на удовлетворение требований заданных критериев
 | Синтез | Систематизироанный и однозначный подход к решению задачи проектирования системы
 | Оптимизация | Процесс подбора параметров модели системы, направленный на удовлентворение требований выбранных критериев
 | Отладка (Диагностика) | Поиск причин (возможных) отказов динамической системы
 | Среда | Масса или область вне динамической системы
 | Модель | Представление динамической системы в форме абстрактного и идеализированного описания, связанного с определенным классом экспериментов
 | Модуль | Часть динамической системы, отделенная от системы границей модуля
 | Модуляризация | Процесс виртуальной декомпозиции реальной динамической системы в модули модели системы
Переменные
 | Мощность | Произведение парных (для каждого энергетического домена) физических величин поперечной и продольной, которое определяет объем преобразуемой энергении в модуле системы
 | Поперечная (across) | Та из парных физических величин (чье произведение есть мощность), которая фиксируется датчиком, подключеным между двумя подводами энергии к модулю динамической системы
 | Продольная (through) | Та из парных физических величин (чье произведение есть мощность), которая фиксируется датчиком, установленным в разрыв любого из двух подводов энергии к модулю динамической системы
 | pole-across | Поперечные переменные (координаты) индивидуальных полюсов многополюсника выраженные в единицах опорной поперечной переменной
 | pole-through | Продольные переменные (координаты) индивидуальных полюсов многополюсника выраженные в единицах опорной продольной переменной


Численные методы решения нелинейных алгебраических уравнений и систем, составляющие основу итерационного решателя моделирующих программ

Решить систему уравнений [f(xn)] = 0 численно — значит найти, а точнее подобрать (подогнать) такие значения [xn], которые обнулят систему полиномов [f(xn)]. В процессе подгонки, по текущим результатам нужно принимать решение о том, какие значения искомых переменных [xn+1] подставлять в следующий раз (n – индекс текущего приближения корня). Для этого существуют разные методы.

Метод Ньютона для решения уравнения и системы уравнений:

xn+1 = xn - f(xn) / f '(xn) ,

[xn+1] = [xn] - [f '(xn)]-1 [f(xn)] .

Метод Ньютона-Рафсона предполагает возможность относительного изменения шага итерации a:

[xn+1] = [xn] - [f '(xn)]-1 [f(xn)] an .

Модифицированный метод Ньютона предполагает замораживание инверсной матрицы производных (инверсного Якобиана) на первом шаге:

[xn+1] = [xn] - [f '(x0)]-1 [f(xn)] .

Но в этом случае наблюдается лишь линейное схождение. Хотя, через несколько итераций, инверсный Якобиан можно обновлять.

Метод секущих:

xn+1 = xn - f(xn) (xn - xn-1) / (f(xn) - f(xn-1)) .

Здесь невозможно вести речь об оценке производной конечной разностью, поскольку шаг итерации очень большой.

В VisSim'е, переменной xn соответствует блок "неизвестная", а блок "нулевой баланс" считывает с модели значение функции f(xn). Приведенные же выше формулы используются для расчета значения на выходе блока "неизвестная" на следующем шаге итерации.

Основные итерационные методы сходятся весьма быстро. Для того чтобы текущее приближение стало более чем в миллион раз ближе к корню, методу дихотомии требуется 40 итераций, методу золотого сечения – 29, методу Ньютона еще меньше. Очевидно, что линейные системы уравнений решаются за одну итерацию. А ими, например, описываются почти все задачи дисциплины "ТОЭ" изучаемые студентами в вузе.


Клиначёв Николай Васильевич

Клиначёв Николай Васильевич Клиначёв Николай Васильевич,
к.т.н., доцент кафедр "Электротехника" и "Информатика" ЮУрГУ
т.р. (3512)67-90-14, т.д. (3512)34-71-62; <klinacherv_nv@mail.ru>

Основные преподаваемые дисциплины:

1) "Электротехника и электроника",
2) "Электрические и электронные аппараты",
3) "Управление техническими системами",
4) "Математические основы ТАУ",
5) "Аналоговые и аналогово-цифровые интегральные микросхемы",
6) "Информатика".

Специальность: Системы обработки информации и управления

Сфера профессиональных интересов:

Все уровни разработки любой электроники любыми методами на любой элементной базе. Программирование: C++, Pascal, Java, VB, JavaScript, HTML, ассемблеры, эмуляторы, отладчики; интегрированные среды разработки IDE; CAE/CAD системы, EDA/PCB инструменты; пакеты симулирующие движение; SCADA пакеты. Педагогическая деятельность.

Принимал участие в разработке следующих проектов:

  1. Генератор сигналов произвольной формы.
  2. Измерительный комплекс для снятия АФЧХ систем.
  3. Имитатор солнечной батареи - DC/DC (для замещения последней в наземных условиях).
  4. Прибор для измерения контактного сопротивления.
  5. Прибор для измерения удельного сопротивления углеграфитовых изделий.
  6. Прибор для измерения активного сопротивления обмоток электрических машин большой мощности.

Личные проекты:

  1. Cервер "VisSim в России".
  2. Сервер "LabVIEW в России".
  3. Система "ИНТЕРНЕТ-КОЛЛОКВИУМ".
  4. Библиотека измерений ЧХ систем для пакета VisSim.

Методическая работа:

  1. Сервер кафедры "Электротехника".
  2. Выполнение обязанностей модератора почтовых дискуссионных групп и одноименных форумов:
    е-группа "Цифровая обработка сигналов в LabVIEW" (пустое письмо для подписки или ...)
    е-группа "Симуляция движения и моделирование САУ в VisSim-е" (пустое письмо для подписки или...)

Публикации (методические):

  1. Клиначёв Н. В. Электротехника: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 1999. - 671 файл, ил.
  2. Клиначёв Н.В. Моделирование обыкновенных линейных систем. ТАУ, Электроника: Руководство к лабораторным работам в пакетах VisSim и Electronics Workbench. - Челябинск, 2001. (дополнительный адрес).
  3. Клиначёв Н. В. Теория систем автоматического регулирования и управления: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 2001. - 101 файл, ил.
  4. Клиначёв Н. В. Моделирование систем в программе VisSim: Справочная система. - Online версия 1.0. - Челябинск, 2001. - 214 файлов, ил. (архив Offline версии - vsmhlpru.chm).
  5. Литюга А. М., Клиначёв Н. В., Мазуров В. М. Теоретические основы построения эффективных АСУ ТП: Конспект лекций. - Offline версия 1.1. - Тула, Челябинск, 2002. - 703 файла, ил.
  6. Неизвестный автор и Клиначёв Н. В. LabVIEW в упражнениях: Учебное пособие. - Offline версия 1.0. - Челябинск, 2001. - 212 файлов, ил.
  7. Федосов Б. Т., Клиначёв Н. В. Теория систем автоматического регулирования: Руководство к выполнению лабораторных работ. - Offline версия 1.0 для заочного обучения. - Рудный, Челябинск, 2002. - 66 файлов, ил.
  8. Клиначёв Н. В. Теория систем автоматического регулирования и управления: Учебно-методический комплекс. - Offline и Online версии 1.5, 1.6, ..., 3.4. - Челябинск, 2000-2004. - 654 файла, ил. (дополнительный адрес).
  9. Клиначёв Н. В. Основы моделирования систем или 7 доменов законов Ома и Кирхгофа: Избранные фрагменты. - Offline и Online версии 1.9, 2.0, ..., 3.4. - Челябинск, 2000-2004. - 654 файла, ил. (Распространяется в одном файле с учебно-методическим комплексом по ТАУ).
  10. Клиначёв Н. В. Библиотека SimLib4Visio - инструмент программирования математических ядер моделирующих программ. - v1.2. - Челябинск, 2004. - 13 файлов.

Год начала преподавательской деятельности:1997

Рабочие языки общения: английский

Адрес: Энгельса 42-31, Челябинск, Россия, 454080


Направленные и ненаправленные графы

Клиначёв Николай Васильевич

Глоссарий терминов

Графов теория
Учение об общих топологических свойствах графов и о вытекающих из них расчетных методах. Две ветви теории: тероия направленных графов и тероия ненаправленных графов четко делят между собой программы визуального математического моделирования.
Граф направленный, сигнальный
Диаграмма прохождения сигнала, состоящая из совокупности узлов (сумматоров) и соединяющих их ветвей. Стрелки на ветвях указывают направление передачи сигнала или воздействия от одного узла к другому. Ветви в направленном графе характеризуются передаточными функциями. Направленный граф является графической формой записи системы уравнений описывающих динамическую систему, и не может отражать ее топологию (модульную структуру).
Узел направленного графа
Сумматор координат модели динамической системы с одним выходом (поэтому узел направленного графа называют координатой). Обычно в каждом энергетическом домене в качестве координат выступают парные физические величины, чье произведение есть мощность. В пакетах математического моделирования эти парные физические величины называются координатами первого и второго рода. Выходные координаты ветвей собираются в узлы направленного графа согласно первому и второму законам Кирхгофа1. Узлы направленного графа, ровно, как и сам граф, не отражают различий в физической природе координат первого и второго рода (это непреодолимый недостаток направленных графов).
Ветвь направленного графа
Графический образ закона преобразования сигнала, который называется передаточной функцией. Если направленный граф есть истинная модель динамической системы и узлы графа отражают все ее координаты (граф не приведен), то передаточные функции ветвей есть либо закон Ома2, сформулированный для соответствующего энергетического домена и связывающий его физические величины первого и второго рода, либо другие физические законы, связывающие физические величины первого и второго рода разных энергетических доменов.
Граф ненаправленный, топологический (схема замещения)
Схема, состоящая из совокупности соединенных в узловых точках двухполюсных модулей преобразующих энергию. Полюсы двухполюсников являются подводами энергии. Для ветвей ненаправленного графа нельзя однозначно указать направление распространения координаты первого рода. Ненаправленный граф зеркально (без искажений) отражает модульную структуру (схему замещения) динамической системы (энергетической цепи), и в том же графическом образе, но как в нелинейном зеркале, отражается ее система уравнений. Для узлов ненаправленного графа формулируются постулат о сохранении материи, а для контуров – постулат о сохранении энергетических потенциалов.
Узел ненаправленного графа
Условное графическое обозначение места соединения трех ветвей, в котором происходит либо распределение, либо аккумуляция координаты первого рода (потока материи). В любом ненаправленном графе узлов-распределителей и узлов-аккумуляторов материи равное количество. Различие математических моделей этих узлов, в силу единообразия физических конструкций, ни как не отражается в графическом представлении (т.е. в ненаправленном графе). Любая ветвь ненаправленного графа энергетической цепи соединяется с узлами разного типа. Модели узлов, в которых сходится большее количество ветвей, получаются каскадированием трехвыводных узлов. В динамике, поток (физическая величина первого рода) любой ветви входящей в узел может менять свое направление; в узлах графа происходит лишь смена знака потока.
Ветвь ненаправленного графа
Участок энергетической цепи в ненаправленном графе с одним и тем же потоком материи (координатой первого рода), который может состоять из произвольного количества последовательно включенных моделей физических элементов.
Контур
Для направленных и ненаправленных графов, это замкнутый путь, проходящий через несколько узлов и ветвей.
Координата первого рода (through variable3)
Отражение в модели той из парных физических величин (чье произведение есть мощность), которая фиксируется датчиком, установленным в разрыв любого подвода энергии к модулю динамической системы. Во всех энергетических доменах физические величины первого рода подчиняются первому закону Кирхгофа.
Координата второго рода (across variable3)
Отражение в модели той из парных физических величин (чье произведение есть мощность), которая фиксируется датчиком, подключенным между любыми двумя подводами энергии к модулю динамической системы. Во всех энергетических доменах физические величины второго рода подчиняются второму закону Кирхгофа.

Математическое моделирование на основе направленных и ненаправленные графов. Или о двух способах описания графическими образами моделей динамических систем

Мир технических систем в 7 раз проще,
чем мы о нем думаем сейчас

Графов теория
Учение об общих топологических свойствах графов и о вытекающих из них расчетных методах. Две ветви теории: теория направленных графов и тероия ненаправленных графов четко делят между собой программы визуального математического моделирования.
Граф направленный (сигнальный)
Диаграмма прохождения сигнала, состоящая из совокупности узлов (сумматоров) и соединяющих их ветвей. Стрелки на ветвях указывают направление передачи сигнала или воздействия от одгого узла к другому. Ветви в направленном графе характеризуются передаточными функциями. Направленный граф является графической формой записи системы уравнений описывающих динамическую систему, и не может отражать ее топологию (модульную структуру).
Узел направленного графа
Сумматор координат модели динамической системы с одним выходом (поэтому узел направленного графа называют координатой). Обычно в каждом энергетическом домене в качестве координат выступают парные физические величины, чье произведение есть мощьность. В пакетах математического моделирования эти парные физические величины называются координатами первого и второго рода. Выходные координаты ветвей собираются в узлы направленного графа согласно первому и второму законам Кирхгофа1. Узлы направленного графа, ровно как и сам граф, не отражают различий в физической природе координат первого и второго рода (это непреодолимый недостаток направленных графов).
Ветвь направленного графа
Графический образ закона преобразования сигнала, который называется передаточной функцией. Если направленный граф есть истинная модель динамической системы и узлы графа отражают все ее координаты (граф не приведен), то передаточные функции ветвей есть либо закон Ома2, сформулированный для соответствующего энергетического домена и связывающий его физические величины первого и второго рода, либо другие физические законы, связывающие физические величины первого и второго рода разных энергетических доменов.
Граф ненаправленный (топологический)
Схема, состоящая из совокупности соединенных в узловых точках двух- или ?многополюсных модулей? преобразующих энергию. Полюсы многополюсников являются подводами энергии. Для ветвей ненаправленного графа нельзя однозначно указать направление распространения коордитаты первого рода. Ненаправленный граф зеракльно (без искажений) отражает топологию (модульную структуру) динамической системы, и в том же графическом образе, но как в нелинейном зеркале, отражается ее система уравнений. Для узлов ненаправленного графа можно записать первый закон Кирхгофа, а для контуров - второй закон Кирхофа.
Узел ненаправленного графа
Условное графическое обозначение технического устройства - узлового распределителя физической величины первого рода. В динамике, поток (физическая величина первого рода) любой ветви входящей в узел может менять свое направление.
Ветвь ненаправленного графа
Участок цепи ненаправленного графа, для которого координата первого рода имеет неизменное значение. Ветвь ненаправленного графа содержит условное графическое обозначение одного технического устройства или нескольких, но инкапсулированных в один модуль.
Контур
Для направленных и ненаправленных графов, это замкнутый путь проходящий через несколько узлов и ветвей.
Координата первого рода (through variable3)
Отражение в модели той из парных физических величин (чье произведение есть мощность), которая фиксируется датчиком, установленным в разрыв любого подвода энергии к модулю динамической системы. Во всех энергетических доменах физические величины первого рода подчиняются первому закону Кирхгофа.
Координата второго рода (across variable3)
Отражение в модели той из парных физических величин (чье произведение есть мощность), которая фиксируется датчиком, подключеным между любыми двумя подводами энергии к модулю динамической системы. Во всех энергетических доменах физические величины второго рода подчиняются второму закону Кирхгофа.

Приложение А. Таблица соответствия физических величин (координат) первого и второго рода энергетическому домену

Энергетический домен | Координата первого рода |  | Координата второго рода
Электрический | электрический ток | i [А] | электрическое напряжение | u [В]
Магнитный | магнитный поток | Ф [Вб с-1] | магнитное напряжение | H l [А]
Температурный | тепловой поток | Ф [Дж К-1 с-1] | температура | q [К]
Гидравлический | поток объема (расход) | Q [м3 с-1] | давление | p [Н м-2]
Акустический | поток объема (расход) | Q [м3 с-1] | давление | p [Н м-2]
Механический | сила | F [Н] | скорость | v [м с-1]
Ротационный | момент | M [Н м] | угловая скорость | w [рад с-1]

Приложение Б. Таблица названий законов Кирхгофа для разных энергетических доменов

Энергетический домен | Интерпретации законов Кирхгофа
 | Постулат Непрерывности | Постулат Совместимости
Электрический | первый закон Кирхгофа | второй закон Кирхгофа
Магнитный | непрерывности магнитного потока | Закон Ампера о магнитной цепи
Температурный | обратимого равновесия энтропии | zeroth закон термодинамики
Гидравлический | закон сохранения массы | принцип суперпозиции давления
Акустический | закон сохранения массы | принцип суперпозиции давления
Механический | динамического равновесия сил | принцип суперпозиции движеня
Ротационный | динамического равновесия моментов | принцип суперпозиции движеня

Приложение В. Таблица вариаций форм записи закона Ома в каждом энергетическом домене

Энергетический домен | Название технического устройства и формулировка закона Ома
 | активный элемент | реактивный элемент 1 | реактивный элемент 2
Электрический |  |  |
Магнитный |  |  |
Температурный |  |  |
Гидравлический |  |  |
Акустический |  |  |
Механический |  |  |
Ротационный |  |  |

Приложение Г. Таблица физических законов, связывающих физические величины (координаты) первого и второго рода разных энергетических доменов

Домен |  | 1 | 2 | 3 | 4 | 5 | 6 | 7
Электрический | 1 |  |  |  |  |  |  |
Магнитный | 2 |  |  |  |  |  |  |
Температурный | 3 |  |  |  |  |  |  |
Гидравлический | 4 |  |  |  |  |  |  |
Акустический | 5 |  |  |  |  |  |  |
Механический | 6 |  |  |  |  |  |  |
Ротационный | 7 |  |  |  |  |  |  |

Литература

  1. Остапенко А. Г. Анализ и синтез линейных радиоэлектронных цепей с помощью графов: Аналоговые и цифровые фильтры. - М.: Радио и связь, 1985. - 280 с., ил.
  2. Кадыров А. А. Динамические графовые модели в системах автоматического и автоматизированного управления. -Ташкент: Фан, 1984. - 239 с. :ил.
  3. Зыков А. А. Теория конечных графов. - Новосибирск: 1969.

Узловая Продольная Вынуждающая Потенциальная Пересекающая Силова, сквозная поточная

1) Для каждого энергетического домена разработаны альтернативные, матричные методы расчета соответствующих систем. Например, в электрическом домене к ним относятся: "Метод контурных токов", "Метод узловых потенциалов" - они тоже могут использоваться для составленя графов. Вспомним цель разработки этих методов. Она состояла только в одном - в сокращении размерности системы уравнений, причем за счет отдаления описания от физического смысла. Компьютерное моделирование понижает ценность этих методов, поэтому для унификации подхода рекомендуется составлять графы согласно методу расчета, использующему первый и второй законы Кирхгофа.

2) И для одного энергетического домена закон Ома может иметь несколько форм записи. Например, для электрического домена формула закона Ома отлична для активного сопротивленя, индуктивного и емкостного.

3) Здесь не рекомендуется использовать дословный перевод терминов across and through variables, как поперечная и продольная переменные (координаты или физические величины). В русском языке, для данной тематики, такой перевод вносит путаницу на уровне интуитивно воспринимаемых оттенков.

3.04.2002


УДК 519.8(07) K493

УДК 519.876.5(075.8)+519.711.3(075.8)+530.17(075.8)
K493

Клиначёв Н. В. Основы моделирования систем или 7 доменов законов Ома и Кирхгофа: Избранные фрагменты. - Offline версия 3.4. - Челябинск, 2000-2004. - 88 файлов, ил.

Учебное пособие предназначено для студентов технических специальностей изучающих курсы "Основы моделирования систем", "Моделирование систем управления", "Основы теории подобия". В качестве дополнительной литературы пособие рекомендуется изучающим дисциплину "Теоретические основы электротехники", а так же подобные ей: "Теоретические основы механики линейных и ротационных перемещений", "... магнитных цепей", "... теплотехники", "... гидро и пневмопривода". В пособии описаны основные технологии компьютерного мультидоменного моделирования, методы анализа моделей, раскрыты главные идеи и алгоритмы функционирования широко известных программ математического моделирования динамических систем: VisSim, Simulink (MATLAB), SystemBuild (MATRIXx), Anylogic (Model Vision Studium), MBTY, 20-sim, ITI-SIM, DyMoLa, SIMPLORER, DYNAST, hAMSter, Easy5, DASE и др.

Ил. 56, табл. 2, моделей 19, список лит. - 4 назв.

Клиначёв Николай Васильевич © Н.В. Клиначёв, 2000-2004.


Типовые динамические звенья

Южно-Уральский государственный университет
кафедра Электротехника

Предмет: ТАУ
Тема: Типовые звенья

Для активизации программы
нажимайте цифры мышкой
или используйте клавиатуру

h(t)

Разработчики:

Клиначёв Николай Васильевич
e-mail: klinacherv_nv@mail.ru


Идентифицируйте частотные свойства безинерционного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства апериодического звена первого порядка.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства апериодического звена второго порядка с не равными постоянными времени.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства апериодического звена второго порядка с равными постоянными времени.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства колебательного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства консервативного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства интегрирующего звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства интегрирующего звена с замедлением.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства изодромного звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства дифференцирующего звена.

ЛАЧХ & ЛФЧХ


Идентифицируйте частотные свойства дифференцирующего звена с замедлением.

ЛАЧХ & ЛФЧХ


Идентифицируйте переходную функцию безинерционного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию апериодического звена первого порядка
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию апериодического звена второго порядка
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию колебательного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию консервативного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию интегрирующего звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию интегрирующего звена с замедлением
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию изодромного звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию дифференцирующего звена
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Идентифицируйте переходную функцию дифференцирующего звена с замедлением
(при отсутствии таковой нажмите цифру 9).

Переходные функции h(t) типовых динамических звеньев
входное воздействие было задержано на 0,001 с


Укажите передаточную функцию безинерционного звена.


Укажите передаточную функцию апериодического звена первого порядка.


Укажите передаточную функцию апериодического звена второго порядка с не равными постоянными времени.


Укажите передаточную функцию апериодического звена второго порядка с равными постоянными времени.


Укажите передаточную функцию колебательного звена.


Укажите передаточную функцию консервативного звена.


Укажите передаточную функцию интегрирующего звена.


Укажите передаточную функцию интегрирующего звена с замедлением.


Укажите передаточную функцию изодромного звена.


Укажите передаточную функцию дифференцирующего звена.


Укажите передаточную функцию дифференцирующего звена с замедлением.


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите сопрягающую круговую частоту апериодического звена (1).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400
12) 800 Pi


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите сумму постоянных времени апериодического звена второго порядка (2).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите круговую частоту для резонансного пика колебательного звена (3).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400
12) 400 Pi


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите постоянную времени консервативного звена (4).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400
12) 1/628


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи консервативного звена (4) в области низких частот.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент усиления интегрирующего звена (6) или его круговую частоту при единичном коэффициенте передачи.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи интегрирующего звена (6) на частоте 10 рад/с.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите постоянную времени интегрирующего звена с замедлением (7).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи для горизонтального участка ЛАЧХ изодромного звена (8).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите постоянную времени дифференцирующего звена с замедлением (5).

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


По реакции h(t) типового динамического звена на ступенчатую функцию 1(t) можно оценить параметры его передаточной функции или частотные свойства.
Определите коэффициент передачи дифференцирующего звена с замедлением (5) в области высоких частот.

Переходные функции h(t) типовых динамических звеньев 1) 0,001
2) 0,004
3) 0,005
4) 0,01
5) 0,5
6) 1
7) 2
8) 10
9) 100
10) 200
11) 400


Укажите структурную схему безинерционного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему апериодического звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему апериодического звена второго порядка
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему апериодического звена второго порядка с равными постоянными времени
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему колебательного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему консервативного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему интегрирующего звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему интегрирующего звена с замедлением
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему изодромного звена
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему дифференцирующего звена, с минимально возможным замедлением при моделировании на ЦВМ
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Укажите структурную схему дифференцирующего звена с замедлением
(при отсутствии таковой нажмите цифру 12).

Структурные схемы типовых динамических звеньев. Остановить можно кнопкой браузера, запустить вновь - мышкой


Определите коэффициент усиления апериодического звена второго порядка (3).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите сумму постоянных времени апериодического звена второго порядка (3).
Задумайтесь, почему этот вопрос методически несовершенен.

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления колебательного звена (5).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите круговую частоту - q для резонансного пика колебательного звена (5).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления консервативного звена (6).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления изодромного звена (9) (для области интегрирования).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите пропорциональный коэффициент усиления изодромного звена (9).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления дифференцирующего звена (10).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите постоянную времени дифференцирующего звена с замедлением (11).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент передачи дифференцирующего звена с замедлением (11) в области потери дифференцирующих свойств.

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Определите коэффициент усиления дифференцирующего звена с замедлением (11) (для области дифференцирования).

ЛАЧХ и ЛФЧХ типовых динамических звеньев 1) 0
2) 0,01
3) 0,0316
4) 0,1
5) 0,316
6) 1
7) 1,01
8) 3,16
9) 10
10) -> oo

остановить анимацию можно кнопкой "Stop" браузера


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция не имеет корней.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет отрицательный вещественный корень-полюс.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два не равных отрицательных вещественных корня-полюса.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два равных отрицательных вещественных корня-полюса.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два сопряженных комплексных корня-полюса с отрицательной вещественной частью.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет два сопряженных чисто мнимых корня-полюса.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-полюс.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой и отрицательный вещественный корни-полюсы.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-полюс и отрицательный вещественный корень-ноль.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-ноль.

ЛАЧХ и ЛФЧХ


Какими частотными свойствами должно обладать типовое динамическое звено, если его передаточная функция имеет нулевой корень-ноль и отрицательный вещественный корень-полюс.

ЛАЧХ и ЛФЧХ


Технология создания тестов

Для ознакомления и перенятия технологии создания данного ресурса выполните действия:

  1. С помощью утилиты "Microsoft HTML Help Workshop" декомпилируйте данный файл на составляющие.

  2. Методом подобия, вооружившись любым HTML-редактором, измените содержание html-страниц.

Примечание 1: После декомпиляции данный ресурс полностью функционален и запускается в любом браузере.

Примечание 2: Утилиту "Microsoft HTML Help Workshop" можно закачать бесплатно с сайта корпорации Microsoft (если адрес изменится, рекомендуется искать файлы htmlhelp.exe и hhupd.exe).

Примечание 3: Ресурс полностью функционален и запускается браузером MSIE, если в адресной строке набрать: mk:@MSITStore:C:\TAU\tau_test.chm::/js/start.html - где C:\TAU\ - путь к файлу tau_test.chm.

Примечание 4: Содержимое данного ресурса является собственностью автора Клиначева Николая Васильевича и его репродуцирование (воспроизведение) любым способом без согласия автора запрещается.

Вернутся к выбору темы


< 1 > < 2 > < 3 > < 4 > < 5 > < 6 > < 7 > < 8 > < 9 > < 10 > < 11 > < 12 > N


КОЛЛОКВИУМ ПО ТАУ

Результаты тестирования оцениваются следующим образом:

1. Первоначально программа задает 5 вопросов. Решение принимается в соответствии с таблицей.

Количество правильных ответов (на пять вопросов) | Оценка
5 | 5
4 | 4
3 | дополнительно задается два вопроса
2 | 2
1 | 1

2. Если на 5 вопросов студент дал 3 верных ответа - дополнительно задается 2 вопроса. В результате оценка может остаться без изменения, быть повышена или понижена на один бал.

3. Если студент неверно отвечает на три вопроса подряд - программа прекращает тестирование.

Вернутся к выбору темы


ТАУ: Контрольно-тестирующая система V 3.4

ИНТЕРНЕТ-КОЛЛОКВИУМ

681.5(07)
K493

Н.В. Клиначёв
ТАУ
Контрольно-тестирующая система

VisSim & Лабораторные по ТАУ

Offline версия 3.4
для вузов

Челябинск 2000

ТЕМЫ

1. Типовые динамические звенья
2. Законы и принципы регули-ния
3. Анализ устойчивости САР
4. Оценка качества регулирования
5. Повышение точности САР
6. Коррекция САР
7. Синтез САР

[Как сделано]
[Правила оценки знаний ]

© Н.В. Клиначёв, 2000-2001. Все права защищены


ТАУ: Контрольно-тестирующая система V 3.0

УДК 681.5.01(076)
K493

Клиначёв Н. В. Теория систем автоматического регулирования и управления: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 2000. - 102 файл, ил.

Учебное пособие ориентированно на использование преподавателями в учебном процессе для контроля знаний студентов технических специальностей, изучающих курсы "Теория систем автоматического регулирования и управления" (ТАУ), "Моделирование систем управления" и им подобных. Для самостоятельной проверки уровня своих знаний оно рекомендуется студентам очной и заочной форм обучения.

Ил. 23, вопросов 77.

© Н.В. Клиначёв, 2000-2001. Все права защищены

Вернутся к выбору темы


Сообщение об оценке

Вы не готовы к коллоквиуму –
неверно ответили на три вопроса подряд.
Дальнейшее тестирование нецелесообразно


Сообщение об оценке

Вы ответили на
1


Сообщение об оценке

Вы ответили на
2


Сообщение об оценке

Вы ответили на
3


Сообщение об оценке

Вы ответили на
4


Сообщение об оценке

Вы ответили на
5